Samba connecting outside of domain

I’m running a clean install of openSUSE 13.1 x64. If I open Dolphin and navigate to smb:/ I can access PC’s through domains. Any PC I can connect to using this method I can also access by IP, such as smb:// The issue I run into is I need to connect to IBM iSeries systems on their IFS which was compatible with Samba on my last install of openSUSE 12.2. Since these are not on domains I use the syntax smb://user@ and I get “Timeout on server”. I want to mount these servers to local directories, which I also did before using sudo mount -t cifs // /home/user/smb/sa -o username=<username>,password=<password> but since the upgrade I now get “mount error(6): No such device or address”. I have started using active directory for authentication, and my PC is not a domain controller, but I have tried creating a local user and still run into the same issue.

After looking into it I think we’re running into this bug:

It seems that the system I’m trying to connect to is running an old version of Active Directory (IBM iSeries NetServer) that is only compatible with Samba 2 or 3. To test try this:

smbclient --list <server name or ip>

After typing my password I get this:

Conversion error: Incomplete multibyte sequence()
protocol negotiation failed: NT_STATUS_INVALID_PARAMETER

As a short-term workaround I’m going to VM 12.3 so I can run Samba 3.6 and use it as a sort of buffer to span the large version gaps. Has anyone successfully accessed old Samba servers from openSUSE 13.1?