SAMBA and host names in local network

Hello, I have a little problem on my local network; I have some windows PCs and my Opensuse 15.2 PC.
I can access windows shared folder only typing manually the full path with ip, host name doesn’t work smb://192.168.x.x…
The Kde (dolphin) window in network\SMB shared shows me only our NAS server, and It’s another linux machine.
What should I do? This happen with firewall turned off too.
Thanks a lot!

This is simply a name resolution problem (converting host names to IP addresses).
Normally this is provided by your LAN’s DNS but it’s unlikely you’ve set up your SAMBA server specifically in the DNS of your Residential Gateway Router (I assume you’re running a SOHO network and not something larger).

So, if you have control of your LAN DNS, that’s the first thing ou can try doing… Today most devices on a network are automatically detected by Residential Gateway Routers but assigned random names, no names at all or create an entry using the Hostname braodcast by the machine (which could mean your SAMBA server is not configured appropriately YaST > Network Settings > DNS/Hostnames tab).

Maybe your LAN DNS won’t permit you to modify its entries,
Then maybe in a tiny network of no more than about 3 machines you won’t mind configuring each individual machine by hand.
If this is your situation,
Then you can create an entry in your /etc/hosts file either directly with your choice of text editor or using the YaST module of that name.
Use one of the existing entries as your template and create an entry using the hostname you want to use and IP address. Since the /etc/hosts file is always read before any other name resolution method, your entry should easily infrom your machine what the SAMBA server’s IP address is.


Further to tsu2’s comments, you can also use Avahi name resolution (assuming firewall configuration allowing). That is often a convenient mechanism to use in small networks.

You should also know that if using KDE Plasma 5.18.x with Dolphin 20.04.0+ , the WS-Discovery protocol is now used to enumerate Windows hosts on the LAN (along with Avahi for Linux samba hosts)…

I’m using openSUSE Leap 15.2 with the KDE installed via KDE repos (currently KDE5.18.5)…

In addition to this I have wsdd2 installed (which allows Windows hosts to discover Linux samba hosts)…

Thanks, I will try soon :slight_smile: