Safest way to get current Firefox on Leap?


Could anyone tell me what would be the safest and recommended way to get current Firefox on Leap?


Maybe not to much on-topic, but you choose LEAP 42.3 as your title prefix and your signature says “Running openSUSE Leap 42.2”.

A bit confusing :slight_smile:

Fixed :wink: Thanks!


You are aware of the fact that now all your old posts about earlier versions of openSUSE show Leap 42.3 in your signature?

BTW, you may want to explain what you mean with the current version of Firefox.
I would say that the current version of Firefox for Leap 42.3 is the one offered in the official Leap 42.3 non-OSS repository and the belonging Update repository. But it is so obvious to install that (and it is probably already done at installation and updated with your regular YOU or zypper patch), that I guess you mean something different.

As far as I know, I am running current firefox on Leap.

Specifically, I am running firefox-esr 52.5.2. And, as far as I know, that is current.

I assume you are really asking about the non-esr release. I have temporarily enabled the mozilla repo

I’ll note that firefox 57.0.1-3.1 is available in that repo. However, I’ve decided to stick with the “esr” version for now. So I can’t report experience with installing 57.0.3. For now, I’m disabling that mozilla repo.

There’s a similar mozilla repo for Tumbleweed. When I last checked, that did have the firefox-esr version available. However, for now, my practice is to only run “firefox” on Leap, though I have experimented with the 57.0* version in a VM.

I did a short Firefox version 57 “install and see” on a Leap 42.3 system – to be perfectly honest, from my view of the world, it didn’t perform as well as the default “ESR” version and, wasn’t quite the same as Firefox “latest” (version 57) on Redmond systems.

I have noticed that, the Mozilla Firefox folks are planning to offer version 59 as an “ESR” version – which I suspect means that, for happy Firefox browsing we should be patient and wait . . .

as nrickert said you can get Firefox 57 from the mozilla repo
you should do a full vendor change to that repo (if you already have firefox installed)
the only issue I found is with a java package so be careful or java might get uninstalled the solution is to ignore the java dependencies as java support has been removed from Firefox 57
the easiest way to get Quantum on 42.3 LEAP would be

zypper ar -f mozilla
zypper dup --from mozilla

when you get a warning regarding java headless chose ignore dependencies as the other 2 options would be to remove java or to keep Firefox-esr
I’ll say it again Quantum does not have java support so ignoring java dependencies has no issues on either Firefox or java

I did some tests on my old system and Firefox quantum did preform only slightly better then ESR so I’m not sure the addon loss is worth the speed gain
the people behind PaleMoon forked Firefox 55 and are offering a browser based on pre-Quantum Firefox code they’re calling their new browser Basilisk they do have a static Linux build but it’s in a tar ball no rpm package
it does have a build-in update capability and should go in your home dir and while it’s profile format is based on FF55 it does not use your Firefox profile dir so you can have both Quantum and a pre-Quantum based browser running in your system
you can copy your Firefox profile in your Basilisk profile dir or use Firefox sync and sync-up both browsers so you can share your bookmarks and logons

I should add that you can get Quantum as a binary blob from Mozilla
and unpack it somewhere in your $HOME but the mozilla build lacks opensuse’s kde integration and the profile format used in esr changed and is not compatable with quantum and as mozilla’s build will upgrade and use your current profile from ~/.mozilla you will experience issues with ESR so you can’t run both ESR and Quantum on the same device the only way arround this would be to use multiple profile folders (using the -p switch) or use Basilisk instead of ESR as it will use a different profile dir

  1. Download from
  2. Unpack: cd /home/karl/Downloads; tar xfv firefox-57.0.2.tar.bz2
  3. Close installed Firefox
  4. Invoke: /home/karl/Downloads/firefox/firefox
  5. If not satisfied revert to installed version
  6. If OK modify your program starter: Properties > Application > Command: /home/karl/Downloads/firefox/firefox %u

kind of but no cigar as Firefox 57 will upgrade your profile and then Firefox 52 will end up with a broken profile
the safest way would be to backup your current Firefox profile so if things go wrong you won’t loose your logins, favorites and addons, Quantum will block all of your xpcom addons so before doing anything make a backup of your profile
I usually use 7zip for compression

7z a ~/Documents/Firefox_backup.7z -r ~/.mozilla/*

should compress your Firefox profile in your Documents folder as a 7zip archive named Firefox_backup
or just make a copy of it

mkdir ~/Documents/FirefoxBackup
cp -r ~/.mozilla ~/Documents/FirefoxBackup 

then you can safly play with Firefox versions
just keep in mind in Mozilla’s ayes xpcom and xul are dead and Firefox-ESR is a stop gap solution as it’s support ends in less then 6 months so sooner or latter you’d have to move to Quantum

I actually performed the above with Tumbleweed then still using Firefox 52.5.0 and found no problems when reverting from Firefox 57 to 52.5.0. However having a backup is always a good idea. Since I moved the home directories to SSD I am issuing rsync -a /home/karl /home-HDD/karl to mirror existing files on HDD before tinkering.

Anyway item #3 should read:

  1. Close installed Firefox and backup ~/.mozilla

I do believe the profile format changed with Firefox 54 there’s another change planned with Firefox 58
if you forget to do a backup there is a way to get the profile working by doing a refresh but that will remove all preferences and addons so I don’t really recommend it
but we’re getting off topic imo the best way to get Firefox is from the mozilla repo and ignore the java warning during the vendor change using a binary blob from mozilla might damage your profile (using 52 and 57 with the same profile is not recommended)

As described above adding the repo and installing Firefox Quantum is straight forward:

zypper ar -f mozilla
zypper dup --from mozilla

What are the steps needed to revert to the previous version?

scrap that as that will upgrade Thunderbird and SeaMonkey to the mozilla build too (I’m not sure which versions)
better use yast and the versions tab for both 52->57 and 57->52 switch
you’d need to add the mozilla repo tho so just do the first step

zypper ar -f mozilla 

then start yast search for Firefox in the versions tab select 57.0.3 and ignore the java headless earning


tried to install latest firefox and got
A780GM-m3<2017-12-28 10:15:58><rpms>… sudo rpm -Uhv --test MozillaFirefox-57.0.1-3.1.x86_64.rpm
[sudo] password for root:
error: Failed dependencies:
MozillaFirefox-branding > 44.0 is needed by MozillaFirefox-57.0.1-3.1.x86_64
mozilla-nspr >= 4.17 is needed by MozillaFirefox-57.0.1-3.1.x86_64
mozilla-nss >= 3.33 is needed by MozillaFirefox-57.0.1-3.1.x86_64 is needed by MozillaFirefox-57.0.1-3.1.x86_64 is needed by MozillaFirefox-57.0.1-3.1.x86_64
A780GM-m3<2017-12-28 10:26:21><rpms>…

also tried via yast with similar result

the following worked,

deleted prior firefox install, 3 packages, and flash, 2 packages

unpacked firefox-57.0.2.tar.bz2 (from mozilla web site) and copied the unpacked directory firefox into /opt/

for videos, installed via yast flash-player-npapi- (from Adobe web site) ignored warnings

is this safe? maybe, but it is much faster!


you got those rpm errors because Firefox isn’t packaged in a single rpm that’s why you needed the mozilla repository (and I originally recommended a vendor change)
putting the unpacked binary in /opt is another bad idea as you’ll have to run it as root to keep it updated or you’ll get update errors (running a GUI app as root is a way to bork your system)
another thing is that the mozilla blob does not have the plasma 5 integration that comes from opensuse
my recommendation is add the mozilla repo delete that dir from opt and get your updates from opensuse
so no that’s not the easiest way to get quantum

You may open a root shell and try:

zypper ar -f mozilla
zypper in --from mozilla MozillaFirefox

regarding the profile format apparently Mozilla changed the profile with Firefox 55
so by running Quantum once it doesn’t matter if installed as an rpm or a tar ball your profile will be upgraded and you will have issues going back to ESR
that being said backup ie compress or copy your profile before doing anything
if you forget to backup a refresh should make your profile accessible to ESR (but you will loose all addons and configs)

… is that why you prompted him to make the change? To confuse him? Hahahaha. :smiley: