Sabnzbd server

A 1-click install for sabnzbd exists but some dependencies are missing. So it does not work. Does anybody has a working sabnzbd server setup and if so, can you give me some info on where to find the solutions? It’s the only thing missing. Latest tumbleweed with kde.

Where did you get this “one-click install” for Tumbleweed?
It sounds odd as Sanzbd is a Python script. Have you read the installation wiki?

I’ve read the wiki. The 1-click install is on Do a search for sabnzbd. It’s there.

Then you will be aware that it recommends that Unix and Linux users install from the developers tarball.

I can not find an openSUSE signed package.
There is one in Eric Schirra (ecsos)'s personal repository. You have presumably discovered that his RPM spec file lists several dependencies that cannot be satisfied from either his own OBS or the openSUSE Tumbleweed (or Leap) repositories. As he does not appear to provide any copyright or contact information, perhaps this is not intended for general distribution.

Last time I helped someone with sabnzbd, we dowloaded from their site, then set it up as instructed. Works fine.

Thanks for your patience. I managed to get it up and running fine, following the instructions and compiling. The offered package is not signed. I agree that it is probably for personal use only. Right now I’m trying to create a systemd startup file for sabnzbd. It’s a little harder than expected though. :wink:

I followed the instructions. Did some compiling. Had some trouble with the different python versions but worked it out. It’s running fine within my personal account. What I’m trying to achieve at this moment is create a systemd startup file. That’s a little harder than I’d expected though. :wink:

IIRC Sabnzbd comes with some systemd service unit, where only the path needs adjusting. It’s in SABnzbd/linux

I could not find this startup script (systemd) on the sabnzbd site. However, I found one on the Fedora forums that works perfectly fine. So, my problems are solved :wink: