Running Skype 2.1 beta with KDE 4.3


I’m trying the new Skype Linux Beta ( Skype ) with KDE 4.3 from


. Sound works just fine for:

  • Amarok
  • SMplayer
  • Firefox (flash)

but I get absolutely no output from Skype. Please note that this new version is supposed to work with PulseAudio, so the sound devices are all “PulseaAudio server(local)”.

My PulseAudio version is pulseaudio-0.9.14-2.2.1 and KDE is using the Phonon GStreamer backend.

Any instructions on how to proceeed would be greatly appreciated

But have you tried using xine backend? I mean globally too. Unfortunately I don’t use Skype so I can’t test it.

Thanks for your answer. I installed the Xine backend and it’s not preferred over GStreamer in KDE, but I get the exact same behaviour from the 3 test apps and Skype.

If you have basically flawless sound in openSUSE generally, I would head over to the Skype forum and see if you can find out anything there. Assuming there is a forum, and or the Skype wiki/help pages

> . Sound works just fine for:
> - Amarok
> - SMplayer
> - Firefox (flash)

are any or all of those dependent on pulseaudio? i think not
(because i think if you uninstall pulseaudio they will all continue to
work)…therefore the fact that you have sound out of them has no
bearing on your problem…

there is a forum for pre-release software at both Skype and here…

here it would be

says you should “Give the version a go and send your feedback
to our JIRA, comments to this post and to our forums.”

i’ll leave it to you to find JIRA and read the many comments on that
page already, and add you own, if needed…

and, their forums are at:

Give a hacker a fish and you feed him for a day.
Teach posting to the correct place and you feed him for a lifetime.

Right, they should not depend on PA, but I assumed an immediate question would be ‘does sound work at all?’.

I thought that this was a forum for pre-release OpenSUSE versions, not pre-release Skype, so I ended up in multimedia. A moderator should move this post if this is not the right place for it.

I’ve already went through those posts, both the blog and the forum. I came here since I hoped to find someone with a configuration similar to mine, since I believe it’s rather a pulse configuration issue than a Skype one.

Hopefully I’ll sort it out on the Skype forums, thanks.

Have you been testing Skype audio using Skype’s Options > Sound Devices >
“Make a test sound” button ?

If so, then I have the same problem (openSUSE 11.1 x64, KDE 4.3, latest alsa
drivers and utilities from Alsa repo’s, Skype 2.1 beta -

The “Make a test sound” button does not work for me at all.

However, the “Make a test call” works just great.

I am using a Plantronics USB headset.

I have the pulseaudio lib’s, but that’s all - I removed what I could of
pulseaudio some months ago and I don’t know what backend Skype is using for
audio now - probably Xine from the Packman repo.

Going to pulseaudio 0.9.15 solved the ‘hearing’ problem for me, but I still can’t capture. I have just a plain headset.

As a general mic functionality test, can you capture with

arecord -vv -fdat foo.wav

and then replay foo.wav with any player.

Microphone - openSUSE

Actually I can’t, so it’s not pulse at fault here, I need to tweak my sound card settings.

> head -n 1 /proc/asound/card0/codec*
Codec: Realtek ALC889A

Thanks for the wiki link, I did not find that particular page initially. I’ll just dig in an try to find which of the knobs to turn.

On my laptop there are two mics - the internal one and the jack that you plug the external mic into. I can switch between them using alsamixer. In a terminal type:

alsamixer -c0

Tab to “capture” and then arrow to “Input So”. Up/down arrow will select between sources. Then make sure the capture level is all the way up.