Running a JavaFX-requiring Java applet

I’m trying to run a java applet using openjdk 8 and icedtea. Unfortunately the app requires JavaFX and fails because it can’t find it.
I’ve installed openjfx8 but it doesn’t seem to make a difference:

java.lang.NoClassDefFoundError: javafx/application/Platform
        at com.quotemedia.quotestream.C.C.E(Unknown Source)
        at com.quotemedia.quotestream.C.C.doInBackground(Unknown Source)
        at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at javax.swing.SwingWorker.run(SwingWorker.java:334)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.ClassNotFoundException: javafx.application.Platform
        at net.sourceforge.jnlp.runtime.JNLPClassLoader.loadClass(JNLPClassLoader.java:1644)
        ... 8 more

The applet is launched thusly:

env JAVA_HOME=/usr/lib64/jvm/jre-1.8.0-openjdk javaws.itweb qs.jnlp

Everything works until the javafx-missing crash.

I guess my question is, is there a way to include javafx in my class path during javaws execution.
I’ve tried various arguments to javaws but it doesn’t seem to be the way to go.

Thanks!

Try the current version of java. Complete versions are available: https://bell-sw.com/pages/repositories

I currently use “bellsoft-java13-runtime-full” which contains the full Liberica JDK, including JavaFX and a variety of JVMs for platforms that support it.

It worked! I have to use version 8 because even 11 doesn’t work, let alone 13, with this applet. Ironically it complains about requiring version 9+ but I guess they never did get to 11…
Anyway, thanks for that. Success!

IF it is just checking the name…

Earlier for self creating a link worked for self when inxi could not find lsb-release would it work for ?

Example:
meaning of the command: ln -s ExistingSourceFile CreatedLinkFile
with
how self linked to use: ln -s /etc/os-release /etc/lsb-release

Read the help: ln --help

Note:
If you delete the source file or move it to a different location, your symbolic file will not function properly. You should either delete or move it. If you try to use it for other purposes (e.g., if you try to edit or execute it), the system will send a “file nonexistent” message.

.

I’m pretty sure that the file content would be wrong.

Just install the “lsb” package, which includes the file “/etc/lsb-release”.