RTL8821ce Tumbleweed

Looks like this is still borked. Using Sauerland repos but module not loading.

Operating System: openSUSE Tumbleweed 20191023
KDE Plasma Version: 5.17.0
KDE Frameworks Version: 5.63.0
Qt Version: 5.13.1
Kernel Version: 5.3.6-1-default
OS Type: 64-bit
Processors: 8 × AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
Memory: 7.4 GiB of RAM

HP 15-db0009ng

Really gnarked that I have to revert to Windows 10 to use WLAN
Suggestions welcome.

Hi
Patience is the fix… I’m assuming from the Sauerland:hardware repository, it has only just rebuilt for the 5.3.6 kernel and has not been published yet…

https://build.opensuse.org/package/show/home:Sauerland:hardware/rtl8821ce

Problem is OBS not publishing the build packages…

Maybe rebuild it by your own with the src.rpm.

Hi
And now at 5.3.7, time to trigger a rebuild :wink: and hopefully publish.

@OP, as suggested I would grab the src rpm and rebuild locally…

Everything comes to him who knows how to wait. Prior to duping always check Sauerland repo for supporting the new kernel. Since sticking to that the driver works without any annoyances.

New kmp is published.

Hello,

I think I have to reawaken this thread,
yesterday I dup’ed my Tubleweed on a HP17 with this rtl8821ce chip and it didn’t load into the new kernel.

It worked fine all the other dup’s I did with the Sauerland repo

Kernel version here now is 5.11.4 and when I try to zypper in rtl8821ce then there is a missing dependency for kernel-uname-r 5.11.2
It seems to me that there is some kernel header file mismatch or whatever.

Did I update too early?

regards

Kernel version here now is 5.11.4 and when I try to zypper in rtl8821ce then there is a missing dependency for kernel-uname-r 5.11.2
It seems to me that there is some kernel header file mismatch or whatever.

Without errors I can not see what is going wrong…

The packages are not delivered for kernel 5.11.4…
https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Tumbleweed/

Thank you, it now works again.