rtl8188eu net usb driver fail after uprade

The usb dongle has work in 15.1, 15.2, 15.3. Failed after “zypper dup…” upgrade to 15.4 which otherwise appeared to complete with no problems.

Yast identifies it as “rtl8188eus”. Yast scans existing wifi AP’s or at least appears to.

lsmod shows driver “r8188eu” installed but says “0” programs use it. Two other modules listed show as used by r8188eu.

15.1 (IIRC - maybe 15.2?) required that rtl88xxxu be blacklisted. I tried creating the blacklist file for this 15.4 upgrade, but it does not seem to help.

All thoughts appreciated.



zypper lr -d
zypper se -si rtl8188 r8188

My only net is a phone; I don’t see any text box buttons on the screen so I’m pasting inline. Zypper doesn’t like the “el” in the first command above; it returns “not found” for the 2nd.

Here is text from lsmod.
vsl:/home/rufus/dl # lsmod | grep r81
r8188eu 339968 0
lib80211 16384 1 r8188eu
cfg80211 1040384 1 r8188eu
r8169 90112 0
mdio_devres 16384 1 r8169
libphy 159744 3 r8169,mdio_devres,realtek
usbcore 323584 10 xhci_hcd,ohci_hcd,ehci_pci,usbhid,usblp,ehci_hcd,btusb,xhci_pci,ohci_pci,r8188eu

From yast - System/NetworkSettings with the wifi adapter selected in the device list above.
RTL8188EUS 802.11n Wireless Network Adapter
(Not connected)
MAC : 00:13:ef:8d:3a:8a
BusID : 4-1.4.2:1.0

I don’t remember the name of the driver which worked in the previous Leap versions. I’ll post these list and continue to search.

software.opensuse.org offers the rtl8xxxu as a community package. But it’s name is …src.rpm and I don’t know if yast will handle that. Also, it takes time to get the rpm file onto the linux machine from my phone.

Thank you for your help.

Opening the “…xxx…src.rpm” file in yast kills yast. After I Ignore the signature problem I get a “…too deep…” Ruby error, or yast simply disappears.

It appears that there is no further help. Since I don’t have the familiarity with driver availability and installation to work through this myself in any reasonable time, I hope a different wifi adapter can solve the issue.

Thanks you to those who responded.


You can use rtl8188eu-kmp-default and rtl8188eu-ueficert from here:

Download and install both.

A …src.rpm is the source with all needed patches to build the rpm.
Not to install.