RTAI for Leap 15.4+

Hi all,

I’m looking for some guidance with applying the RTAI patch to a Leap compatible kernel.

I have found this patch “kernel-rtai-4.9.80-lp150.1.22.x86_64.rpm”. What I don’t understand is, how the version numbers relate - the above patch is for leap 15.0, but does that make it suitable for 15.4+?

The instructions say - apply the patch to a vanilla kernel from kernel.org. But what flavour kernals compatible with Leap 15.4+.

Any help would great.

Kind regards

You found it where? Providing link would be helpful.

Guessing what these version numbers are without knowing anything about where you found it is rather hard.

Which instructions?

I’m not sure I understand this question at all. There is one “flavor” of upstream kernel - it is upstream kernel itself. Showing what “flavors” you mean may clarify it.

But briefly looking at RTAI site, the latest RTAI patch version 5.3 supports Linux kernel up to 4.19 if that is what you were asking.

Thank you very much for your reply.

What I’m trying to do is, workout if it’s possible to use LinuxCNC on an up-to-date Leap distro.

My understanding is, that I can install LinuxCNC onto any distro that has the RTAI patch applied to the kernel.

My understanding is, that there are several branches to the RTAI project, some more stable than others.

I did read the following from rtai.org.

May 19, 2021: RTAI 5.3 released
The tarball is available at rtai-5.3.tar.bz2
Supports up to Linux 4.19.

What I don’t know is – Is it hard limited to that kernel version or, is that just because their branch of the project finished at that time. What would have changed in the kernel to make it make it incompatible…

I also found this:-

This is from ‘bosconovic’, built for Leap 15.0, kernel 4.9.80

There’s a link to OpenSUSE (but the folder is empty.):-


My initial 3 questions are:-

  1. Is the bosconovic branch of the RTAI stable?

  2. Can I push an old kernel version (say 4.19) into an up-to-date Leap (I’m assuming – No)?

  3. What is the last version of Leap that can use kernel version 4.19?

Kind regards


And the reason you are asking it on openSUSE forums instead of asking RTAI project?

It is user name on build.opensuse.org

As long as none of the the applications you are using require post 4.19 features - I do not see, why not.

This is the wrong question. openSUSE is not “bring your own kernel” distribution. It is released with specific kernel version and nobody tests “what happens if” you will be using something else. Leap 15.1 came with base version 4.12 and Leap 15.2 came with base version 5.3.

Thanks again for your reply.

I don’t think any of these project are still active. There hasn’t been any activity on their sites for years…

LinuxCNC come as an ISO install – Debian 10, kernel, with RTAI…

LinuxCNC say they are moving away from RTAI because of the lack of support. They are moving towards ‘uspace’, but that will come with a significant drop in performance…

I don’t think my 10 year old, 3GHz, dual core will cope. With the existing attached hardware, It will be a very painful process to upgrade. I’m happy to keep the CNC side of it static until something breaks.

However, there is some CNC software tools that I also want to use on this machine, but they don’t work well under debian. This software runs fine under Tumbleweed. Debian is also problematic when connecting to a NAS – some days it’s fine, others it has the day off!

Yes – I have the dual boot, yes – I have pile of USB sticks, yes – I take my laptop with me… All of which creates a version control nightmare!

My CNC machine is about 50 metres from the my office, some days can be very slow.

On the odd occasion, I have done a project with a Raspberry pi. Recently, I did one where debian was so painful that I installed Leap 15.4 – I had the job done in no time. This project had nothing to do with CNC nor RTAI, and used the supplied kernel.

This got me thinking – can Leap help with this CNC issue.

I’ll create another boot for my CNC PC. I know that kernel works, so I need to have a best-guess at which Leap version to use – any advice?

Is there a guide to replacing the kernel for Leap?

Is it possible to copy the kernel, files & folders, from Debian, and paste it into Leap?

Alternatively, I could install a version of Leap (maybe 15.1) with has closest kernel to, then try to apply the RTAI patch…

Any advice would be helpful.

Kind regards

There is no need to replace, you can have multiple kernels and select one on boot. So just install and test your kernel and if you are satisfied - set it as default in the bootloader configuration.

Yes, I think so. You nee files and directory

/lib/modules/$(uname -r`)
/boot/vmlinuz-$(uname -r)`
/boot/System.map-$(uname -r)
/boot/config-$(uname -r)

($(uname -r) denotes the kernel release). After copying them, run


This should create initrd and add this kernel to boot menu.

1 Like

Hi all,

I haven’t been able to give this project 100%. It’s not complete as yet, so, I thought I would post a progress reports :-

My PC had a partition with Leap 15.5 loaded. As an experiment, I installed the RTAI 4.19 kernel onto it. Initially, I thought I had done something wrong, because it booted with the Debian splash screen, but it did boot as 15.5. It was not happy. Applications like Dolphin were struggling, networks not working correctly… I didn’t bother looking at any logs, thinking there would nothing I could do with what I’d find.

I then used Gparted to remove that partition, and installed Leap 15.1, via USB ISO. It went well until I got to the point where it asks to setup the network. This machine doesn’t have Ethernet (it’s too far away from a port), it uses a USB WiFi dongle (RT5370), about 5-6 metres from the access point (works well with Windows, Debian and Leap 15.5). I couldn’t get Leap 15.1 Setup to connect, so, I allowed it to install via the ISO, and I would do an update later…

It seemed to install okay. About 1/3 through the update it froze, and I had to use the power switch. I tried it again, and it froze again at about the same place.

The WiFi signal strength was showing 65%, this was not right, I was guessing that the RT5370 driver was bad, and that an update may install a better driver…

I found a powered USB hub with a 5metre lead, so could get the antennas very close – it went from 65% to 85%, but enough to allow the update to complete. Unfortunately, the WiFi didn’t improve.

But another problem came up – after around 3-4 minutes of On time the machine would just switch Off, without warning. It was like the power supply in the machine had gone faulty. It was working okay with either Windows or Debian running. I then noticed when I turned the machine back on immediately after it shutdown, the BIOS settings were showing the CPU core temperatures at very high (over 100’C), but cooling down. Using ‘sensors’ under Debian the cores were about 55’C.

It was tricky with a very limited On time to install sensors into 15.1, but when I did, it was showing rubbish – one core at -17’C, another at +21’C… It was time to get Gparted out again…

With the better WiFi signal things went better this time. I have managed to do the updates, but the WiFi is still not good…

I see on the web that there are several replacement drivers for the RT5370, but these are focused on the Debian Raspberry Pi.

Does anyone have a suggested replacement?

Can I find and install the 15.5 driver?

Kind regards

I do not get all what you write (very long story), but I am afraid you miss a bit what these forums (and special the technical help parts of it) are for. They are a user to user help for the current supported openSUSE versions.

Now most of the people here are very kind and helpful and they will try to be of your service even if you come with questions about a long ago version like 15.1 (out of support since 2021-01-31) . And also when you are doing things with it that most of them not even would think about now, let alone in the time that 15.1 was still supported. But please be aware of the fact that for the most of us your situation is far beyond anything they ever tried and can help with.

Change from kernel-tai (RTAI) to kernel-rt (preempt-rt). Kernel-rt is the free of charge version of SUSE Linux Enterprise Real Time. Kernel-rt provide Preempt-rt patches for linux kernel.

Read chapter “Kernel and Version requirements”:

Never, never install a linux kernel which is not supported by SUSE with security updates!

See row “openSUSE Leap 15.5” for a overview of all supported linux kernels from SUSE:

  • More information about Preempt-rt patches for linux kernel:

Thank you for your reply.

I was attempting to explain what I have done thus far. Given Leap 15.1 wasn’t too long ago, some people may still remember it, and have useful advice.


Thank you for that info. The CNC side of what I have is working great – “don’t fix what is not broken”

What doesn’t work so well is the Debian UI, password and network management. I am ONLY looking to fix these issues.

This CNC machine generates a LOT of electrical noise. It is a dangerous machine - a malfunction could cause serious injury or death!

I am definitely NOT interested in using a raspberry pi…

Kind regards

This, not being an openSUSE technical question (the discussion covers a lot of distros and sometimes even openSUSE is mentioned), will be moved to OpenChat.