RT2500 mini-pci (made by MSI) doesn't work with 11.0


I’m going to try and follow the suggestions in the first thread of this topic, e.g. report the problem “properly” :slight_smile:

So, I have MSI RT2500 based wireless card, which worked on Suse 10.0 using the RT2500-1.1.0-b4 serialmonkey drivers.

Here’s the output of lspci:

01:05.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)

and the output of lspci -n:

01:05.0 0280: 1814:0201 (rev 01)

and the output of modinfo rt2500pci:

filename: /lib/modules/
license: GPL
description: Ralink RT2500 PCI & PCMCIA Wireless LAN driver.
version: 2.0.14
author: http://rt2x00.serialmonkey.com
srcversion: A92FDFBB65BEEBE1A7849AA
alias: pci:v00001814d00000201svsdbcsci*
depends: rt2x00pci,rt2x00lib,eeprom_93cx6
vermagic: SMP mod_unload 586

Should mention that unlike many other Ralink chips, rt2500 needs no firmware to function.

dmesg has only two relevant lines:

phy0: Selected rate control algorithm ‘pid’


ADDRCONF(NETDEV_UP): wlan0: link is not ready

lsmod | grep rt

rt2500pci 23040 0
rt2x00pci 14848 1 rt2500pci
rt2x00lib 27392 2 rt2500pci,rt2x00pci
firmware_class 13696 1 rt2x00lib
rfkill 11796 1 rt2x00lib
input_polldev 9096 1 rt2x00lib
crc_itu_t 6144 1 rt2x00lib
mac80211 178328 2 rt2x00pci,rt2x00lib

Next, iwconfig:

wlan0 IEEE 802.11g ESSID:“jjjj”
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr: off Fragment thr=2352 B
Encryption key: xxxxxx
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

So it’s not associated with the accesspoint.

And finally, iwlist wlan0 scan

wlan0 No scan results

Compiling the old module which was known to work fails, too:

/tmp/rt2500-1.1.0-b4/Module> make

make[1]: Entering directory /usr/src/linux-' make -C /usr/src/linux- O=/usr/src/linux- modules CC [M] /tmp/rt2500-1.1.0-b4/Module/rtmp_main.o In file included from /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c:50: /tmp/rt2500-1.1.0-b4/Module/rt_config.h:58:40: error: linux/config.h: No such file or directory /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘RT2500_probe’: /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c:203: error: implicit declaration of function ‘SET_MODULE_OWNER’ /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘RT2500_open’: /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c:343: error: ‘SA_SHIRQ’ undeclared (first use in this function) /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c:343: error: (Each undeclared identifier is reported only once /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c:343: error: for each function it appears in.) /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c:343: warning: passing argument 2 of ‘request_irq’ from incompatible pointer type /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘rt2500_init_module’: /tmp/rt2500-1.1.0-b4/Module/rtmp_main.c:1009: error: implicit declaration of function ‘pci_module_init’ make[4]: *** [/tmp/rt2500-1.1.0-b4/Module/rtmp_main.o] Error 1 make[3]: *** [_module_/tmp/rt2500-1.1.0-b4/Module] Error 2 make[2]: *** [sub-make] Error 2 make[1]: *** [all] Error 2 make[1]: Leaving directory /usr/src/linux-’
rt2500.ko failed to build!
make: *** [module] Error 1

The machine is a AMD Sempron 64bit, but the system installed is 32 bit one.

So, a “success” story >:(, isn’t it? I could add that my D-Link DSB-C300 (OV511) webcam stopped working, too, though I never had ANY problem with it before, it just worked right away. But this is another topic…
Can anyone help?:beat-up:

I don’t have one any more, but, I did have it working with 11.0 before
10.3 & Rt2500 Wireless Howto - openSUSE Forums

Make sure you have kernel-source, kernel-syms, C++, gcc and make installed & that kernel-source & kernel-syms match your running kernel (uname -a) – if not do an update.

Because you have been messing around, do “make clean” prior to starting over.

You have to remove the previous driver at the proper place & modprobe the new driver; then you also have to select it on the card’s config tab in Yast and reboot.

should work:)

Hi snakedriver,

Thanks for the hints, I didn’t have kernel syms package, after installing it nothing changed for the 1.1.0-b4 version, but the CVS version got complied!

I blacklisted the rt2500pci (old builtin) driver, registered the new rt2500 in yast et al, and things got a bit further now.

Namely, I can do iwlist ra0 scan finally, which then lists a few networks, including the one I want to connect to.

But if I simply configure my card to connect to a specified ESSID it doesn’t, namely link quality remains 0 and the AP MAC doesn’t appear in the iwconfig output. Yet if I specify it (the AP MAC to connect) manually or in the config file, things work fine! This is probably out of the scope of this forum, might still be of interest for the driver developers.