root login

Is there a way to have back the root account to be selected in X ?

I use essentially root to develop in different languages and don’t want to be p***d off by sudoing each command I want to do as an admin. I WANT the full power on MY computer.
With LEAP, I can’t log as root in X… I can boot in run level 3 but sometimes I develop with GUI and I WANT to be root to develop.

How can I do that with LEAP ?

It’s not very important as my main development computers works on 12.2 or 13.2 but this test laptop is on LEAP and it’s impossible to work with no root users.

On Fri, 18 Dec 2015 17:06:01 +0000, soundlord wrote:

> Is there a way to have back the root account to be selected in X ?

This is very strongly not recommended.

As I mentioned in your other thread, a basic principle of computer
security is to use the lowest privileges required to accomplish the task
you’re doing.

Logging in as root and using that as your normal user runs a huge risk of
data loss, system instability, and accidental deletion of critical system

Perhaps you come from the Windows world where logging in as
“Administrator” is a normal (but still bad) practice. Linux isn’t
Windows. Practice safe computing, and use the minimum rights needed for
the task you’re doing.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

I know that this is not recommended, but I assume it.
Must I boot on runlevel 3 to have a chance to boot into root account at login ?
Or there is somewhere something I could do to enable it using X ?
For the IDE development in root (the most of my filesystems (remote and local) are root:root set and using IDE in LEAP loads source files in read only mode :{{{{{ or I got access denied (or can not see them) because only root could handle them :{{{{{{{{{{{ )

Extremely bad to log into a GUI as root. Also why are your remote file systems set as root?? How are you mounting them. You absolutely do not need to be root to develop anything. So this sounds like a very very poor set up of your system

If you must live dangerously look at the setting in KDE configure desktop login screen

Personally I’d rethink the set up. You are doing things wrong if you must be root to develop :open_mouth:

Are you sure you aren’t able to login as root?

Depends on your Desktop, but for my LXDE Desktop, I simply select “other,” then type in root and then a password.

That said,
The recommended procedure isn’t to login as root, but to open a window running a root console, just type su, enter and then your password (this is something you can’t do in some other OS like Ubuntu where you have to do something like “sudo su”). You can “full screen” your root console to fully utilize your display, and you can open multiple consoles for greater productivity. You shouldn’t have to init 3, although some “old school” who live in the world of “pre-modern Desktops” might prefer that.

You should have full access to your everything on your system using this root console, besides running commands directly with the root security context, you can also invoke GUI apps with root security context… If the GUI is integrated into the Desktop framework you may need to run something like “kdesu” (for KDE) but if the app is not a Desktop integrated app you can launch directly from the console.

I understand your special needs for a machine doing Development where many things may have to run as root, everything I’ve set up for others and myself can be done as I’ve described. Also, if you’re running some special IDE, there are typically instructions how to set up to run with root security context. If you can’t get that working, then post again here.


Which desktop are you using?

Grand Morning,

I’m KDE, have been for many years. For some tasks I use root on SLES and RHEL. My first try with LEAP was an update from an openSUSE 13.n that was using KDE. I enjoyed using LEAP and I did not have any issues using root via the login.

I then installed a new machine with LEAP and my normal applications. No root login, so looking around I’m told the /etc/sysconfig/displaymanager is the issue as it does not have the “…LOGIN_LOCAL” = Yes. I looked at my old updated machine and sure enough that “displaymanager” file had this and another “KDE_LOCAL_ARGS” which is null… Anyway I popped the file over to the new machine and re-ipl’ed. Bit of a bad hair day, seems the keyword “DISPLAYMANAGER” only likes “sddm” which I have not seen on SLES.

Bottom line, I would like a clean install to allow me to login with root. Having to install openSUSE 13. and then over install with LEAP is not the way I want to go.

I accept all the good words I have read about the dangers, I accept the risks, I have worked this way from the '90 and use SLES that way on my own machines. On our production and development machine that is another world and maint/root/admin are not used.

There are some words about doing what I have done, but it seems that is not the full story. I’m KDE, I have to be use another on SLES now, so I want to see if LEAP is away I can work with KDE and I want to login with root.

Many Thanks, looking forward to the replies, but please no chatter on how easy it can corrupt a environment. It’s my Hardware/Environment let me use it my way.


I have no problems doing it in Leap, so you need to provide more details what you do and what does not work.

Grand Morning,
I have installed on new hardware with the Linux mag’s version of LEAP and a download version from SUSE. Giving KDE as the display manager. I create a user and pass etc and say this is not the admin user. After the install on the 1st run I only loginusing the user/pass of the created user. I can from another machine ssh root@ and that works grand. I do not get any opportunity to login as root on the local machine. Looking at the values in DISPLAYMANAGER the item “…LOGIN_LOCAL” is missing. On SLES you can select “other” and that gives you a root login opportunity. I did a few month back update a running KDE openSUSE 13. environment and that does give me a KDE Displaymanager, on the new environment I get issues if I don’t use “SDDM”, if I use KDM I get a very simple logon screen. Giving root or user into that one gets the screen again. I have to use remote access to amend /etc/sysconfig/displaymanager and re-ipl.
I would expect out of the box would could create a simple KDE LEAP with root user or root logon.

Does this link help?

some other input.

As with other no-frills display managers, you can configure SDDM by editing a file, namely /etc/sddm.conf. There you can enable automatic login, turn Num Lock on, modify which users are displayed on the greeter (login window), and change themes. There’s another way: if you’re using SDDM on KDE, it has a configuration module in System Settings, and there’s also a handy utility called sddm-config-editor.

I read the words and had a look at what I had in /etc/sddm.conf

on hp-dwc01 (new hardware, LEAP install) there is no /etc/sddm.conf file. Displaymanager sddm, window manager is kde4

pn dwc01 (used hardware, opensuse updated to LEAP) there is a /etc/sddm.conf file, the Displaymanager is set at KDM and the window manager has kde4

The words on-line seem to say one does need a /etc/sddm.conf but when / what creates this. Also in that conf file it points to a number of items in /usr.bin/X11/xd* which are also not there in the new LEAP install…

Have not found the items in red on either machine. I can run krunner on dwc01 but on hp-dwc01 it has a bad hair day, lots of issues.

As I need to deliver this new hardware with an OS and applications in the near future I think I’ll back off. Install openSUSE 13.n and update to LEAP. That did work for the other environment and I had a happy root.


Just out of curiosity I fired up my test KDE Leap install in a VM, pretty much a default install AFAIK,
> found the sddm config module at > System Settings > Startup and Shutdown > Login Screen (SDDM)
> chose the Circles Theme instead of the default Breeze one
> rebooted
> at login SDDM offered a box to enter the username, happily accepted “root” and voilà, I was “root on the GUI”

So maybe those not seeing all that might be missing something in their systems, or the very latest updates, which I didn’t apply yet, might have messed up something.
Hope this helps others reading this thread.

PS: I promptly logged out before being banned from the forum for logging in as root in a GUI :wink:

You will not be banned from the forums as long as you make it clear that these type of actions are not to be done by sane persons. :wink:

In earnest, everybody may do to her/his system as she/he likes. But the audience knowledge here varies very much. Thus always make it clear that somethig is bad practice when it is.

Grand Evening,

As I was going to run a re-install of a openSUSE 13 I said why not try it …

The su -c systemsettings5 really got the pulse going, a couple or more screen full of output, but I think it was this that created /etc/sddm.conf which was not there after the install.

When on a roll go with the flow…

I amended my new /etc/sddm.conf as per the good words… I checked what was in /etc/pam.d/sddm and it looked Okay, well what was below was not there…

So with a roll of the bones on the desk, re-ipl and well it was different. I had a whole row of “users” who could / maybe login Grand old root was hiding out on stage left but a mouse found it and glory be, a root login.

I set up the screen and it’s looking Okay.

A lot of all this was to be able to start VMware Workstation the way I like to… and now I can. Yes I do know you can set sudo -E /usr/bin/vmware… I just want to do it, “My way”.

Would I do it again… Probable not, the login screen does look crappy, and I would not like my customers or friends to see it. What did work was a install of openSUSE 13 with KDE etc. Then update that with LEAP-42 which seems to keep the KDE login clean and tidy, until of course some one looking to keep root out fixes that. In English it’s called a Nanny State attitude. You are trying hard to make sure nobody has any bad hair days, but life is a learning exercise, you do need a few hair days, good and bad. I’m 70 in a few weeks and there were weeks in the '90 of very bad days and night, but good learning times. I was also working on the 1sr s390x zLinux environments. IBM BIB created the low-level, SUSE integrated it, SAG tested it. Gave the results back and round and round we went…Good and Bad hair days, character building, no Nanny State.

Many Thanks for your pointers, very good. I hope you have a good week and a grand weekend. Good Rugby this weekend.

I assume you’ve already set up a password for the root account.

First at all, you need to modify /etc/sddm.conf as following:





Second, you need to modify /etc/pam.d/sddm. Be careful! If you don’t pay attention here you will end by locking yourself out from your computer!

You have to comment out the following:
auth required user != root nopasswdloginso that it’ll look like:#auth required user != root nopasswdloginThen uncomment*# auth sufficient user ingroup nopasswdloginso that it’ll becomeauth sufficient user ingroup nopasswdlogin*