*.rmvb on opensuse11 64bits

I’m new to SUSE but former user of ubuntu.
I have the opensuse11.0 64bit install on my PC.
Iread on another thread that user with the 64 system couldn’t play this media format. So i’m having the same problems with the rmvb files.
In Ubuntu there was a w64codec package that solve this problem.
I not a expert or something alike but if the w64codec were install on the system it could work?
In my google research i found this: Medibuntu – Details of package w64codecs in hardy

But i don’t know how to install a tar.gz and don’t have the idea if it works…

help please…

I have a 32-bit opensuse, so I can neither replicate, nor test the solution, for a 64-bit system.

I also note they also provide a link to a .deb file](http://packages.medibuntu.org/pool/non-free/w/w64codecs/w64codecs_20071007-0medibuntu1_amd64.deb)

But another approach, besides building the tarball from scratch, is converting the .deb file with the program “alien”, to an rpm file.

First install the program “alien” with:su -c 'zypper install alien’And then, with alien installed, one could download the .deb file w64codecs_20071007-0medibuntu1_amd64.deb to one’s hard drive, then open a konsole, and change to that directory, and run:alien -rv w64codecs_20071007-0medibuntu1_amd64.deband that will convert the .deb to an rpm. Then try to install that rpm file.

I can’t recall if alien needs to be run with root permissions, but it will become immediately obvious upon running if that is necessary. And if that does not work, one can simply remove the rpm file, just like what one would do for any rpm.

Of course failing the above, one could go to the tarball. There is a risk that Ubuntu will store the files in a different location than openSUSE, and hence that will fail.

Having thought about this, I’m not convinced this will work, because it could put the files in the wrong directory …

I downloaded and read the readme.txt that comes with the tarball. It notes:

*These are binary codecs for use with MPlayer. They are useless for normal Windows players (like Windows Media Player, QuickTime, RealPlayer, …) as they only contain the DLLs without installer and other fancy stuff needed to use them with common Windows players.

Put the files contained in this archive in a directory where MPlayer will find them. The default directory is /usr/local/lib/codecs/ ($prefix/lib/codecs/) if you are compiling from source, but you can change that value by passing the ‘–with-codecsdir’ option to ‘./configure’.

If you use a prebuilt MPlayer package it will most likely be /usr/lib/codecs, see the documentation of your package for details.

In the past /usr/local/lib/win32 or /usr/lib/win32 was the default directory, some packages as well as a few other Unix players like xine and avifile still use it, refer to their documentation for further details.

On Windows if you are using a prebuilt MPlayer, put the contents of this package in the codecs folder within your main MPlayer installation folder.*

On my 32-bit openSUSE, I have codecs under /usr/lib/win32, and under /usr/lib/codec I have a symbolic link pointing to /usr/lib/win32. So you need to ensure your 64-bit libraries and any symbolic links are also set up properly. Again, I don’t have a 64-bit system, so I can’t specifically help … only point to some things that may need be considered.

Before I forget … WELCOME to openSUSE and WELCOME to our forum. :slight_smile:

I’m _64
And I was in a thread recently, where the user was unable to play them, but at the time I didn’t have a file to hand to try.

Anyway, I did run one yesterday
.rmvb are real media-
if you have real player installed. What’s the problem?

It just works.

I have the realplayer install and the image appears but theres no sound.
I will try to convert the deb to rpm

I did the rpm from the deb.
uninstalled the w32codecs and installed the w64codec
restart suse and still the same problem.
Mplayer only play sound
Realplayer only plays image…
Wheres the page of the Mplayer: MPlayer - The Movie Player
They have the codec’s for 64bit (i think that the mediaubuntu package is compile from that source).

We shouldn’t have to use realplayer. Every other video can be played in your favorite player, dragon player, smplayer, vlc, mplayer, xine, etc. I shouldn’t need to have an entire separate video player just to play one type of video, especially not when the necessary codecs are being installed but aren’t working. And especially not when other distributions seem to be able to make .rmvb files work properly in any common video player.

As for the codecs issue, you can download the 64-bit codecs straight from the mplayer website. I then tried copying and/or symlinking them into various directories. That didn’t work for me, but you can try it if you want.

the more simples things are the more people like.
Ubuntu makes everything in linux to do.
This suse for me is one of the best ever(11.0- very stable, elegant and faster than ubuntu) but not seeing what i want it gives it bad points. in the near future i will go back to ubuntu based distro because of this.
One of the thread that i read about the rmvb files here in this forum was from late 2007 and theres not a great solution for this yet. maybe in 11.1

If we want linux to grow, e must be easy to work and simple to use.

Like in some circles is said:
“K.I.S.S. : Keep It Simple, Stupid”
The final user most not have complex solutions but a one click solution.

But by the way. some one can tell me how to do the rpm from the tar.gz from the Mplayer web site?