Restore original KDE desktop as it was from the OpenSuse DVD

I followed the instructions in the following post, to try and over come a graphical issue.
openSUSE Forums - View Single Post - Black and white squares during KDE login

Unfortunately now i’m a bit worser off.
When i click the green frog head, things dont behave as before. When i moved my mouse from the Favorites to Applications or to Computer/Recently Used/Leave tabs, the desktop enviroment would automatically switch, without me having to click them.

Another thing is if i want leave the green frog toolbar i have to click somewhere withing the green frog head window to close that window. Before i was able to get out of it by clicking on any window out of it, like a firefox window.

Also when i go to desktop setup , the only themes remaining are Oxygen and Aya.There were more before. Finally similar programs on the taskbar are grouped together which i don’t like.

I’d really appreciate if anyone knew how i could over these problems without having to reinstall the OS , preferably using the opensuse dvd.

Hi, I don’t know the proper solution, but this workaround may help. Try to add a new user and login as he, If his desktop looks ok, then delete the previous user and it’s home directory from yast, but make sure you transfer all data to the new users home directory first.

I was able to figure out how to “move my mouse from the Favorites to Applications or to Computer/Recently Used/Leave tabs, without me having to click them” going to RIGHT click Application launcher setting and then “application launcher settings”.

By going to new theme i was able to under desktop settings, i’ve overcomed the theme issue. But i’d still appreciate it if someone knew how i can get out of the application launcher by just clicking on a different window

That’s been mentioned as new behaviour by a few people, and can only be assumed to be a bug.

Well, if anyone knows how i can use the DVD to restore the original setup of the kde desktop enviroment, i’d still appreciate it.

This bug is a Kwin bug. It doesn’t affect those using Compiz-Fusion as the Window Manager. If you were using Compiz-Fusion before and then switched to Kwin this could account for why it’s happening now.


i’ll try to uninstall kwin then and see what happens. It also seems compiz is still installed.

You can’t uninstall Kwin. At least I don’t think so. It’s an integral part of the KDE system. All you have to do is make sure Compiz-Fusion is enabled. Open Configure Desktop (Personal Settings) then under Personal click Default Applications. Under the Window Manager section see which is enabled. If it’s Kwin then choose Use a different window manager and choose Compiz, not Compiz custom. Then click apply, logout, then login.

Hope this helps!


Yeah that did the trick. I went back and reinstalled kwin aswell and it downgraded other kde components from 4.2 to 4.1.3. you’re a lifesaver Ian, thanks again!

EDIT: Unfortunately i had switch from compiz back to kwin. as soon as i booted into opensuse, the windows would freeze in position. Kwin seems to be working as i wanted it to, originally.

do’t worry its too simple…
step (1) just click on tool box(it is on right up corner of desktop) and then
step(2) click on remove this desktop activity
repeat step1 and 2 until original setting is not come…
remember do’t perform this step after clicking any other place on desktop.