Resolution resets at boot

I set the resolution to 1280x1024 in System Settings but at reboot it resets to 640x480. I followed the instructions at Setting the resolution or character size for boot and text consoles on SLE 12 and newer | Support | SUSE but when I tried to save /etc/default/grub using nano as root CTL-x would not work. I started Kate as SUDO_EDITOR=kate sudoedit /etc/default/grub and made the change, This is my current /etc/default/grub…

localhost:/home/ion # cat /etc/default/grub

If you change this file, run ‘grub2-mkconfig -o /boot/grub2/grub.cfg’ after

wards to update


Uncomment to set your own custom distributor. If you leave it unset or empt

y, the default

policy is to determine the value from /etc/os-release

GRUB_CMDLINE_LINUX_DEFAULT=“splash=silent preempt=full mitigations=auto quiet
security=apparmor video=1280x1024”

Uncomment to automatically save last booted menu entry in GRUB2 environment

variable `saved_entry’


#Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD …)


#Uncomment to disable graphical terminal (grub-pc only)


The resolution used on graphical terminal

#note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo’


Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux


#Uncomment to disable generation of recovery mode menu entries


#Uncomment to get a beep at grub start

GRUB_INIT_TUNE=“480 440 1”

localhost:/home/ion #

But when I continue as root I get…

localhost:/home/ion # grub2-mkconfig -o /boot/grub2/grub.cfg
Invalid output terminal “1280x1024”
localhost:/home/ion #

Any suggestions to correct this annoying “feature”?

video= on kernel cmdline only applies to framebuffer output on the vttys reached after boot, via Ctrl-Alt-Fn or when booting to or other targets less than It also applies to text messages on the screen during boot while Plymouth (GUI) is not operational.

Applies to grub-pc only, so not if UEFI booting. Did you install Leap in UEFI mode?

That SLE instruction page doesn’t bother to make applicability to grub-pc only (non-grub-efi) evident.

The system settings resolution selection applies only to running X. /etc/default/grub is the only place I’m aware of that applies to Grub. You can use YaST Bootloader to make modifications to /etc/default/grub. On exit from YaST, it will automatically update /boot/grub2/grub.cfg.

Yes installed in UEFI mode. I followed your instructions. But 1280x1024 hides my applications menu so I have changed to 1280x960. Settings>Display is set to 1280x960.

I tried setting my .profile to include

xrandr --newmode “1280x960_60.00” 101.25 1280 1360 1488 1696 960 963 967 996 -hsync +vsync
xrandr --addmode VGA-0 “1280x960_60.00”

It had no effect. I set the resolution using YaST>System>Boot Loader>Kernel Parameters to 1280x960. That had no effect.

My unmodified /boot/grub2/grub.cfg shows

set gfxmode=1280x960
insmod gfxterm

It has no effect. It still boots at 640x480. Did I misunderstand your instructions? Where do I look for a solution?

Could be the video resolution is not supported.
When you boot, when the screen with os chooser to boot appears you press “e” you will see the kernel lines etc…
Then press Ctrl-c to show the GRUB prompt. then type “videoinfo” to see the video resolution supported.

Well I can understand that 1280x960 may not be supported, but it was doing the same thing with 1280x1024 (earlier post) which “videoinfo” reports is supported. The settings are the same on my 15.4 installation with no problems.

If that worked before, it maybe the video cable problem.
Here if I use a HDMI cable I only get 720 but if I use DP cable I get 1920.
Using HDMI here videoinfo doesn’t show 1920 but using DP cable videoinfo shows the 1920.

I’m still confused. Two distros on the same desktop, 15.5 and 15.4. Same monitor, same cable. 15.4 boots fine. How might the cable change things? If I have to double boot to use 15.5 I can live with that. But an explanation would help, even if I can’t fix it.

I think I need some time to read long journals.

Oh, my bad. So you have two opensuse installed 15.4 and 15.5… it boots the resolution fine in 15.4 however if you switch to 15.5 it doesn’t work. Yeah kinda weird. I thought you have 15.4 before the you installed 15.5 and resolution didn’t work. Sorry I can’t help you with that.

You just defined a regression. Report a bug and include the string [regression] in the summary. The X devs may know something we don’t.