Resolution Problem

Hi guys ,

             Very new to OpenSuse. I have downloaded opensuse 12.2 and tried to install on Intel D2500HN board.Everything is working fine but only problem is it is taking the optimal resolution for the monitor and I am unable to change the resolution and refresh rate also

                           Thanks in advance n any help may be appreciated.

Hi, welcome !!!

To help you, we need as much info as you can give, like:

  • video card, brand, model, did you install 3d party drivers?
  • desktop environment (KDE, GNOME)
  • 32 or 64 bit?

I have a bash script that will run inxi who’s output you could post here in a message for a complete hardware listing. inxi comes from the Packman repository, which you must add first before you can use this utility. Have a look here:

H.I. Hardware Information - A Bash script to install and run inxi with default options! - Blogs - openSUSE Forums

Thank You,

Sorry for the delayed reply .

I am using XFCE desktop 32 bit and intel D2500HN board with GMA 3600 graphics controller

Hi nishanth9042. A good idea to assist us here, would be to upload the contents of /var/log/Xorg.0.log to SUSE Paste
and post the link to it here. For example, it could be a driver issue, or it could be that your display does not pass correct EDID info, but the Xorg.0.log will help determine the cause, and maybe the solution too.

It might also be helpful to provide the output of

 /usr/sbin/hwinfo --gfxcard

Output of /usr/sbin/hwinfo --gfxcard

10: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: _Znp.E97Q61vVAOC
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Model: “Intel VGA compatible controller”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x0be1
SubVendor: pci 0x8086 “Intel Corporation”
SubDevice: pci 0x202e
Revision: 0x09
Driver: “gma500”
Driver Modules: “drm”
Memory Range: 0x40100000-0x401fffff (rw,non-prefetchable)
I/O Ports: 0x20d0-0x20d7 (rw)
IRQ: 45 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00008086d00000BE1sv00008086sd0000202Ebc03sc00i00”
Driver Info #0:
Driver Status: gma500_gfx is active
Driver Activation Cmd: “modprobe gma500_gfx”
Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #10

OUTPUT of /var/log/Xorg.0.log is

SUSE PasteI don’t know whether I have installed the drivers or not.

The intel (gma500) driver is not in use. For some reason the basic framebuffer driver is in use. This explains the low display resolution. Here’s the relevant output

  1.    604.883] (--) FBDEV(0): Virtual size is 1280x768 (pitch 1280)

  1.    604.883] (**) FBDEV(0):  Built-in mode "current"

  1.    604.883] (++) FBDEV(0): DPI set to (100, 100)

  1.    604.883] (II) Loading sub module "fb"

  1.    604.883] (II) LoadModule: "fb"

So what to do now

Not sure. Others may be able to advise better than I can. Anyone else using this hardware?

The only drivers matched are the following:

(==) Matched fbdev as autoconfigured driver 0
   604.841] (==) Matched vesa as autoconfigured driver 1

I note that your chipset is listed as

Model: "Intel VGA compatible controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0be

The gma500_gfx driver is supposed to support that

# modinfo gma500_gfx|grep 0BE1
alias:          pci:v00008086d00000BE1sv*sd*bc*sc*i*

Maybe it is as simple as explicity loading this driver in /etc/X11/xorg.conf.d/50-device.conf

#Section "Device"
#  Identifier "Default Device"
Driver "gma500_gfx"
#  ## Required magic for radeon/radeonhd drivers; output name
#  ## (here: "DVI-0") can be figured out via 'xrandr -q'
#  #Option "monitor-DVI-0" "Default Monitor"

Alan Cox is the developer:

Some useful info concerning the Poulsbo (GMA500) hardware:

and a Fedora blog:

Fedora 17 GMA500 (Poulsbo) | Shadows of epiphany

After reading a few Phoronix articles about this hardware, I can honestly say that I’m glad I don’t own hardware with it. What a messy situation! In reverse chronological order:

[Phoronix] Years Later, Intel Poulsbo Remains A Bloody Mess](
[Phoronix] Poulsbo Looks Better On Ubuntu 12.04, But Still Ugly](
[Phoronix] The Intel Poulsbo Open Driver TODO/Support List](
[Phoronix] Cedar Trail Coming Soon To Open GMA500 Driver](

Is there anything that I can do because I have got 15 systems in my lab.

Did you try the advice in post #10?

Okay, ignore the previous advice…from the following threads
Gentoo Forums :: View topic - GMA500 Xorg problems

I’ve learned that the fbdev driver is the optimal driver for this hardware. (The kernel gma500_gfx DRM module is used to provide basic 2D acceleration only.) There is a ‘xf86-video-modesetting’ package available, which provides basic modesetting capability, but I confess that I know nothing about whether this will help your situation. So, your choice is to

  1. leave as is


  1. try installing the modesetting driver from here:

then edit /etc/X11/xorg.conf.d/50-device.conf to include

Driver      "modesetting"

and restart the X-server when done.

Yes I have tried the post 10.after modifying it is booting to text mode i.e console screen.

I also tried to change to gui by pressing CTRL+ALT+F7 and startxfce4 but it is showing some error.

On 2012-10-20 14:26, nishanth9042 wrote:
> Yes I have tried the post 10.after modifying it is booting to text mode
> i.e console screen.
> I also tried to change to gui by pressing CTRL+ALT+F7 and startxfce4
> but it is showing some error.

And do you expect us to help if you keep that “some error” as a state
secret? >:-P

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Sorry for that the log below

SUSE Paste

On 2012-10-20 15:06, nishanth9042 wrote:
> Sorry for that the log below
> ‘SUSE Paste’ (

>    386.333] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
>    386.343] Parse error on line 11 of section InputClass in file /etc/X11/xorg.conf.d/50-device.conf
>         "°3É  p4B·" is not a valid keyword in this section.

Correct that.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

I did tell you not to proceed with the advice in post #10, but after looking at the Xorg error, it looks like you’ve entered some other invalid entry anyway. Remove your changes with an editor, (either at runlevel 3, or via safe mode boot). In post #15, I’ve explained to leave as is, or the possibility of trying the ‘modesetting’ driver. Your options are limited with this hardware.