Requesting Guidance on Dual Linux Boot

Good evening Geekos :slight_smile:

Sorry if I am asking a very basic and simple to do question but for the last few days I can’t seem to find the correct article on how to accomplish my goal. Additionally, since I don’t know how this might be better explained for a more advanced audience, please excuse me if what I post is lacking the information you require and/or seems a little noob (because I am lol)

To help make it simple, I will break it down the goal, present scenario, and objective below.

Goal: (2 parts)

  • To have the GRUB2 Menu on my home PC have OpenSUSE (LEAP 15.2) and Linux Mint.
  • To do this via CLI for the nerdy purpose alone of just trying to learn how to do this.

Present Status:

  • Installed OS - Linux Mint


  • To not erase the current HDD and to install OpenSUSE without destroying the present Linux Mint installation.


  • Being a noob, I went with Linux Mint first so that I could teach myself how to game on Linux. To fully have a PC experience independent from Windows or Mac. Now, I want to branch out and go with OpenSUSE Leap 15.2 since I have read really amazing things about the system, I really jive with the rock-band YT videos (love those), and I have been told that gaming on OpenSUSE is not as simple as Mint (challenge - accepted).

Where I am stuck:

When I fdisk -l to check the current disk, partition table, and the option for free space I find this:

root@desktop:/# fdisk -lus
Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: A714CFF6-F5C5-49BE-8F74-4770DE1E1F4C

Device Start End Sectors Size Type
/dev/sda1 2048 1050623 1048576 512M EFI System
/dev/sda2 1050624 1953523711 1952473088 931G Linux filesystem

From articles I have read, I need to have a free space allocation but I can’t seem to figure out (without the warning of the process will wipe the entire present partition table, which I am assuming means - goodbye present Mint install) how to make this new /dev/sda3 (I am assuming it is logical order) from /dev/sda2 without seemingly destroying the present partition table.
If anyone has some great advice for a noob over here trying to learn, I would really appreciate it. Articles, books, etc - I’ll read it all and attempt to try it out :slight_smile:

Thank you for your time and patience.

If I am reading that correctly, then your Mint system is using almost all of the disk. There isn’t any free space left to create a new partition.

One option would be to pick up the “gparted live” CD (or .iso). Booting that, it can probably shrink that Mint partition to something a lot smaller. And then you would have free space for a new partition.

Good evening Nrickert,

Thanks for your reply and suggestion. I will get right on this and work out the details as soon as possible.

While I want to keep with the original idea, may I ask what your thoughts would be on if I simply added a new HDD to the box? By doing so, I assume I would be able to have a HDD with Mint and an HDD with OpenSUSE. If that is true, woudl I then be able to find both OS bootable and displayed in GRUB2?

Sorry, random question but just some thoughts I had rummaging around in my head while I was about to reply to your post lol :smiley:

Thanks again!

Yes, adding a disk would one way of solving your problem.

The grub2 menu should then include an entry for openSUSE and an entry for Mint.

Add a SSD, not a HDD. Go for a budget model. Keep the HDD as a backup. Disable CSM, use UEFI. With modern hardware (Windows 10 ready) the latter is the preferred option.

Hey guys!

Great recommendations and insight, so thank you for that. In the future, I will be getting an SDD and going for a quicker and smoother boots.

Just an update:

GParted worked like a charm! I was able to create /dev/sda4 for 30G! I know most would be like, “That’s cool, bro…” but for me it was a good dance moment for fun lol :smiley:

New obstruction that I am having a hard time finding good DuckDuckGo details on (sadly):

Completed - Mint on /dev/sda4, custom install of Mint with / on the 30G part, and ----- it’s done!

Issue - when I booted up it goes right to the Mint login screen and I can’t find the exact information on how to update GRUB to initiate the menu. I have tried to do grup-update and update the grub file to have splash without quiet but… I am running into a good pit here.

If there are any articles either of you could recommend I would totally read it all :slight_smile: This has been pretty fun and learning even GRUB seems to be an area I really need more knowledge base on.

Thanks guys!

LOL Well, then I proved myself wrong with this explanation:

So, I set GRUB_TIMEOUT= to -1 and that fixed the GRUB menu issue.

Now, onto the next step which is OpenSUSE doesn’t show up on the grub menu.

Which is the last installed?? that OS usually controls booting. You should be able to boot any OS via the BIOS/UEFI boot menu.

As roo run os-prober and see if all OS’s are seen. If you want Mint to control. Can not help with easy ways. If you whish openSUSE to control ,boot to openSUSE in the BIOS boot and run Yast select boot from there and be sure that the prob for other OS box is ticked (be sure to change something even if you change it back to trick the program to think something has changed)after accepting openSUSE boot should be in control and Mint should be on the menu. There my or may not be such utilities in Mint.

Hey there Gogalthrop,

Thanks for the question clarification and suggestion - they got me a bit further! :slight_smile:

To help answer your question, my initial base was OpenSUSE 15.2 Leap. Then, I used GParted to resize a portion for 30G for Mint (I just picked it because it was something quick to mind and noobie feel :slight_smile: ). Following GParted, I installed Mint on a custom build under /dev/sda4 which was the new partition with 30G. It worked great! But then the next part is where I got stuck and resolved which was getting to the Grub Menu but OpenSUSE was missing.

Now the controlling device is the Mint one (which doesn’t taste as good as openSUSE…)

I tried using your suggestion of os-prober but this just resolved with nothing new added. I was a bit confused so I did a quick init 6 and found the grub hadn’t changed. Coming to this point I realized we got a bit of keyboard to chair issue going on still (LOL). So, I checked out how os-prober works. Following up on another forum’s post suggestions related to not this issue, I did a quick mdir -p /mnt/opensuse; mount /dev/sda2 /mnt/opensuse; os-prober.

BOOM! We’ve got OpenSUSE into the grub.cfg file. :slight_smile: Then, I did a simple update-grub and notice something weird in the reading that mentioned openSUSE 15.1. But, I went with "Well, likely I did some wrong configurations so let’s wing it and see what happens… init 6 "

From there, the grub menu now shows openSUSE Leap 15.1 (on /dev/sda2) and also attempting to get to that follows up with a failed to load kernel.

ERROR related to vmlinuz 4 and error to load kernel.

In a nutshell, for some random reason where I failed at is in the /dev/sda2 - opensuse. I thought I had it at 15.2 but for some reason I guess I hadn’t. And, Mint is running Kernal 5.0 while the OpenSUSE part is running 15.1 / K 4.#.

side bar Just in case I am not following proper protocol and forum ethics, please advise me if I should close this ticket. I’d hate to waste anyone’s time and/or the communities patience. I created this ticket as an opportunity to learn something that I lacked all knowledge base on and hoped to learn from the experience.

Thanks for the help and patience with my learning :slight_smile:

The “os-prober” used by Mint is probably confused by the “btrfs” file system that you are probably using for openSUSE.

As root, run the command:


That will tell you the UEFI boot options that your BIOS knows about. There’s probably one for “opensuse-secureboot” and one for “mint” (or maybe that one is called “ubuntu”).

You can set the preference order. For example, if the opensuse-secureboot entry is “0000” and the Mint entry is “0001”, then the command

efibootmgr -o 0000,0001

will set choice 0000 to be the preferred boot entry. And that should give you the openSUSE grub boot menu.

Hmm, Mint might be missing from that menu. If that happens, run (as root)

grub2-mkconfig -o /boot/grub2/grub.cfg

to update the menu.


So, I worked out the details on this and found that Mint is a bit strange and does not have the grub2 option and only has the grub-mkconfig option which is incompatible with the opensuse grub2.

Too, when I ran the efibootmgr -o 0000,0001 the report back was:

“EFI variables ar not supported on this system.”

I don’t understand this piece yet so I am going to do some reading on how best to resolve that.

Fun stuff I did which was interesting; once I realized that the vmlinuz was incompatible with the /boot/ I mounted where I remembered the OpenSUSE boot was stored before I went on this adventure. Then, I cp -r /boot-sda1/ /boot-opensuse-sda2/ (the wording is not correct but I hope it is understood); init 6; grub - opensuse 15.1; now the error is recovery entry is missing.

So, that is a plus lol. I just need to find out where that recovery is… ONWARD!!! (lol)

Actually, it is reasonably compatible. There’s just a naming difference.

In Mint, update the grub menu with:

grub-mkconfig -o /boot/grub/grub.cfg

Too, when I ran the efibootmgr -o 0000,0001 the report back was:

“EFI variables ar not supported on this system.”

You installed that system to use traditional MBR booting rather than EFI booting. And that’s about all it means.

I just jumped to the conclusion that you were using UEFI, because you mentioned an EFI partition in the first post in this thread.

Note also if you have both MBR and EFI booting this can cause confusion. ie one OS MBR the other EFI the OS will not see each other. Also BTRFS may be an issue not all Linuxes support it out of the box…

Hey guys,

Sorry for the delay in my response… I was tinkering around and then blew up my science experiment (ROFL!)

In a nutshell, a more advanced co-worker of my notified me that the objective was like placing two engines under one car’s hood; that the point was without purpose.

So, I pressed on and took some earlier mentions that you guys made about the boot record and attempted to change a few things. Here is how that went:

  • mounted openSUSE /dev/sda2 to Linux Mint’s tree; moved over the boot entries for openSUSE into Mint and updated grub
    • Worked and grub menus showed Leap 15.1 but upon jumping in the boot was unable to be achieved (recovery was missing)
  • I then attempted to find that the cp over again and looked for recovery but this didn’t work being I didn’t now well enough what I was looking for (let’s be honest - noob! :smiley: )
  • Light bulb went off (pretty dim lighting though) and I opened up Gparted and deleted the 30G Mint Part and attempted to have it boot from openSUSE instead
    • Uh, so… yeah, upon boot we got to “grub rescue >”
  • I tinkered around a bit more to figure out what I could do to resolve this and it wasn’t happening for me…

I apologize if this next step is a disappointment for any of you but I decided to reboot the full drive (/dev/sda) with openSUSE fresh install and make it a very pared down version with server install.

My new objective is to try and build the openSUSE to be KDE with YaST2 from this now fresh server build. I am not sure if this is possible but I am open to trying.

What I learned was absolutely the best and funniest in a while. Thanks for all of your help and I look forward to breaking and learning more with your inputs further on future forum post :slight_smile:

Thanks guy for all of your time and patience. I hope you are all having a great day and a good weekend ahead :slight_smile:

I’m working on it.

What you are doing, is trying things out and finding out what works. It’s actually a great way of learning. And you can have some fun doing it.

Just install the KDE pattern that will install KDE essentials