Removed some packages in YaST, now boots to console1

Running latest TW (though I didn’t run zypper dup yesterday 02 Jun)

I booted into my primary TW install KDE/Plasma desktop and ran YaST and went to remove packages related to “jupyter”. I did this because I noticed two “Jupyter” apps listed in the “Development” menu. I never use it (and won’t) …

I checked my secondary TW install and my laptop TW install and neither of those have any packages related to “jupyter”.

So, after I selected the packages to Remove (in YaST), I clicked the Accept button, it performed the removal of the packages, then I clicked the YaST OK button to finalize …

And suddenly, the KDE Plasma screen disappeared … and I’m now looking at a login prompt on console1 !!

So I thought to log in as my regular user and run startx … but I’m shown IceWM as my GUI.
So, I quit, and login as another user, and then as root … same thing = IceWM.
Then I thought to reboot - maybe needs a fresh boot. Did so, shows me console1 … I run startx, end up in IceWM.

It’s a bit odd too … I can run various KDE apps while in IceWM. I can run Dolphin, Spectacle, Kate, etc.
I have seen this error a couple of times (so I ran the suggested export, then create ‘0’ subdir):

:~ # spectacle
QStandardPaths: runtime directory '/run/user/1000' is not owned by UID 0, but a directory permissions 0700 owned by UID 1000 GID 100
QStandardPaths: runtime directory '/run/user/1000' is not owned by UID 0, but a directory permissions 0700 owned by UID 1000 GID 100
kf.dbusaddons: DBus session bus not found. To circumvent this problem try the following command (with bash):
    export $(dbus-launch)

:~ # export $(dbus-launch)
dbus[12683]: Unable to set up transient service directory: XDG_RUNTIME_DIR "/run/user/1000" is owned by uid 1000, not our uid 0
:~ # ls -la /run/user
total 0
drwxr-xr-x  3 root    root    60 Jun  3 11:45 .
drwxr-xr-x 46 root    root  1180 Jun  3 12:02 ..
drwx------  8 my-user users  220 Jun  3 12:02 1000

:~ # mkdir -p /run/user/0
:~ # ls -la /run/user
total 0
drwxr-xr-x  4 root    root    80 Jun  3 12:07 .
drwxr-xr-x 46 root    root  1180 Jun  3 12:06 ..
drwxr-xr-x  2 root    root    40 Jun  3 12:07 0
drwx------  8 my-user users  220 Jun  3 12:02 1000

I went into YaST and added back the “jupyter” packages - no difference - still IceWM.
ANY suggestions for next steps ??
Should I go back to a previous Snapshot ? Which one? (I would think 01 Jun?? It’s 03 Jun now, 13:05)

Just a wild suggestion. Install the KDE Pattern. It probably will not install may packages because most is already there. But who knows it installs one or more that is missing.

1 Like

Wow … I did as you suggested … rebooted back, and now I have my KDE Plasma desktop and everything is shown as it was. Except the Latte dock did not display … could not find it in Apps Menu, so went to YaST and it wasn’t installed, so installed it, then executed latte, and the dock showed up with all the icons and configuration in place.

What in the world?? I remove “jupyter” packages and zypper decided to removed some KDE stuff and Latte ???

A BIG THANKS out to @hcvv - Henk !!!

It is a pleasure. But it was only some stupid “first action”.

Why not simply using a terminal:

zypper rm --dry-run packagename

1 Like

And in my case, there were numerous jupyter packages … so I remove jupyter-notepad, then other jupyter packages remain …

Can this be executed (probably not a good idea)

zypper rm --dry-run packagename*

(added ‘*’)

I tried your “asterisk” question - what I see

# zypper rm --dry-run jup*
Reading installed packages...
'jup*' not found in package names. Trying capabilities.
No provider of 'jup*' found.
Resolving package dependencies...
Nothing to do.

That might be because i dont have Jup stuff installed.


@aggie … okay, my run shows this … but there’s nothing related to KDE / Plasma … though there are some Python packages named

:~ # zypper rm --dry-run jup*
Reading installed packages...
Resolving package dependencies...

The following 37 packages are going to be REMOVED:
  jupyter-bqplot-notebook jupyter-doc jupyter-ipyparallel jupyter-jupyter_core-filesystem jupyter-jupyterlab jupyter-jupyterlab-filesystem
  jupyter-jupyterlab-pygments jupyter-jupyterlab-rtc jupyter-jupyterlab-widgets jupyter-jupyter-wysiwyg jupyter-lineup-widget jupyter-nbclassic
  jupyter-nbconvert jupyter-notebook jupyter-notebook-filesystem jupyter-notebook-shim jupyter-panel jupyter-server-fileid jupyter-server-terminals
  jupyter-widgetsnbextension python310-bqplot python310-ipywidgets python310-jupyter python310-jupyter-collaboration python310-jupyterlab
  python310-jupyterlab-pygments python310-jupyterlab-server python310-jupyterlab-widgets python310-jupyter-server python310-jupyter-server-fileid
  python310-jupyter-server-terminals python310-lineup-widget python310-nbclassic python310-nbconvert python310-notebook python310-notebook-shim

37 packages to remove.
After the operation, 107.3 MiB will be freed.
Continue? [y/n/v/...? shows all options] (y): n
:~ #