Remote KDE session?

Is it possible to run a remote KDE session some how?
I am running a test install of 13.1 Factory and want to use it as my main machine and then remote into my normal system so I can interact with what it’s doing like transferring files, starting torrents and my IRC sessions.
Is there a way to do this?


Test machine
Machine is a Dell Optiplex 755 with 3 gig of memory running KDE and 13.1 x64

Sure there’s a way to do it, what makes it easy is that it’s both openSUSE machines.

On the remote:
In Yast’s softwaremanager select View-Patterns
tick the Remote desktop pattern, perform the install
Next use Yast - Network services - Remote desktop, don’t forget to open the port in the firewall.

On the client:
install KRDC or another VNC viewer of your choice
Use remote’s IP address and port 5901 to connect. You’ll see the login screen

Hi Knurpht,

if both machines are his own and running openSUSE with KDE, can’t he do a “real” remote login?

On the remote:
In Yast’s softwaremanager select View-Patterns
tick the Remote desktop pattern, perform the install
Next use Yast - Network services - Remote desktop, don’t forget to open the port in the firewall.

Plus: Create your user on the remote.

On the client:
KDE menue go to “logout” or “change user”
choose “start new session”
you should get into KDM menue to login
type “alt + r” or click on the start icon and choose “remote login” all remote machines in your LAN that allow remote login will be listed.
Choose your remote (e.g. double click on it) and there you are.
If you did not log out of your old session, you can switch back and forth with “ctrl + alt + F7” / “ctrl + alt + F8”
(Sorry if the English terms are not precise.)

Or am I missing something about 13.1 not yet ready and remote X not available?

Best regards


Method 2 seems to work except all the text is mirrored in reverse and I can’t read it.

I could not get KDRC to connect. (method one)

I can’t close the connection to the remote machine.

The remote machine is running 12.3 and the client is running 13.1

The text is reversed too. I the input (mouse and keyboard) is wonky too.

Wow! I am using that method since years with the largest number of different openSUSE versions, never had that. I don’t know if that is a bug or something about video driver etc.
If you shutdown the client, that session will be killed. Can you switch to your old session? "ctrl+alt+F7?

Probably it has got something to do with the resolution settings on the host? That the client’s hardware can’t cope?
I am just guessing wildly. I have just tried a remote from my laptop (12.2) to my homeserver (11.2) without problems.
I suspected kernelmodeset. My homserver doesn’t have any xorg.conf file, so I can’t tell if creating one would help.
Can you somehow reduce the resolution on the host?

Weird. Method 2 in my case crashes. No time to investigate atm. KRDC works fine (and fast) both LAN and WAN

I too now suspect the differences in Video settings and systems.
Client machine is running VESA framebuffer at an unknown resolution and host machine is running Nvidia binary blob at 1920X1080.
Looking in KDE configure desktop on the client machine to see the reported resolution shows just VGA no dimensions given.

Still trying to figure out why Knurpht’s method seems to connect but there is no display at all.
Anyway it;s not a show stopper for me. I have a KVM switch and the host machine has a cloned second monitor so I can watch what is going on; on that machine.

Not sure this is a bug or incompatibility in hardware so I’ll not report it as a bug against 13.1 beta 1.

Thanks for your assistance.

By the way I am not getting email notifications of post to threads I have started even though I am subscribed by default.
Is this how the forum is currently working?

OK Knurpht trying the KRDC method.

Now I have configured a machine with the same version of openSUSE and the same graphics and driver.
I enter the address of the host machine into KRDC likes so

I hit the arrow key.
I see no login prompt.
What am I doing wrong?

I see the disconnect icon as if it’s connected.

I have the same issue I try to connect with krdc from openSUSE 12.3 to different openSUSE (12.3 and 13.1RC1) and I only get a blank screen wiith vnc , rdp ask me for username and password but then nothing.
The remote machines are KVM hosted by a SLES11SP3 .
But I also tried a earlier version of 13.1 (beta 1) hosted on a VMWare ESXi - same result. Connections to SLES Machines work fine strangely enough