Recover gnome-shell from command line

Hello!
On other distributions, it’s possible to recover from a gnome-shell freeze by pressing alt+f1 and typing:
either:
DISPLAY=:0 gnome-shell --replace
or
DISPLAY=:7 gnome-shell --replace
However, on openSUSE, both of them are ineffective. As a matter of fact I tried DISPLAY=: 0 through 9 and none worked. On DISPLAY=:0 I get a “No protocol specified” message along with the regular 'Window manager error: cannot start X" error.
How can I restart gnome-shell in case it freezes on openSUSE?

Alt-F1 just opens up my main KDE menu. Perhaps you are thinking of Ctrl-Alt-F1, to open up terminal and Ctrl-Alt-F7 to switch back to your desktop?

Thank You,

Are you trying to do this ? Projects/GnomeShell/Development - GNOME Wiki!

On Tue, 23 Apr 2013 01:26:02 +0000, Vagrant232 wrote:

> How can I restart gnome-shell in case it freezes on openSUSE?

What I’ve done on the rare occasions it happens is switch to a vt and
just kill it - it’ll restart on its own.

I’m running 12.2 here (not sure which version you’re running).

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Yeah, my bad. It’s ctrl+alt+f1. I tend to do it unconsciously hence why I forgot to type ctrl as well. Anyhow, I digress. Restarting gnome-shell from tvt doesn’t seem to work with DISPLAY:=0 gnome-shell --replace.
Killing the gnome-shell process leaves me with a black screen. The mouse is still there but I can’t interact with anything.

I’ve already seen it in another post of yours, but I think the others would like to see output of


zypper lr -d

too.

Please get used to a couple of things:

  • include your openSUSE version, i.e. also Tumbleweed
  • ditto for desktop environment
  • ditto for 32/64 bit
  • explain how you got to the situation you’re currently in.

I’m obviously using GNOME (3.8). The distro version is Tumbleweed based on 12.3. The Arch is x32. Gnome-shell is known to lag and (occasionally) crash with the proprietary NVIDIA drivers. Exiting certain fullscreen apps such as XBMC or wine may cause the shell to crash. Sometimes it crashes after unlocking the screensaver, among other problems. I haven’t seen it crash on the nouveau driver. On Ubuntu, switch to tvt and typing DISPLAY:=0 gnome-shell --replace (or compiz, gala, kwin --replace) would solve the problem. But obviously this isn’t Ubuntu and the command doesn’t seem to be the same (or isn’t working on my end)
Here’s the list of repositories. I have modified some as you have previously suggested. I am not done modifying them. Please don’t be startled by the large list, most of the repos are actually disabled and about 8 from the listed ~15 (approximately) are the ones that are actually enabled.
I’m fairly certain that the driver is causing teh crash and I’m not asking for a way to prevent the shell from crashing. All I need is an equivalent from the tvt --restart command