Recent problem with downloading from repositories, help!

I say recent because this wasn’t a problem until so. All my repositories for my opensuse 11 were fine, out-of-the-box defaults with packman and dvd iso additions, until yesterday and today i get the dreaded invalid metadata error at start-up disallowing from updating the system.
Ive tried checking if the problem was from one specific repository by disabling the one mentioned in the error message (from yast control center -> software repositories), but the error presists on to the next listed repository (also allowed me to understand that the error was only picking up the first listed repository, since its the first its got to download updates from).
I then noticed the error mentioned ‘unable to download’, so checked my internet and its fine as always. Also checked if i could solve the problem using software manager but on launch the manager pops the same ‘unable to dl valid metadata from repo url’, and after abort/next and the manager opening no upgrades are listed and cant install any listed uninstalled software.
Ive also gone to the bugzilla list of bugs for opensuse 11 and similar bugs show up but the help comments are geared towards solving the problem through one of the ways described above which ive figured aren’t the way im to solve my problem.
To sum up, its the error that unables me to do updates but the problem is neither the internet connection or the repository urls (because they are the listed defaults as explained above). Im sorry if this is a trivial problem, but its a trivial problem thats putting a dent on the evolution of my sweet lizard.

ps im a little noobish (new to oss) so could explanations of possible solutions be noobish geared, thx

opensuse11 host, straight out of box, not much done other then mplayer and dvd source repo turned into iso source repo (oh and bridge-utils for bridging, which was successful hence the fine n dandy net connection)


sorry, just read two posts down and its power outage at the server location, very sorry :shame:

You can just disable your oss, non-oss and update repositories pointing
to and re create using mirrors close to you from
this link;
Mirrors Released

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 10:47, 1 user, load average: 0.03, 0.14, 0.18
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Unclear how one uses repos on the list of mirror systems in smart. Can you provide a few hints to someone who is smart-challenged, but otherwise Linux-literate? I’ve tried adding repos against a few of the mirrors, but so far, have had no success.


You can use “smart” also for repository management.

thejaswi:~ # smart channel --help

This command allows one to manipulate channels. Channels are
used as sources of information about installed and available
packages. Depending on the channel type, a different backend
is used to handle interactions with the operating system and
extraction of information from the given channel.           

The following channel types are available:

  apt-deb    - APT-DEB Repository
  apt-rpm    - APT-RPM Repository
  deb-dir    - DEB Directory     
  deb-sys    - DPKG Installed Packages
  mirrors    - Mirror Information     
  red-carpet - Red Carpet Channel     
  rpm-dir    - RPM Directory          
  rpm-hdl    - RPM Header List        
  rpm-md     - RPM MetaData           
  rpm-sys    - RPM Installed Packages 
  slack-site - Slackware Repository   
  slack-sys  - Slackware Installed Packages
  up2date-mirrors - Mirror Information (up2date format)
  urpmi      - URPMI Repository                        
  yast2      - YaST2 Repository                        

Use --help-type <type> for more information.

  -h, --help        Show this help message and exit
  --add             Argument is an alias and one or more key=value pairs
                    defining a channel, or a filename/url pointing to a channel
                    description in the same format used by --show, or a        
                    directory path where autodetection will be tried           
  --set             Argument is an alias, and one or more key=value pairs      
                    modifying a channel                                        
  --remove          Arguments are channel aliases to be removed                
  --remove-all      Remove all existent channels                               
  --show            Show channels with given aliases, or all channels if no    
                    arguments were given                                       
  --edit            Edit channels in editor set by $editor                     
  --enable          Enable channels with given aliases                         
  --disable         Disable channels with given aliases                        
  -y, --yes         Execute without asking                                     
  --help-type=TYPE  Show further information about given type

  smart channel --help-type apt-rpm
  smart channel --add mydb type=rpm-sys name="RPM Database"
  smart channel --add mychannel type=apt-rpm name="Some repository" \
                    baseurl= components=extra
  smart channel --set mychannel priority=-100
  smart channel --disable mychannel
  smart channel --remove mychannel
  smart channel --show
  smart channel --show mychannel > mychannel.txt
  smart channel --add ./mychannel.txt
  smart channel --add http://some.url/mychannel.txt
  smart channel --add /mnt/cdrom

You should be using “smart channel --add” option to add the mirrors. See the examples above and it should be straightforward.
Post back if you face any problems.

  • Thejaswi Raya