Reboot fails to unmount disks on 11.1

As the title says, I’ve been having problems with my disks not unmounting properly during reboot in 11.1. The problem does not exist, however, when I shutdown. This is on a clean install of 11.1 with an Intel ICH9R chipset. I thought that this could be due to the binary Nvidia driver, but it happens with or without it.

I’m really impressed with how responsive 11.1 seems to be, and I’ve managed to get audio and automount to work properly in KDE 4, but this issue is really confounding me.

Any and all input is much appreciated.

Unmounting file systems
/dev/ bla bla bla

umount:/home divice is busy
Oops umount failed :frowning: look at some man pages and stuff

the problem is pulseaudio. Kill the process manualy or since you use kde just uninstall it.

Thanks for the advice, Tom. :slight_smile: Strange that it only happens during reboot, and not shutdown…I’ll follow your advice and report back.

Aha! Brilliant! Thank you. :slight_smile:

any time. I had the same thing happen to me, it took me a little while to figure out. Now to figure out how to make pulseaudio not do that.

Since I wanted to keep Mplayer, I couldn’t completely uninstall pulse audio, and the remaining libpulseaudio0 doesn’t seem to be causing any problems.

  1. Backup /etc/init.d/boot.localfs
  2. Edit /etc/init.d/boot.localfs
  3. Find ‘umount’ command, and add option -l (lazy unmount) to each of it.
    it will solve the problem.