Realtek RTL8821 not recognised

Hi everybody!

I have been having problems installing opensuse on my new IdeaPad S540 (Model name 81NH).

I tried installing the latest Leap 15.1, but even during the installation process, it did not see my network card, and the touch acted weirdly and the froze.

Thinking of a driver/firmware problem, I tried installing Tumbleweed. That solved the touchpad problem, but not the wifi issue: when I was offer the ossibility by Yast to “edit” a network card during install, Yast simply crashed, after displaying an error message. Same behaviour after install.

The card is listed by Yast -> Hardware info as a RTL8821.

Systemlogs are not very helpful, here is what I could find:

ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge

<info>  [1585085082.3210] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:14.3/PNP0C09:00/VPC2004:00/rfkill/rfkill0) (platform driver ideapad_acpi)
<info>  [1585085082.3585] manager[0x55cc149d2070]: rfkill: Wi-Fi hardware radio set enabled
<info>  [1585085082.3585] manager[0x55cc149d2070]: rfkill: WWAN hardware radio set enabled

iwlist finds only the lo interface, which does not support scanning, and iwconfig also finds only lo, with no wireless extension.

The kernel is

Any help as usual greatly appreciated!


The RTL8821 is not currently supported by the kernel.

Be aware, the kernel and rtl8821ce driver versions must match.

If you (also) have a wired connection then you can install the rtl8821ce driver from “Sauerland’s” home repository at:

Thanks for your reply and for pointing me to that repo, I will try manually installing the driver and report back here.

Please post:

/sbin/lspci -nnk | grep -iA3 net

Because rtl8821 is a wide term…

Thanks a lot!

Here it is in full (but I suppose only the first two lines are relevant):

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Sandisk Corp Device 5005 (rev 01)
04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c2)
04:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller

Run the command as Sauerland gave it. It will show more information than you’ve reported here.

I run it again and indeed the result is different:

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
        Subsystem: Lenovo Device [17aa:c024]
03:00.0 Non-Volatile memory controller [0108]: Sandisk Corp Device [15b7:5005] (rev 01)
        DeviceName: Broadcom 5762

No LAN Hardware?


uname -a

Please, if anybody is asking for some output from Terminal, please post it completely incl. the complete input line.

Thanks again, here it is:

federico@localhost:~> uname -a
Linux localhost 5.5.9-1-default #1 SMP Thu Mar 12 06:33:05 UTC 2020 (70a6377) x86_64 x86_64 x86_64 GNU/Linux

If you have Internet, as root:

zypper ar -f Sauerland-Hardware
zypper in -f rtl8821ce-kmp-default

So you will get the Update of the driver.

No Internet:
Download and install:
After that the first Command from above to get my Repo.

THANKS! worked instantly right after reboot. I will also update my other requests for help in other forums.

Is Bluetooth working?
If yes, nothing to do.

If no, you can test my Bluetooth kmp:

zypper in -f btrtl-kmp-default

It can work or not, it depends on the chip inside your Wlan.
If it is not working, nothing to do.

Bluetooth works perfectly, thanks again!