Realtek r8168/9 Driver Problem - No module


In the past 3 days I am trying to fix my wired internet connection. It works great at windows at the same computer. I know that there are a lot of threads about the Realtek r8168, but I couldn’t find the solution. I adopted the instructions of a member forum:

**1. Get root **privileges, open terminal, type “su” ‘enter’ root pass ‘enter’ you will see red leather in command prompt
**2. Get the requirements
To build and install the driver, we need the kernel headers and the build tools like gcc. To get them, just easily type in a terminal:**zypper in -t pattern devel_basis devel_C_C++ devel_kernel
3. Get the driver
Now, go to the official download page from Realtek for the Linux/UNIX Driver for the RTL8111/RTL8168 ethernet card and download the latest driver version.
Link: Realtek Download Page

**4. Untar the archive
The driver is compressed to an archive. So uncompress it with the following command:***tar xfvj r8168-8.025.00.tar.bz2
NOTE: Please do not forget to replace the “r8168-8.025.00.tar.bz2″ with the driver version which you have downloaded!

**5. Blacklist old driver
We have to blacklist the old driver (r8169) to prevent the system to load it. To do this, easily set a new entry in “/etc/modprobe.d/99-local.conf” which is called:***blacklist r8169
**or just enter in the terminal againecho “blacklist r8169″ >> /etc/modprobe.d/99-local.conf
to do this in only one command.
6. Build and install the new driver
Now, the whole requirements to install the new driver are done. Let us now change in the driver directory, which we have uncompressed in a few steps before:cd r8168-8.025.00
NOTE: Again, please do not forget, to change “r8168-8.025.00″ to the version which you have downloaded.
The only think we have to do now is, to build the driver and install it. To build it, just type:make clean modules
after a few seconds (depending on your CPU), the driver is build and you can install it with:make install
7. Welcome r8168
One of our last steps is, to let the system know about the r8168 driver. With the command
depmod -a

you rebuild the kernel module dependencies
8. type exit ‘enter’ to close terminal

Everything did ok, but it didn't work. Since I blacked list the r8169 module, no modules are loaded. Below are some commands that may help to find a solution.

linux-csox:/home/tahim # lspci | grep Realtek
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)

linux-csox:/home/tahim # cat /etc/modprobe.d/99-local.conf

please add local extensions to this file

blacklist r8169

linux-csox:/home/tahim # lspci -v
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)
Subsystem: ASUSTeK Computer Inc. P8 series motherboard
Flags: bus master, fast devsel, latency 0, IRQ 47
I/O ports at e000 [size=256]
Memory at f0004000 (64-bit, prefetchable) [size=4]
Memory at f0000000 (64-bit, prefetchable) [size=16]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 01
Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
Capabilities: [d0] Vital Product Data
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Virtual Channel
Capabilities: [160] Device Serial Number 5d-00-00-00-68-4c-e0-00
Kernel driver in use: r8168
Kernel modules: r8169, r8168

linux-csox:/home/tahim # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default UG 0 0 0 enp3s0 * U 0 0 0 enp3s0

linux-csox:/home/tahim # ifconfig -a
enp3s0 Link encap:Ethernet HWaddr 10:C3:7B:C4:60:BE
inet addr: Bcast: Mask:
inet6 addr: fe80::12c3:7bff:fec4:60be/64 Scope:Link
RX packets:10311 errors:0 dropped:175 overruns:0 frame:0
TX packets:518 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1464466 (1.3 Mb) TX bytes:29201 (28.5 Kb)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:354 errors:0 dropped:0 overruns:0 frame:0
TX packets:354 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:36978 (36.1 Kb) TX bytes:36978 (36.1 Kb)
RX bytes:35518 (34.6 Kb) TX bytes:35518 (34.6 Kb)

linux-csox:/home/tahim/Downloads # lsmod
Module Size Used by
st 44725 0
sr_mod 22416 0
cdrom 60734 1 sr_mod
xt_pkttype 12504 3
xt_LOG 17718 10
xt_limit 12711 10
bnep 19624 2
bluetooth 483238 5 bnep
6lowpan_iphc 18702 1 bluetooth
fuse 100461 5
iscsi_ibft 12862 0
iscsi_boot_sysfs 16000 1 iscsi_ibft
af_packet 40034 0
ip6t_REJECT 12939 3
xt_tcpudp 12884 3
nf_conntrack_ipv6 14798 3
nf_defrag_ipv6 34768 1 nf_conntrack_ipv6
ip6table_raw 12683 1
ipt_REJECT 12541 3
iptable_raw 12678 1
xt_CT 12956 4
iptable_filter 12810 1
ip6table_mangle 12700 0
nf_conntrack_netbios_ns 12665 0
nf_conntrack_broadcast 12589 1 nf_conntrack_netbios_ns
nf_conntrack_ipv4 14806 3
nf_defrag_ipv4 12758 1 nf_conntrack_ipv4
ip_tables 27240 2 iptable_filter,iptable_raw
xt_conntrack 12760 6
nf_conntrack 114273 6 xt_CT,nf_conntrack_netbios_ns,xt_conntrack,nf_conntrack_broadcast,nf_conntrack_ipv4,nf_conntrack_ipv6
ip6table_filter 12815 1
ip6_tables 27026 3 ip6table_filter,ip6table_mangle,ip6table_raw
x_tables 34059 15 xt_pkttype,ip6table_filter,xt_CT,ip6table_mangle,ip_tables,xt_tcpudp,xt_limit,xt_conntrack,xt_LOG,iptable_filter,ip6table_raw,ipt_REJECT,ip6_tables,iptable_raw,ip6t_REJECT
xfs 1011981 1
libcrc32c 12644 1 xfs
joydev 17344 0
x86_pkg_temp_thermal 14205 0
intel_powerclamp 18823 0
eeepc_wmi 13151 0
snd_hda_codec_realtek 80983 1
snd_hda_codec_generic 77129 1 snd_hda_codec_realtek
asus_wmi 28190 1 eeepc_wmi
sparse_keymap 13948 1 asus_wmi
snd_hda_codec_hdmi 55740 1
iTCO_wdt 13480 0
snd_hda_intel 34475 5
coretemp 13441 0
r8168 505186 0
rfkill 26772 5 bluetooth,asus_wmi
iTCO_vendor_support 13718 1 iTCO_wdt
snd_hda_controller 35103 1 snd_hda_intel
snd_hda_codec 151970 5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
serio_raw 13434 0
kvm 501446 0
crct10dif_pclmul 14268 0
crc32_pclmul 13133 0
ghash_clmulni_intel 13230 0
aesni_intel 152552 0
aes_x86_64 17131 1 aesni_intel
lrw 13286 1 aesni_intel
snd_hwdep 13602 1 snd_hda_codec
gf128mul 14951 1 lrw
glue_helper 13990 1 aesni_intel
ablk_helper 13597 1 aesni_intel
cryptd 16263 3 ghash_clmulni_intel,aesni_intel,ablk_helper
snd_pcm 116857 4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
pcspkr 12718 0
ppdev 17671 0
tpm_infineon 17131 0
tpm_tis 18581 0
snd_timer 33609 1 snd_pcm
snd 87947 18 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
i2c_i801 22454 0
tpm 39966 2 tpm_tis,tpm_infineon
parport_pc 41414 0
parport 46395 2 ppdev,parport_pc
mei_me 23664 0
mei 96067 1 mei_me
thermal 22971 0
battery 23237 0
processor 40484 0
fan 13018 0
soundcore 15047 2 snd,snd_hda_codec
lpc_ich 21093 0
mfd_core 13435 1 lpc_ich
wmi 19193 1 asus_wmi
shpchp 32951 0
dm_mod 111114 0
btrfs 1007121 1
xor 21411 1 btrfs
raid6_pq 106004 1 btrfs
uas 27255 0
usb_storage 62302 2 uas
crc32c_intel 22094 2
i915 983524 7
i2c_algo_bit 13413 1 i915
drm_kms_helper 65670 1 i915
drm 335594 6 i915,drm_kms_helper
xhci_hcd 178893 0
video 24419 2 i915,asus_wmi
button 13971 1 i915
sg 40630 0

What am I doing wrong? Since I blaked list the r8169, the mii module hasn’t shown up anymore in lsmod.

 I appreciate any advice, because I am almost quitting and keep working on windows.[/size][/size][/size]

First of all: a warm welcome to the openSUSE forums.

Second: the card is supported by the linux kernel, so building it yourself is not necessary, you’ll end up with a module that’s already there.

The card works, in the output it shows that the card has an ip address:

enp3s0    Link encap:Ethernet  HWaddr 10:C3:7B:C4:60:BE  
          inet addr:****  Bcast:  Mask:

We have two options here:

  • Either you yourself set the ip address as static ip address. This requires that you set the DNS’s ( use google’s and ) and the gateway address ( the ip your router has inside the network ) through Yast’s Networksettings module
  • Or your /etc/resolv.conf is borked by manual editting. Remove it, reboot and see if things work properly.

But, there is no missing kernel module.

Thanks Knurpht!

I did not edit the /etc/resolv.conf. It was a clear installation and I just did the steps that I mentioned above.
About the module, I realized that before I black list the module r8169 it appeared when ask for the list modules (lsmod)
**mii r8169
**but now it has gone. I thought it should appear as **
mii r8168
**that’s why I put no module after reboot.
I will try to set the ip address and the DNS again (the first time it did not work). Do you have another idea?

Thanks a lot!

Knurpht it doesn’t work…

Someone has an additional advice? At Ubuntu the system shows as connected but it didn’t work. At Opensuse the problem continues…

Does it work with the r8168 and r8168-kmp Packet from my Repo?

Here it works with the r8168 or r 8169 driver.

/sbin/lspci -nnk | grep -iA3 net
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 09)
        Subsystem: ASUSTeK Computer Inc. P8 series motherboard [1043:8505]
        Kernel driver in use: r8168
        Kernel modules: r8169, r8168

I am sorry if it is a stupid question, but how can I use your repository without internet? I don’t have any alternative connection. To answer you all I have to restart and boot using windows.

Download the Kernel -Modul-Package and the r8168-Package and install it with zypper.

As you have doen it with the Source from Realtek.