realtek audio problems

Please help!
I am unable to get any audio through my on board optical out under opensuse 11.1 i8. My motherboard is MSI K9A2 with Chipset integrated by Realtek® ALC888/ALC888T.
OS: Linux i686
System: openSUSE 11.1 (i586)
KDE: 4.1.3 (KDE 4.1.3) “release 4.9”

I followed instruction from this website How to install driver for Realtek ALC268 (HDA) for Acer Aspire 4710 laptop - Ubuntu Forums

Then it runs the ALSA configurator but does not detect my onboard sound.

I checked the sound configuration in yast and this is what I am shown.

SBx00 Azalia (Intel HDA)
Configured as sound card number 0
Driver snd-hda-intel

Radeon HD 3870 Audio device
Configured as sound card number 1
Driver snd-hda-intel

I am new to linux and I really hope someone can help me with this issue as I have spent some time trying on my own already and cant work out where I am going wrong.

Thanks in advance

Rather than follow a guide for Ubuntu users on your openSUSE , try working your way through an openSUSE guide: SDB:AudioTroubleshooting - openSUSE

When testing your sound, please use the following speaker test: speaker-test -c2 -l5 -twavIf your sound functions, you should heard a lady’s voice saying ‘FRONT LEFT’,‘FRONT RIGHT’ five times. Please also try that test with root permissions it it does not work with regular user permissions. Also, when testing basic sound functionality, move your master and PCM volume controls to 95%. Once you have sound established, you can back off to a lower volume level where there is no distortion.

If you the various / many suggestions in the troubleshooting guide, and still have no luck, then we will need more information in order to help. To provide more information, with your PC connected to the Internet, please copy and paste the following into a gnome-terminal or a kde konsole:
/usr/sbin/alsa-info.shthat will give you a URL. Please post ONLY the URL here. NOT the rest. JUST the URL.

Also, please copy and paste the following one line at a time into a konsole or gnome terminal and post here the output:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I actually tried all the steps listed on SDB:AudioTroubleshooting - openSUSE first but had no luck with that so thats when I tried the ubuntu link and it seemed to me like it might have been on the right path but then again I’m new at this so maybe not.

here is the url you requested

then you said Also, please copy and paste the following one line at a time into a konsole or gnome terminal and post here the output:

here are the results I got.

linux-y51p:/home/chris # rpm -qa | grep alsa

linux-y51p:/home/chris # rpm -qa | grep pulse

linux-y51p:/home/chris # rpm -q libasound2

linux-y51p:/home/chris # uname -a
Linux linux-y51p #1 SMP 2008-12-04 18:10:04 +0100 i686 athlon i386 GNU/Linux

linux-y51p:/home/chris # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel,snd-hda-intel

5Dex.IxZY6FR_2b6:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

NXNs.j+5LH6QOLIC:Radeon HD 3870 Audio device

alias snd-card-1 snd-hda-intel

Thank you so much for your help I hope this wont be too hard to get this sorted out.

I hope so to.

Your sound driver is not loading. I can see that from:

!!ALSA Version

Driver version:     
Library version:    
Utilities version:

Lets try an update of alsa. Please open a gnome terminal or a kde konsole and type “su” (no quotes, enter root password when prompted). Then with your PC connected to the internet, copy and paste the following, one line at a time, in sequence, into that gnome terminal or kde konsole:

 zypper ar multimedia 
zypper install alsa alsa-plugins alsa-plugins-pulse alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
 zypper ar multimedia 
zypper install alsa-driver-kmp-pae
zypper rr multimedia

then restart your pc and test your sound. If that does not work, please again post the output of
/usr/sbin/alsa-info.shand post here the URL provided (just the URL).

Also if sound still not working run: rpm -qa | grep alsaand post here the list of alsa apps installed.

And if sound still not working also run: dmesg > dmesg.txt && curl -F file=@dmesg.txt and post here the URL provided (just the URL)

here is the url you requested

and here is the other information

linux-y51p:/home/chris # rpm -qa | grep alsa
linux-y51p:/home/chris # dmesg > dmesg.txt && curl -F file=@dmesg.txt
curl: (6) Couldn’t resolve host ‘
linux-y51p:/home/chris #

I still have no sound. Is it possible the Audio from the ati graphics card which is connected via HDMI is causing a problem with my onboard optical out or is it that I dont have the realtek audio driver installed?

Thanks for your help its much appreciated

That looks MUCH BETTER. There is a significant improvement there, as opposed to your previous running of the script.

That looks correct.

This needs to be run with your PC connected to the internet.

You need to investigate the wiring and connections, to ensure it is correct. I can’t help you there.

I know nothing about optical output nor HDMI. But I do note from the script that your PC’s hardware audio codec is an ALC888. If that is not configured automatically by the alsa autoprobe, you could look at applying a model option to that.

As of alsa 1.0.19 , the model options for the HD-Audio are contained in the HD-Audio-Modules.txt file, where for the ALC888 the list is:

  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  medion	Medion Laptops
  medion-md2	Medion MD2
  targa-dig	Targa/MSI
  targa-2ch-dig	Targs/MSI with 2-channel
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  auto		auto-config reading BIOS (default)

One can try applying the codes one by one (only one at a time) to one’s /etc/modprobe.d/sound file with the appropriate syntax, to see if the identification of the hardware audio codec can be forced. … I don’t know if you are at that stage, as I do not know anything about the hardware you are using.

I pasted the second one in the list but not sure if I pasted it in the correct part. Can you tell me if I have done this correctly before I move on and try and paste any others in.

options snd slots=snd-hda-intel,snd-hda-intel

5Dex.IxZY6FR_2b6:SBx00 Azalia (Intel HDA)

6stack-dig 6-jack digital with SPDIF I/O
alias snd-card-0 snd-hda-intel

NXNs.j+5LH6QOLIC:Radeon HD 3870 Audio device

alias snd-card-1 snd-hda-intel


Still no sound in Opensuse though : (

Also just so you know my sound works fine in Vista, but I had to disable the audio from the ATI 3870 graphics card as I dont have the correct connection for that to get audio and then set my onboard audio Chipset integrated by Realtek® ALC888/ALC888T- Flexible 8-channel audio with jack sensing- Compliant with Azalia 1.0 Spec
as the default and then in the options select SPDIF-out header.

just like to mention I downloaded realtek-linux-audio-pack-5.09
from here Realtek

And this is the readme file I got with the download. I thought I might have to follow these instructions but I’m lost and confused. Any assistance would be grateful as I have been trying for 2 days now to get this to work.

The source code copy from Main Page - AlsaProject. ver:3.3-4
Linux Source Code for ALC audio codec
Support Codec list:
====AC97 Codec=====

====HD Audio codec ====

This Source Code is from Main Page - AlsaProject.
For OS installation, please remember add the Development tool kit.
For driver installation, please follow below steps.

Automatic install: (Recommend RedHat distribution)


Note: Ubuntu OS, please use manual install.
Run commands need to add sudo at first words.

Manual install:
Step 1. unzip source code
tar xfvj alsa-driver-1.0.xx.tar.bz2

Step 2. Turn on sound support from kernel config
(soundcore module, default turn on)

Step 3. Complied source code
a. cd alsa-driver-1.0.xx
b. ./configure
c. make
d. make install
e. alsaconf
f. ./snddevices (Only kernel 2.4 does it)

Step 4. Edit your /etc/modules.conf or conf.modules depending on the distribution
(Please refer to the attached modules.conf)

    snd-xxxx is the card ID.

-- Azalia controller --ALC880 ALC882 ALC260 ALC262 ALC883 ALC885 ALC888
   --- Intel ICH6 ICH7 ---------

    -- AC97 controller --ALC655 ALC650 ALC250 ALC255
       --- Intel ICH6 ICH7 , SiS 7012 and NVidia----------
       --- Via8233 Via686a  -------------------------------    
       --- ATI Chipset  -------------------------------

    Copy and paste this to the bottom of your /etc/modules.conf or /etc/modprobe.conf file.
# ALSA portion
      alias char-major-116 snd
      alias snd-card-0 snd-xxxx     
    # OSS/Free portion
      alias char-major-14 soundcore
      alias sound-slot-0 snd-card-0
    # card #1
      alias sound-service-0-0 snd-mixer-oss
      alias sound-service-0-1 snd-seq-oss
      alias sound-service-0-3 snd-pcm-oss
      alias sound-service-0-8 snd-seq-oss
      alias sound-service-0-12 snd-pcm-oss

Step 5. reboot your machine

Step 6. Use the alsamixer the disable mute (All audio line default is mute)
*Must to compile and to install the ALSA library and utility. (Use automatic install is already install)
excute alsamixer

Note: 1. The most detail information, can refer the alsa-kernel/Documenttation/ALSA-Configuration.txt in the azx-021705.tar.bz2.
2. Kernel Version must be 2.2.14 or later.
3. All mixer channels are muted by default. You must use a native
or OSS mixer program to unmute appropriate channels.
4. If can not compile the source code, try to rename the /usr/src/linux-2.x -> /usr/src/linux.
5. The driver added to support the SPDIF functoin.
6. a. You can download the alsa-lib-1.0.9 and alsa-utils-1.0.9a form the Main Page - AlsaProject, then unzip and install them.
b. Suggest use “alsamixer” to control mixer function.
c. Used “alsaconf” can autodetect which drive you need to install (step 4).
7. SUSE Distribution must install the ncurses package.

Please do not use the realtek driviers. IMHO that will just make this worse. If you have already installed the realtek drivers on top of the alsa update to 1.0.19, then I can no longer help you. You are, in that case, on your own.

Now, if you have not installed realtek drivers, then reference your question on the /etc/modprobe.d/sound file, … you have incorrect syntax in the file:

Instead, try this for 6stack-dig:

options snd-hda-intel model=6stack-dig
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.IxZY6FR_2b6:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.j+5LH6QOLIC:Radeon HD 3870 Audio device
alias snd-card-1 snd-hda-intel 

Then restart your alsa sound driver with su -c ‘rcalsasound restart’ (enter root password when prompted) and restart your mixer and test your sound.

Thanks for all your help but unfortunately I was impatient for a response and partly installed the realtek drivers. I tried again from the beginning of the post and went through everything you suggested again but I still have no sound.
Thank you for your time I guess I will just have to only have sound when using vista.
I wouldn’t have tried to install the realtek drivers if I had been aware that it would cause an issue.


This thread is continued here:
Realtek audio installation issues - openSUSE Forums