I got a new noteBook “Positivo Motion Plus” model V142R4G-1, version 11144885
The OpenSUSE 15.1 is not recognizing the wireless network card and I don’t have internet and wifi access.
With windows the wifi works well
I have verified that the card being used is REALTEC RTL8723BS WIRELESS LAN 802.11nSDIO

How can I solve ?

Not the name is important, the ID is important, so please post:

/sbin/lspci -nnk | grep -iA3 net

This code when used on this PC it returns a lot of information
But when use on notBook does not show any lines

It is not PCI, it is SDIO adapter. I do not know if it is even possible to enumerate SDIO devices.

Try “modprobe r8723bs”. If wireless interface does not appear, provide full output of dmesg (upload to if it is long and post link).

Along with the requested dmesg output, you could also try examining the SDIO device tree with something like

ls -R /sys/bus/sdio

However, I’m not certain that the wifi driver will handle such a device.

FWIW, I found a Linux Mint thread dealing with the same wifi hardware which may be of interest…

The linked repository is empty, driver is part of Linux staging tree (and is built by default on Leap 15.1).

I don’t have it

# modinfo rtl8723bs
modinfo: ERROR: Module rtl8723bs not found.
# uname -r

In any case aside from the driver, the OP also mentioned

Booted into Bios/ South Bridge/ LPSS & SCC CONFIGURATION/ SCC SDIO Support = changed acpi to PCI then saved and exit. After reboot, wifi working!

Ah, I used the wrong name - it should have been r8723bs. All good.

Because it is not called rtl​8723bs.

I know - see above. I copied the name from the Mint thread. :wink:

[LEFT][FONT=&amp]I try to use, but after filling in and clicking “create” I get a message “not found”
[FONT=&amp]So, I put the result of “dmesg” in this link

“modprobe r8723bs” return nothing[/FONT][/LEFT]


“modprobe r8723bs” return nothing

That’s as expected. The next step is to see if a wireless device node now exists.

ip a

If so, proceed with configuring.

That’s the result from ls-R

sergio@linux-yzrb:~> ls -R /sys/bus/sdio
devices  drivers  drivers_autoprobe  drivers_probe  uevent
bind  mmc0:0001:1  uevent  unbind

That’s the 'ip a"

sergio@linux-yzrb:~> ip address 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether dc:35:f1:d4:1f:90 brd ff:ff:ff:ff:ff:ff

The device node ‘wlan0’ is present. Have you tried configuring yet? Are you using NetworkManager or wicked?

Yes, I tried and also tried use [LEFT]NetworkManager and Wicked
No wifi appears[/LEFT]

Ok, assuming NetworkManager is active report back with output from

nmcli d
nmcli g

That’s codes now return all ok
I turned this notBook on and off for several days, always trying to use the internet… This was never possible, because there was no connection. No wifi was found.
Today while trying to change from wicked to networkmanager… There was my wifi network visible.
What was the reason this happen?
If I ever happen again, what can I do?

Good to read that it is finally working.

In general, always a good idea to post requested output, not just interpret it with words. Good to read that it is finally working as expected.