Really bad Grub...

I seem to be plagued with Grub related problems. My system no longer boots to any of my Grub entries except Windows. I cannot think of anything I have done recently that would have caused this. I installed Fedora recently, but without Grub, and everything worked fine after that. But this morning I booted up, chose “openSUSE 11.0”, got the standard Grub “pre-boot” message (file system type, kernel version, etc), then the BIOS screen comes back as the machine reboots itself. I tried all of the various openSUSE entries (with previous kernels), as well as my Ubuntu and Fedora entries, but no dice. I don’t have a clue what happened. Any ideas?

Are you able to boot up with the OpenSUSE DVD and enter repair mode to fix GRUB?

Never mind; apparently I had left the Fedora Live CD in the drive, and even though I chose to boot from local drive, it seemed to mess up my boot. I removed the disc (duh) and all is well.

Thanks anyhow!

Looks like your BIOS is still set to try the optical drive first.