Reading HFS+ on 11.4?

I just decided to learn how to use opensuse(total newbie), I installed 11.4 on my macbook along with os x. At first I used to be able to read the two HFS+ partitions on the laptop after entering the password. But after looking up how to configure the system on the macbook(sound, grahpics…etc) I dunno if I messed up something or what, now I get this error whenever I try to mount the HFS+ partitions( I am still asked for authorization though):

An error occurred while accessing ‘Data’, the system responded: org.freedesktop.UDisks.Error.Failed:Requested filesystem type is neither wll-known nor in /proc/filesystems nor in /etc/filesystems

Anyone can help?

Thanks :slight_smile:

What about adding a line like :


in the /etc/filesystems file ?

Or what about a install of the package hfs-utils

I guess that simply adding that line does not install the software to support it. @Benmh’s advice looks much beter to me. And you better do not change such system files like /etc/filesystems without having a very good reason and much understanding.

Actually, HFS is is there already in the filesystem I checked it the second I got the error. At the beginning when I installed the OS, it used to read HFS(+) by default. Though now I dunno what I did to screw things up, that’s why I thought that it might be better to fix what I ruined instead of trying to install something new

It is a bit difficult for innocent people like us to find out what you did if you do not know yourself.

Always take notes when you are changing the system.

sorry, I am new to this, I just assumed that there would be a magic way to check :D. I installed hfsutils, I still get the same kind of error.

Linux has read only support for journaled hfs+. Some people were able to mount hfs+ partitions read/write after disabling journaling under Mac OSX. You’ll find posts about this topic in the forum. I never tried. To mount hfs+ from Linux on my iMac, I use the following line in /etc/fstab:

UUID=ccbbbd94-deb6-3a95-aadf-531952d1af33    /mac                               hfsplus       acl,user_xattr                   0   0

where the partition is mounted by UUID in the mount point /mac. But you don’t have to use this notation (although it never hurt). Use blkid under Linux to find out UUIDs. Your Mac partition should have the type “hfsplus”.

I still get the same error, I also tried

 /dev/disk/by-id/ata-Hitachi_HTS545016B9SA02_090604PBDB00QCGHP31H-part2  /mnt           hfs       acl,user_xattr       0 0

I tried changing the mount point, hfsplus to hfs. But nothing changed :confused:

you should use hfsplus as fs type, not hfs !
And don’t use /mnt as fixed mount point in /etc/fstab! Create a directory and use it as mount point for your hfsplus partition.

What about:

mount -t hfsplus -o ro /dev/sda2 /mnt


This actually didn’t work. :shame: You see how often I mount hfsplus partitions! So I replaced this line with the following one. Now it mounts:

UUID=ccbbbd94-deb6-3a95-aadf-531952d1af33    /mac                               hfsplus       ro,noauto,nodev                  0   0

To mount it, you would just type:

mount /mac

provided you did create the directory /mac. You can give this directory another name if you wish.

That would be hfsutils (without hyphen). However these tools are not used to mount hfs partitions over a directory. There are used to read or write hfs volumes in a similar way that the mtools utilities handle DOS volumes. You can use them too. This is a different approach.
See man hfsutils and the manpages of the different commands: hmount, hcopy, etc.

I did create a new one but when it didn’t work, I tried changing the mount point and the type just to test. I have two hfs+ partitions, when I changed to the other partition, it worked! Now it works with everything, even my external. Thanks a lot for your help :smiley:

you can try NTFS&HFS for Linux Express