reading an absent floppy fd0 ?

With NO floppy on this machine, why is the attempt to access, and how to stop ?

Try command fdisk -l and reads only the existing hard drive partitions, then seems to stall as if trying to read something

linux-gedt:~ # fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000b52ff

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63     4209029     2104483+  82  Linux swap / Solaris
/dev/sda2   *     4209030    25189919    10490445   83  Linux
/dev/sda3        25189920    52452223    13631152   83  Linux
/dev/sda4       347631616   976773119   314570752    f  W95 Ext'd (LBA)
/dev/sda5       347633664   620253183   136309760   83  Linux
/dev/sda6       620255232   976752639   178248704   83  Linux
linux-gedt:~ #

Apparent problems in **/var/log/messages **

Terminal Command: grep -i ‘fd0’ /var/log/messages >/home/USERNAME/Downloads/fd0_20130305

Extracted from file: fd0_20130305


Mar  5 07:47:08 linux-gedt kernel:     0.000000] kernel direct mapping tables up to 0xafdeffff @ [mem 0x1fffd000-0x1fffffff]
Mar  5 07:47:08 linux-gedt kernel:     0.802569] pci 0000:00:11.0: reg 18: [io  0xfd00-0xfd07]
Mar  5 07:47:08 linux-gedt kernel:     9.441601] Floppy drive(s): fd0 is unknown type 13 (usb?)
Mar  5 07:48:04 linux-gedt kernel:    75.261076] end_request: I/O error, dev fd0, sector 0
Mar  5 07:48:27 linux-gedt kernel:    97.948839] end_request: I/O error, dev fd0, sector 0
Mar  5 07:48:27 linux-gedt kernel:    97.948857] Buffer I/O error on device fd0, logical block 0
Mar  5 07:48:50 linux-gedt kernel:   120.630379] end_request: I/O error, dev fd0, sector 0
----deleted-----
Mar  5 08:10:03 linux-gedt kernel:  1390.916173] FAT-fs (fd0): unable to read boot sector
Mar  5 15:02:11 linux-gedt kernel:     0.000000] kernel direct mapping tables up to 0xafdeffff @ [mem 0x1fffd000-0x1fffffff]
Mar  5 15:02:11 linux-gedt kernel:     0.805787] pci 0000:00:11.0: reg 18: [io  0xfd00-0xfd07]
Mar  5 15:02:11 linux-gedt kernel:     9.734745] Floppy drive(s): fd0 is unknown type 13 (usb?)
Mar  5 15:08:24 linux-gedt kernel:     0.000000] kernel direct mapping tables up to 0xafdeffff @ [mem 0x1fffd000-0x1fffffff]
Mar  5 15:08:24 linux-gedt kernel:     0.801576] pci 0000:00:11.0: reg 18: [io  0xfd00-0xfd07]
Mar  5 15:08:24 linux-gedt kernel:     9.480855] Floppy drive(s): fd0 is unknown type 13 (usb?)
Mar  5 15:11:08 linux-gedt kernel:     0.000000] kernel direct mapping tables up to 0xafdeffff @ [mem 0x1fffd000-0x1fffffff]
Mar  5 15:11:08 linux-gedt kernel:     0.812762] pci 0000:00:11.0: reg 18: [io  0xfd00-0xfd07]
Mar  5 15:11:08 linux-gedt kernel:     8.891820] Floppy drive(s): fd0 is unknown type 13 (usb?)
Mar  5 15:12:04 linux-gedt kernel:    75.164706] end_request: I/O error, dev fd0, sector 0
Mar  5 15:12:27 linux-gedt kernel:    97.848059] end_request: I/O error, dev fd0, sector 0
Mar  5 15:12:27 linux-gedt kernel:    97.848077] Buffer I/O error on device fd0, logical block 0
----deleted---- 
Mar  5 15:34:02 linux-gedt kernel:  1390.840644] end_request: I/O error, dev fd0, sector 0
Mar  5 15:34:02 linux-gedt kernel:  1390.840682] FAT-fs (fd0): unable to read boot sector
----deleted----
Mar  5 15:34:02 linux-gedt kernel:  1390.840644] end_request: I/O error, dev fd0, sector 0
Mar  5 15:34:02 linux-gedt kernel:  1390.840682] FAT-fs (fd0): unable to read boot sector
Mar  5 19:39:54 linux-gedt kernel: [16115.737790] end_request: I/O error, dev fd0, sector 0
linux-gedt:~ # 

As one of the Technically-Challenged, still with floppy drive(s) in cupboard, am aware floppy’s rarely used these days, believe not one on this machine, yet can see:

linux-gedt:~ # hwinfo --disk --short 
disk:                                                           
  /dev/fd0             Disk
  /dev/sda             ST500DM002-1BC14
  /dev/sdb             Generic Storage Device
linux-gedt:~ # hwinfo --disk 
25: None 00.0: 10600 Disk                                       
  [Created at block.245]
  Unique ID: kwWm.Fxp0d3BezAE
  SysFS ID: /class/block/fd0
  SysFS BusID: floppy.0
  SysFS Device Link: /devices/platform/floppy.0
  Hardware Class: disk
  Model: "Disk"
  Driver: "floppy"
  Device File: /dev/fd0
  Device Number: block 2:0
  Size: 8 sectors a 512 bytes
  Capacity: 0 GB (4096 bytes)
  Drive status: no medium
  Config Status: cfg=new, avail=yes, need=no, active=unknown
----deleted----

Similar problems found.

Not so clear how to resolve.

Perhaps, source: error.log entry

quote from #19: Re: error.log entry

Sebastian Gottschalk skrev:

Anders wrote:

Sebastian Gottschalk skrev:

Moe Trin wrote:

The file integrity checker should (if possible) be stored on removable
media along with the checkfiles. This removable media should normally
be stored in a secure place, and installed ONLY during the checks.
Installed? Booting a Linux floppy doesn’t require any installation.
No, but you need to mount it.
“/dev/fd0 /floppy/ext2 ext2 ro,root,noauto 0 0”

The floppy will of course mount itself.

Not necessary, if you use a line like the one above in fstab it will
never mount
by itself, and you have to be root to do it too.

/Anders

Changes to /etc/fstab not wish rush do without some more knowledgeable advice, as may not be the best solution :slight_smile:

Looking at systemctl wondered if this cause, symptom or possible solution to the problem. Might a change to systemctl stop attempt to load fd0, or make fd0 inactive or dead, and be more appropriate ?


linux-gedt:~ # systemctl  --all | egrep -i "fd0" 
dev-fd0.device                                                                             loaded active   plugged       /dev/fd0
sys-devices-platform-floppy.0-block-fd0.device                                             loaded active   plugged       /sys/devices/platform/floppy.0/block/fd0
linux-gedt:~ # 

Not sure yet how to STOP in systemctl yet nervously tried :

linux-gedt:~ # systemctl  stop dev-fd0.device
Job timed out.
linux-gedt:~ #
Mar  5 15:34:02 linux-gedt kernel:  1390.840644] end_request: I/O error, dev fd0, sector 0
Mar  5 15:34:02 linux-gedt kernel:  1390.840682] FAT-fs (fd0): unable to read boot sector
Mar  5 19:39:54 linux-gedt kernel: [16115.737790] end_request: I/O error, dev fd0, sector 0
Mar  5 19:51:43 linux-gedt systemd[1]: Job dev-fd0.device/stop timed out.
Mar  5 19:51:43 linux-gedt systemd[1]: Job dev-fd0.device/stop failed with result 'timeout'.
Mar  5 19:51:43 linux-gedt systemd[1]: Job sys-devices-platform-floppy.0-block-fd0.device/stop timed out.
Mar  5 19:51:43 linux-gedt systemd[1]: Job sys-devices-platform-floppy.0-block-fd0.device/stop failed with result 'timeout'.
linux-gedt:~ # 

Wiser solution ideas welcome :wink:
.

Check the BIOS, if a floppy entry is available, disable it.

you might want to use “systemd-gtk - Graphical front-end for systemd”

BIOS at boot did not appear to recognize any floppy fitted, though was mention of USB drives.

Inside /etc/fstab made change from the below #19: Re: error.log entry

Into /etc/fstab add this line /dev/fd0 /floppy/ext2 ext2 ro,root,noauto 0 0

Computer at boot still appears to recognize fd0 as a floppy, then follows /etc/fstab instruction to ignore, so this seems to work neatly.

Demands to mount fd0 only showing this initial incorrect identification:

 
Mar  6 14:52:14 linux-gedt kernel:     0.000000] kernel direct mapping tables up to 0xafdeffff @ [mem 0x1fffd000-0x1fffffff]
Mar  6 14:52:14 linux-gedt kernel:     0.802575] pci 0000:00:11.0: reg 18: [io  0xfd00-0xfd07]
Mar  6 14:52:14 linux-gedt kernel:     9.806972] Floppy drive(s): fd0 is unknown type 13 (usb?)

Search systemctl for floppy



linux-gedt:~ # systemctl  --all | grep -i "floppy" 
sys-devices-platform-floppy.0-block-fd0.device                                             loaded active   plugged       /sys/devices/platform/floppy.0/block/fd0
floppy-ext2.mount                                                                          loaded inactive dead          /floppy/ext2


search systemctl for fd0



linux-gedt:~ # systemctl  --all | grep -i "fd0" 
dev-fd0.device                                                                             loaded active   plugged       /dev/fd0
sys-devices-platform-floppy.0-block-fd0.device                                             loaded active   plugged       /sys/devices/platform/floppy.0/block/fd0
linux-gedt:~ # 


IMHO need improve settings in /etc/fstab where have line /dev/fd0 /floppy/ext2 ext2 ro,root,noauto 0 0

Reading : How to edit and understand /etc/fstab

Even if NOT intend mount, feel should be written better as (more accurate?) setting for any mount point, perhaps replace /floppy/ext2 ?

.