read-only root and long fstab overlay line

I’ve had a read-only root Leap 15.2 installation running for quite a while (installed as 15.1 while I still worked at SUSE). My /etc/fstab has an overlay entry for /etc which is 4088 chars long, so when I install any package updates, that pushes the line over what I suspect is a 4096 char limit and the system fails to boot (technically what happens is some of the overlays don’t get mounted). I then have to snapper rollback, blah blah blah.

This means I’ve fallen behind on system updates, and can’t install anything else. Which is mildly annoying. :slight_smile: I only have like 10 snapshots, but I have around 150 overlay entries in fstab. I tried just removing the ones which didn’t correspond to btrfs snapshots, but that did not go well at all. I suspect that what I actually need to do is to collapse several of them into a few snapshots. But read-only root is apparently not that popular outside of enterprises, and I never ran into is on SLES or SLES derivatives, so I’ve not found how to fix this particular problem. Does anyone here happen to know offhand how to fix this, or is this a bug that needs an issue filed on the github repo?