Raspberry pi 400 wifi

Got one of the new Pi400s (almost a pi4 with built in keyboard) and have got it running Tumbleweed. However, it is not quite the same as the pi4 and the wifi and bluetooth are not working. I have also tried it with Manjaro which required the firmware to be manually installed as the base system had very out of date files. I suspect Tumbleweed is the same.

Just wondering if there are others with a pi400 who have managed to get wifi and bluetooth working. Ethernet is fine and I’m typing this on the box. I’m expecting that there are driver modules needed too but I’ve not been able to track them down.

So, if anyone can help…

This model has caught my interest (I have Raspberry Pi 3 and 4 devices, one of which provides basic NAS function for me). Anyway, perhaps it’s a firmware issue? I assume that ‘kernel-firmware-brcm’ would provide the necessary firmware. Perhaps share the chipset details here.


Just in case this thread is of value here…

I found that the OpenSUSE Pi 4 versions just had too many pieces that do not work. No sound from you tube, jerky video.

I tried almost every Pi4 Linux out there - I have twenty three 32gb SSD one for every flavor of Linux I could find.

If you want everything to work you need the Loboris version of Ubuntu 20.04. The Official Ubuntu Pi4 version has many of the same bugs as OpenSUSE has.

Loboris version of Ubuntu Mate is the most stable Ubuntu Mate and you can get the latest 5.9 kernel as well. Loboris has fixed almost everything that Ubuntu left broken.
I have 2 8gb pi4’s with this and I installed pi-hole to get rid of ads and have my router point to it for DNS. I suspect he is working on 20.10 version that may be released soon. He also has support for booting off the USB from flash drives.



From what I can see, the chipset is BCM43456 and in lib/firmware there is BCM43455 but no 6 (I’m assuming that the pi400 is a step above a standard pi4 and a new firmware is required). BCM43456 is not in the kernel-firmware-brcm directory.

I did try Manjaro and did read the article you cited. Followed the instructions to the letter and it worked, mostly. Wifi and bluetooth both appeared and the wifi was fine. Sound over bluetooth was not good and I followed the thread to try and improve it but that is still a work in progress. When trying to pinch the files from Manjaro, I found that the opensuse files are xz compressed while the Manjaro ones are not. I had a go at compressing the files, loaded them but still no joy. That may be down to my incompetence at using xz though.
What I really need is an updated kernel-firmware-brcm-20201023-2.1.noarch.rpm although I could get away with some detailed instructions as per the Manjaro link.

I expect a new firmware package will be released shortly but I’d like to try and do a DIY solution for the learning experience.

Recommend you join the openSUSE ARM mailing list… Following is a link to archives and on it a link to subscribe.


Don’t know if the same person(s) maintain the Pi images, but the discussion is open and frank and hard working.
You should be able to ask any questions you want.
I’m sure your efforts, contributions, enthusiasm and initiative would be welcomed.


I have managed to get the internal wifi working! Using the files from the Manjaro fix (brcmfmac43456-sdio.bin, brcmfmac43456-sdio.clm_blob and brcmfmac43456-sdio.txt), copied them AS IS into /lib/firmware/brcm and rebooted. The internal wifi then worked. There are still a few issues (not surprisingly for such a new product) but generally, Tumbleweed works well on the pi400.
The adventure continues…

I took the KDE Tumbleweed image from here

https://en.opensuse.org/HCL:Raspberry_Pi4 , but my PI 400 keeps looping in the boot.

The leap KDE image boots fine but the keyboard does not work so I cannot login.

Can anyone who got a version of suse installed on their PI 400 , kindly posts some more detail here.

Raspberry Pi 400 is your complete personal computer, built into a compact keyboard. Featuring a quad-core 64-bit processor, 4GB of RAM, wireless networking, dual-display output, and 4K video playback, as well as a 40-pin GPIO header, it’s the most powerful and easy-to-use Raspberry Pi computer yet.](https://mcdvoice.me/) Raspberry Pi 400 is also available as part of a complete kit including a mouse, power supply, preloaded SD card, and more.