RALINK rt61/rt2561 working - no internet

The PCI card is working - firmware in /lib/firmware/.
I have my DHCP address from the netgear firewall router and can ping the wireless access point and (which is connected to) the netgear router, but I can’t get on to the internet.
I can get internet through windows using the wireless card (dual boot).
I can ping the wireless card from other PCs on the lan.

I have the gateway address (netgear) correct (for DNS), but not sure what’s missing - opensuse 11.

Any ideas?

Are you using networkmanager? What is the output of ‘/usr/sbin/routel’ and ‘/sbin/ifconfig’? If you can ping the router and ping other machines on the network, your hardware setup is fine. Check /etc/resolv.conf to see if your gateway is properly set.

Sorry for not replying sooner, I didn’t get auto notification.

I’m not using network manager - ifup using Yast.
I reinstalled suse 11, uninstalled the rt61 suse driver. Make/installed rt61-cvs-2008091717 from serial monkey no errors.
There was no rt61sta.dat file as the opensuse wiki suggested, so I’m running without that.

I am online using eth0 now - configured in Yast identically to wlan0. I can’t ping any URL with wlan0 (eth0 disconnected), though I can ping my wireless AP and router/gateway
Yast is set to Update DNS Data Via DHCP, so I assume that wlan0 should be getting DNS through the router which is DHCP server.

a7n8x-1g:/home/user10 # /usr/sbin/routel
target gateway source proto scope dev tbl 24 kernel link wlan0 16 link wlan0 8 link lo broadcast kernel link wlan0 local broadcast kernel link lo local local kernel host eth0 local broadcast kernel link wlan0 local local kernel host lo local local kernel host wlan0 local broadcast kernel link lo local local kernel host lo local 8 local kernel host lo local
default unreachable none lo unspec
::1 :: none lo local
default unreachable none lo unspec

a7n8x-1g:/home/user10 # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 RT61 Wireless ESSID:“001601D26580” Nickname:“a7n8x-1g”
Mode:Managed Frequency:2.462 GHz Access Point: 00:16:01:D2:65:81
Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=100/100 Signal level:-31 dBm Noise level:-79 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

a7n8x-1g:/home/user10 # ifconfig
lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:500 errors:0 dropped:0 overruns:0 frame:0
TX packets:500 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:35108 (34.2 Kb) TX bytes:35108 (34.2 Kb)

wlan0 Link encap:Ethernet HWaddr 00:1F:1F:05:CA:C0
inet addr: Bcast: Mask:
RX packets:14276 errors:0 dropped:0 overruns:0 frame:0
TX packets:758 errors:2 dropped:2 overruns:0 carrier:0
collisions:5 txqueuelen:1000
RX bytes:1258191 (1.1 Mb) TX bytes:25782 (25.1 Kb)



<misc comments here>


search a7n8x-1g

a7n8x-1g:/home/user10 # ifup wlan0
wlan0 device: RaLink RT2561/RT61 802.11g PCI
wlan0 warning: using NO encryption
DHCP client is already running on wlan0

what happens if you do the following

route add default router_ip

If that works, then your hardware is fine just need to rework the configuration a little.

I’ll try that this afternoon after work and will post my results - thank you.

I typed “route add default router_ip” at the root shell.

Response was:
SIOCADDRT: No such device

I still get an ip address for my machine from the gateway router through the access point. Apparently still can’t get DNS.

Wish I could find training material for Linux system admin without spending years in compsci classes.

Is your router also your DNS? Have you tried using dhclient to set the ip address after making certain the card is associated? What is the output of ‘route’? Try disabling the wired ethernet port by either using rmmod to remove the module for it or ‘ifdown ethX’ and then restart your wireless connection.

DNS addresses are provided to the wired router (gateway) by the ISP. I even tried using the actual DNS addresses in wlan0 configuration instead of the gateway address - didn’t make any difference. (read below)

a7n8x-1g:~ # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * U 0 0 0 wlan0
link-local * U 0 0 0 wlan0
loopback * U 0 0 0 lo
default UG 0 0 0 wlan0

a7n8x-1g:~ # ifdown eth0
(went down)

a7n8x-1g:~ # dhclient
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit ISC DHCP

Listening on LPF/eth0/00:11:d8:2d:4c:dd
Sending on LPF/eth0/00:11:d8:2d:4c:dd
Listening on LPF/wlan0/00:1f:1f:05:ca:c0
Sending on LPF/wlan0/00:1f:1f:05:ca:c0
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to port 67 interval 3
DHCPDISCOVER on eth0 to port 67 interval 2
DHCPDISCOVER on eth0 to port 67 interval 2
DHCPREQUEST on wlan0 to port 67
DHCPDISCOVER on eth0 to port 67 interval 3
bound to – renewal in 1583 seconds.

a7n8x-1g:~ # ifdown wlan0
wlan0 device: RaLink RT2561/RT61 802.11g PCI
a7n8x-1g:~ # ifup wlan0
wlan0 device: RaLink RT2561/RT61 802.11g PCI
wlan0 warning: using NO encryption
Starting DHCP Client Daemon on wlan0… . . . . . . . . IP/Netmask: ‘’ / ‘’

I’m able to access the Internet using wlan0.

I had assumed that the device which gets DHCP would get DNS too.

Now I will have to get encryption working…

Thanks so much David for taking the time to help !!

Can you tell me where you got the driver and firmware for your card?

I just installed OpenSuse 11 last night and am having one heck of a time getting it going. I work with Unix daily, but not to great extents, so I am basically still a noob at getting hardware working. This is made all the more fun by the fact that I have an invidia graphocs card so I am having to do everything through the command prompt until I get the networking up so I can get the drivers for the video card installed.

I found this link
Ralink Technology: Linux
But when I download the firmware and try to run ./rt2561.bin I get a “cannot execute binary file” error. So either I am doing it wrong, or the file is corrupted.

If there is another way I would love to know it.

Just found this thread
RT61 Wireless in SUSE 11.0 - openSUSE Forums

Will try that as soon as I get home. Leave it to me to try and do things the hard way.

That will work - reboot and open Yast2, network devices, network settings.
Disable eth0 if you see it there, or you won’t get on the internet with wlan0.

Go through the configuration and enter the router ID etc.

Have fun