Radiotray start niet op

Wanneer ik radiotray op de gewone manier wil opstarten gebeurt er niets.
Na opstart uit terminal krijg ik dit:

darknet@darknet-pc:~> radiotray
/usr/lib/python2.7/site-packages/radiotray/XmlDataProvider.py:23: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
cannot import name Gst
Traceback (most recent call last):
  File "/usr/bin/radiotray", line 15, in <module>
    radiotray_runner.main(sys.argv[1:])
  File "/usr/lib/python2.7/site-packages/radiotray/radiotray_runner.py", line 39, in main
    RadioTray()
  File "/usr/lib/python2.7/site-packages/radiotray/RadioTray.py", line 72, in __init__
    self.audio = AudioPlayerGStreamer(self.mediator, self.cfg_provider, eventManager)
  File "/usr/lib/python2.7/site-packages/radiotray/AudioPlayerGStreamer.py", line 55, in __init__
    self.souphttpsrc = Gst.ElementFactory.make("souphttpsrc", "source")
NameError: global name 'Gst' is not defined

Iemand met een oplossing?

Waarschijnlijk heb je iets als ‘python-gst’ nodig. Ik zal er in de loop van de dag / morgen even naar kijken, maar ik denk dat 't zoiets is.

Mijzelf maar even aanhalend. Werkt hier ook niet. alhoewel radiotray wel opstart:


zypper in radiotray
Gegevens van installatiebron laden...
Lezen van geïnstalleerde pakketten...
Pakketafhankelijkheden oplossen...


De volgende 5 NIEUWE pakketten zullen worden geïnstalleerd:
 ** python-gst** python-notify python-pyxdg radiotray radiotray-lang                                                                                             
                                                                                                                                                             
Het volgende aanbevolen pakket was automatisch geselecteerd:                                                                                                 
  radiotray-lang

Zoals je ziet wordt python-gst meegeïnstalleerd. Wat ik niet begrijp is waarom dat bij jou niet gebeurd is. Hoe heb je 't pakket geïnstalleerd?
Bij mij start het programma wel, maar werkt niet. Ik heb wat kleine hacks geprobeerd, maar werken doet 't niet.
Overigens zie ik dat 't programma niet echt fanatiek onderhouden wordt. De laatste ‘changes’ zijn van meer dan twee jaar geleden, er is alleen een patch van 8 maand oud.

Ik zou hierover een bugreport indienen, kan via bugzilla.opensuse.org

Gewoon de installatie via software mangement in yast.
Zou wel willen een bugreport indienen, maar ben nog nieuw bij opensuse en moet nog even mijn weg vinden ;).

Hopelijk is dit een geslaagde onderneming:
https://bugzilla.opensuse.org/show_bug.cgi?id=1017473
Laat me even weten of dit ok is.

Prima in eerste instantie. De packager(s) zal wel vragen om output, maar daarover krijg je wel mail als iemand 't oppakt.

Is er iemand die een gelijkwaardig programma kan aanraden?
Dus iets waar je radio kan op laten streamen met de url’s die jezelf ingeeft.

Heb intussen ‘great little radio player’ hier draaien en deze werkt perfect:)

Voor zover ik weet speelt VLC zo’n beetje alles af. Al geprobeerd?
Of, misschien beter nog: kradio ? ( deze moet je opstarten met ‘kradio4’.

Deze heb ik 's even geïnstalleerd. Moest even de juiste URL hebben, maar ik luister op dit moment naar NPO6. kradio is een KDE4 programma, ik zie in de repos nog geen port naar Plasma5. Het zou kunnen zijn dat je in jouw geval wat extra codecs nodig hebt. Ik heb zelf al 't e.e.a. aan multimedia zooi geïnstalleerd ( gebruik ffmpeg nogal 's op de command line ), er werden geen extra dependencies geïnstalleerd. De NPO6 URL heb ik hier http://listenlive.nl/board/message.php?id=4207 vandaan gehaald.

great little radio player voldoet perfect aan mijn noden, kradio zal ik niet proberen aangezien ik de mate draaien heb en geen kde-dependencies wil installeren.

Mooi zo, veel plezier ermee.