radeon issue in 11.1


I’m using SuSE (7.x, 8.x, 9.x, 10.x) for several years and I never had problems with my hardware configuration. But with 11.1 I have an issue with the Radeon graphic card.

At first the installation failed when detecting the graphic card.
Now I’m only able to start the system in failsafe mode.
When I try to activate the radeon driver in the xorg.conf and restart, the cursor appears shortly on the top left and then the screen remains dark with no chance to switch into a console (Alt-F1,Alt-F2,…). I’ve installed the monitor on the VGA and on the DVI port - no difference.
There is only one way to start the system correctly: if I boot into Windows before I restart and boot into Linux everything works perfect with the radeon driver.
That can’t be the solution !
Has anybody successfully installed 11.1 with a Radeon 9250 or 9200 card?

I’ve tried several options in the xorg.conf, but none of them solved the issue:

Section “Device”
BoardName “RV280 5960”
Driver “radeon”
Identifier “Device[0]”

Busid “PCI:0:0:1”

VendorName “ATI”

Option “Monitor-VGA-0” “Monitor[0]”

Option “Monitor-DVI-0” “NoMonitor”

Option “UseEDID” “FALSE”

Option “ConnectedMonitor” “DFP”


Please help.


Follow exactly this steps:

How To: ATI Drivers OpenSUSE 11.1 - Ubuntu Forums

Unfortunately the Radeon 92xx is not supported by the current ATI driver …

Try this:
ATI Installer HOWTO for SUSE/Novell users

Just to repeat: the “radeon” driver works perfect (incl. 3D support), if I shortly boot into Windows before I start openSuSE 11.1, but it fails if I power on the PC and boot directly into openSuSE 11.1.
It can’t be the solution that you need Windows as a “starter” for openSuSE 11.1.
It seems as if openSuSE does not correctly initialize the Radeon 92xx after power-on.
I guess I have to switch over to (k)ubuntu …

Have you tried playing with the AGPMode option? I assume it’s an
AGP card? You could start with a line like this in the device

Option  "AGPMode" "1"

If that works continue with a value of “2” and possibly “4”.

I have tried Option “AGPMode” “1” and almost all possible options in xorg.conf - without success !

The only difference in Xorg.0.log is the following

Successful startup (with boot into Windows first then restart and boot into openSuSE 11.1)

(==) RADEON(0): Using AGP 8x
(II) RADEON(0): [agp] Mode **0x1f00400a [AGP 0x10de/0x00e1[/b]; Card 0x1002/0x5960]
(II) RADEON(0): [agp] 8192 kB allocated with handle 0x00000001

Unsuccessful startup (boot directly into openSuSE 11.1 after power-on)

(==) RADEON(0): Using AGP 8x
(II) RADEON(0): [agp] Mode **0xff00020a [AGP 0x1002/0x5960[/b]; Card 0x1002/0x5960]
(II) RADEON(0): [agp] 8192 kB allocated with handle 0x00000001

I don’t know what Mode **0x1f00400a [AGP 0x10de/0x00e1[/b] means and how to force the graphic card to use this mode even if the system is booted directly into openSuSE 11.1.

Any ideas?******

Well I’m not on the same hardware so I can’t test anything,
but there are a couple of other options to force the AGPMode,
AGPMask and AGPv3Mask, they take the following values:

0x00000001 = AGP 1x disable (force 2x and/or 4x)
0x00000002 = AGP 2x disable (force 1x and/or 4x)
0x00000004 = AGP 4x disable (force 1x and/or 2x)
0x00000010 = fast writes disable
0x00000200 = Sidebanding disabled

0x00000001 = disable AGP 4x (force 8x)
0x00000002 = disable AGP 8x (force 4x)

So the following line in the device section:

Option "AGPv3Mask" "0x00000001"

should force 8x. I suppose they’re risk free to try, but you’re
on your own.

well, I’m on x1950 agp and had the same problem

I used sax2 -r -m 0=vesa
to boot into gnome and there I installed fglrx from ati website. I couldnot get radeon driver to work. maybe you will have more luck with latest test builds of radeon driver

forget the proprietary ATI driver with older cards. Use the X11 OSS one. it works perfectly, with 3d acceleration.

As a last activity I tried several AGPMask and AGPv3Mask options in xorg.conf, but they changed nothing.
While I’m writing this lines I’m already on kubuntu 8.04 which runs perfect with the Radeon 9250 (just tested with ppracer and gl-117).
The openSuSE 11.1 adventure took me about one week and a lot of frustration. Maybe I will test it again, when release 20.x will be available.
By the way: the best SuSE release I ever had was 9.3 …