Quick Question: Compiz Fusion on Startup.

The Thread title says it…

How do I set up Compiz Fusion on startup? lol!


In kde4 just enable desktop effects in the Configure Desktop

not sure in gnome

use control center
session manager
change window manager to compiz
or you can install fusion icon and start it from there

Thanks…I´ll try that later on. Points raised.


not really… i mean in kde4 if you just enable desktop effects it will NOT use compiz as default windows manager.
You may also need to go to Configure Desktop-Default Applications-Window Manager and choose Compiz. If you dont do that you will use KWin effects NOT Compiz effects which is a little different.

Err… thanks. I am on KDE 4 actually. How to set it up there?


You may add comfiz-fusion in the systemsettings autostart to start it as soon as you login.
If you want it not to start in the next session, just click the tick box to disable.

Compiz is kinda built in you just need to enable the desktop effects in Configure Desktop and adjust settings there as required

To set up compiz as the default you go to kickoff>configure desktop>default applications>window manager tab>use different window manager>compiz>configure>apply

I personally cant use compiz because it freaks out my tablet. Anyone have any ideas why that is? I have an acer c301.

There is no need to employ compiz as the WM in kde4. Keep kwin and enable desktop effects in Config Desktop.
If you update kde4 to Factory 4.2 you will love it.

I am curious, if I go to the YAST>Software> search for compiz, can I uncheck all the compiz checked items and still have the 3d effects work? I am new to all this and am not clear on if some of the compiz program works in conjunction with KDE4, etc. I would like to shut off any of the crap I dont need. Plus as I mentioned in my previous reply, when I enabled compiz it screwed up my system. I had to shut it off. But I am unsure if I can uncheck the compiz stuff in the software settings.

Having Compiz effects under kwin is not the same as making it your WM.

If you have installed Compiz (like the OneClick method) you will have probably have this repo in your list
Index of /repositories/X11:/XGL/openSUSE_11.1

You don’t need to delete it and it’s probably best you don’t - unless you are confident you know what you are doing.

Just switch to kwin for your WM, enable desktop effects from config desktop.

Thanks for the reply. I dont really know what I am doing…lol. So unless someone can give me the details I will take your advice. The thing is I intermittently have issues using some of the 3D effects. They freeze up at times. Mostly the cube wont spin. I am under the assumption that seeing as I have 512 MB of RAM right now, I am over taxing the resources availaibe on my tablet. So my thought was to shut off anything I dont need…
I killed the beagle program, and checked the Kerry files, they werent turned on. Then I updated the repositories through the Yast>software, etc. So now I am just trying to think of other tweaks that may free up some ram. I will be upgrading to 2 GB of RAM in a week or so, I am sure that will help this old turd handle the 3D better, but until then I want to shut off any services that I dont need. how does one find out what programs i dont need?? Also, what is the reason I cant use the sphere or cylinder and some other 3D effects? is that something that has to be supported with your graphics card specifically or what?

Thanks again!
PS-this whole linux thing is addictive! I got my tablet pen to work last night…I need more stuff to do…lol

well to be honest with only 512
you are better without effects.

I just added 2GB to my lap - only £16 UK

I know…but I just started playing with linux, and Suse 11.1 so I NEEDED to play with the 3D…As I said I will be upgrading to 2GB soon. Is the low RAM what is making the other effects not work then?
Take care,

If I just enable desktop effects… nothing happens. If I pick compiz as my WM, I get wobbly windows etc… but on reboot I loose my window borders and all applications are full screen.

Is there something I am missing to get “the wobbly windows” and keep Kwin?

Using 9800 GT and have the nVidia drivers installed (get the nVidia logo on boot)

i have the same problem when I use Compiz. Plus my system seems to crash. So I just went into the KDE desktop configuration, clicked on enable 3d, then went to the effects tab and clicked on wobbly windows and Cube. It works for me…good luck.

Nice one!.. this will do 4 now :wink: