Question on nvidia official drivers


It’s until now that I had the time to update Suse. I’ve been using 12.3 until now.

Ok, this time I have a problem with the nvidia official driver.

My card is EVGA Geoforce GTX 980

The suggested driver are the G04 series which says it’s from cards 800 and newer. After installation and rebooting the system either hangs or shows a black screen.

Noveau is blacklisted by the installation with a file on et/modeprob.d

So I had to once again doa clean install. Using Noveau at the moment, and I prefer the official driver from nvida and from the nvidiia repository.

Something I noticed, when I installed the drivers on Suse 12.3 it was the ‘.desktop’ set, in this case it shows only the ‘.default’ set.

So, did I install the wrong set of drivers ?

Thank you.

a small correction. It’s the G03 set that I tried to install.

You want 04 or 05 for that card I believe

Note you should not need to reinstall to remove a driver just boot to a terminal (run level 3) and run yast from command line

Since 12.3 there was added another competent FOSS DDX driver for NVidia. Nouveau upstream then became an optional DDX driver. openSUSE packaging overrides the default, by default, by including the nouveau DDX in a default pattern. You might wish to try the other, which is newer, named modesetting, included in the xorg-x11-server package, before installing the non-FOSS driver. To do so, uninstall xf86-video-nouveau, be sure nouveau is not blacklisted, and that nouveau is not blocked by a cmdline option (nomodeset or nouveau.modeset=0).

Thanks for the info. I did have to re-install because the black screen appears while loading the OS and included the recovery/safe mode.

I installed the G04 set and it worked. Thank you. I very much prefer the official drivers, noveau is a good effort but caused constant flickering while the officlal drivers don’t give me trouble and works perfect in the few games that I use: Grid and War Thunder.

Thanks again for the help, I prefer always to ask when something goes wrong since it’s my work machine.