qjackctl crashes

For unknown reason qjackctl (frontend for jack audio system) started crashing. I started it in the konsole, msg was core dump (Iwonder where).
I tried to start it under root , the msg was

QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
Segmentation fault (core dumped)

There seams to be something wrong with the ownership (of what ?) …

Does anybody have an idea ? … That would be much appreciated since I would need qjackctl to test a soundcard connection.

Thanks for your help

Only about this part.

I doubt you should run such an end-user application as root (remember: never run something as root when not really needed). And it seems that the application thinks likewise. The end-user has UID 1000 and root has of course UID 0. Thus better forget about this side path and concentrate on your real problem.

… sure wrong path but why does an application all of a sudden does not work ?

and where would I find the core dump.? I cant see what triggered it

Thanks for your help

Solved …
There is in the hidden files of a user …/.config/mcbc.org/ the file QjackCtl.conf. So I saved/renamed that file as old.conf.

No hoping when starting qjackctl a new config file will be created with qjackctl working … and it worked. !!!

So there must be an entry in the conf file which let qjackctl crash.

anyway it works now


You could of course compare both files and see if it tells you something. But maybe it never happens again.