Qgis on 11.3

My system is 11.3/KDE4.6 on AMD_64. All are up to date.

I am attempting to run Qgis.
Found and installed the repository:
Index of /repositories/Application:/Geo/openSUSE_11.3

Installed qgis 1.6 using Yast.

When starting, I get the following messages

 p, li { white-space: pre-wrap; } Couldn't load PyQGIS.
Python support will be disabled.

Traceback (most recent call last):
  File "", line 1, in 
RuntimeError: the sip module implements API v8.0 to v8.1 but the qgis.core module requires API v7.1

 Python version:
2.6.5 (r265:79063, Oct 28 2010, 20:56:23) 
[GCC 4.5.0 20100604 [gcc-4_5-branch revision 160292]]

So there is a dependency mismatch.

Has anyone found a good workaround?

Not sure I want to back down Python and break something else.

Hi, same problem here and no convenient solution in sight :-(.

1 - roll back all KDE stuff that uses the newer SIP or 2 build QGIS from Trunk using ccmake to select the versions of various libs that are known to work

from: [Qgis-user] SIP problem on startup](http://lists.osgeo.org/pipermail/qgis-user/2011-February/011252.html)