proxies testing

When I tried to test proxy under Network services-proxy it comes back as url malformed.
I am trying to use a free proxy service.On the checking update with xen updater it comes back as repo 1-7 Valid metadata not found at specified URL(s).

[QUOTE=phisics;2137541]When I tried to test proxy under Network services-proxy it comes back as url malformed.
I am trying to use a free proxy service.On the checking update with xen updater it comes back as repo 1-7 Valid metadata not found at specified URL(s).how to find the URL from the IP address

On Tue, 16 Mar 2010 19:36:03 +0000, phisics wrote:

> how to find the URL from the IP address

You could try using nslookup or dig with the IP address and see what it
resolves to.

Jim


Jim Henderson
openSUSE Forums Administrator

I got nslookup name from the server address, look like this: linux-uq3h:/home/abicore # nslookup 216.239.116.65 -timeout=120
Server: 192.168.0.1
Address: 192.168.0.1#53

Non-authoritative answer:
65.116.239.216.in-addr.arpa name = c13-ss-2-lb.cnet.com.

Authoritative answers can be found from:
116.239.216.in-addr.arpa nameserver = ns.cnet.com.
116.239.216.in-addr.arpa nameserver = ns3.cnet.com.
116.239.216.in-addr.arpa nameserver = ns2.cnet.com.
ns.cnet.com internet address = 216.239.127.70
ns2.cnet.com internet address = 216.239.123.201
ns3.cnet.com internet address = 62.108.138.30

Now I tried proxy.ns.cnet.com and I get:

  • <url> malformed

curl: (3) <url> malformed

  • About to connect() to proxy proxy.ns.cnet.com port 1080 (#0)
  • Trying 72.215.225.9… Connection refused
  • couldn’t connect to host
  • Closing connection #0

curl: (7) couldn’t connect to host
Now what I am doing wrong?

On Thu, 18 Mar 2010 04:36:01 +0000, phisics wrote:

> I got nslookup name from the server address, look like this:
> linux-uq3h:/home/abicore # nslookup 216.239.116.65 -timeout=120 Server:
> 192.168.0.1
> Address: 192.168.0.1#53
>
> Non-authoritative answer:
> 65.116.239.216.in-addr.arpa name = c13-ss-2-lb.cnet.com.
>
> Authoritative answers can be found from: 116.239.216.in-addr.arpa
> nameserver = ns.cnet.com. 116.239.216.in-addr.arpa nameserver =
> ns3.cnet.com. 116.239.216.in-addr.arpa nameserver = ns2.cnet.com.
> ns.cnet.com internet address = 216.239.127.70 ns2.cnet.com
> internet address = 216.239.123.201 ns3.cnet.com internet address =
> 62.108.138.30
>
> Now I tried proxy.ns.cnet.com and I get: * <url> malformed
>
> curl: (3) <url> malformed
> * About to connect() to proxy proxy.ns.cnet.com port 1080 (#0) *
> Trying 72.215.225.9… Connection refused * couldn’t connect to host
> * Closing connection #0
>
> curl: (7) couldn’t connect to host
> Now what I am doing wrong?

What type of proxy is this supposed to be?

Jim


Jim Henderson
openSUSE Forums Administrator

the proxies supposed to be:
http:// for http slot
http:// for http(s) slot
http:// for ftp slot
under network services proxy in Yast.

On Thu, 18 Mar 2010 14:56:01 +0000, phisics wrote:

> the proxies supposed to be:
> http:// for http slot
> http:// for http(s) slot
> http:// for ftp slot
> under network services proxy in Yast.

If you use the “test proxy settings” button in YaST, what result do you
get?

Jim


Jim Henderson
openSUSE Forums Administrator

  • <url> malformed

curl: (3) <url> malformed

curl: (5) Couldn’t resolve proxy ‘www.arandomproxy.com

and I tried this:

  • <url> malformed

curl: (3) <url> malformed

curl: (5) Couldn’t resolve proxy ‘proxy.arandomproxy.com

On Sun, 21 Mar 2010 00:16:02 +0000, phisics wrote:

> * <url> malformed
>
> curl: (3) <url> malformed
> * getaddrinfo(3) failed for www.arandomproxy.com:1080 * Couldn’t resolve
> proxy ‘www.arandomproxy.com’ * Closing connection #0
>
> curl: (5) Couldn’t resolve proxy ‘www.arandomproxy.com
>
> and I tried this:
>
> * <url> malformed
>
> curl: (3) <url> malformed
> * getaddrinfo(3) failed for proxy.arandomproxy.com:1080 * Couldn’t
> resolve proxy ‘proxy.arandomproxy.com’ * Closing connection #0
>
> curl: (5) Couldn’t resolve proxy ‘proxy.arandomproxy.com

Try changing the URL to “http://proxy.arandomproxy.com:1080” (or whatever
the proxy is) - I think you probably need to include the scheme part of
the URL as well as just the DNS name and port.

Jim


Jim Henderson
openSUSE Forums Administrator