Programme gehen nicht mehr……

Hallo,

auf meinem Netbook, habe ich OpenSuse 11.4 installiert und das lief eigentlich die ganze Zeit auch fein.
Jetzt plötzlich und auch ohne Grund gehen diverse Anwendungen nicht mehr zu öffnen… z.B. Yast, KPassX usw.
Sind ja nicht gerade Programme die irgendwie unwichtig sind, so das ich jetzt ziemlich doof da stehe.
Zum besseren Verständnis, ich öffne ein Programm, sehe unten in der Statusleiste das es geladen wird und bevor sich das Fenster öffnet o.ä verschwindet der Eintrag unten wieder. Keine Fehlermeldung und nix.

Gefällt mir nicht und ich hab keine Ahnung was ich machen soll um das zu beseitigen, kann mir jemand weiter helfen bitte?

Dank im Voraus und viele Grüße

Andreas

ich öffne ein Programm, sehe unten in der Statusleiste das es geladen wird und bevor sich das Fenster öffnet o.ä verschwindet der Eintrag unten wieder. Keine Fehlermeldung und nix.
Betrifft es vielleicht nur die GUI-Programme welche root-Rechte benötigen?
Welche Oberfläche verwendest du (LXDE, XFCE, GNOME, KDE, etc.)?

bzgl. YaST2:
Du kannst YaST2 u.a. auch aus einem Terminal starten, vorausgesetzt es lässt sich noch ein Terminalprogramm öffnen :slight_smile:

/usr/bin/xdg-su -c /sbin/yast2

Im Terminalfenster siehst du dann etwaige Fehlermeldungen, mitunter fehlt eine Datei (lib), etc.
Unter /var/log/YaST2/ befinden sich die Logfiles…

Hallo,

versuch mal die Programme aus der Konsole heraus zu starten.
(Alt+F2 -> konsole)
Die Fehlermeldungen die du dabei erhältst Postest du dann hier.

LG

On Tue, 12 Jul 2011 17:44:40 +0530, tux93
<tux93@no-mx.forums.opensuse.org> wrote:

> Hallo,
>
> versuch mal die Programme aus der Konsole heraus zu starten.
> (Alt+F2 -> konsole)
> Die Fehlermeldungen die du dabei erhältst Postest du dann hier.
>

zuerst was tux93 gesagt hat, und dann kannst du auch mal “zypper ve” in
einer konsole eingeben, nachdem du dich als “root” angemeldet hast. was du
da schreibst sieht mir nach unpassenden libraries oder falsch
zusammengestellten paketen aus. wenn “zypper ve” sagen sollte, daß alle
abhängigkeiten (wie heißt das auf deutsch?) erfüllt sind, kannst du auch
mal das ergebnis von “zypper lr -d” hier zeigen. (am besten zwischen

...

tags, damit’s lesbar wird.)


phani.

Sorry das ich jetzt erst antworte und danke bis hierher für die Antworten,

also jetzt wird´s echt heftig, ich kann nicht mal mehr das Terminal/Konsole aufrufen, via alt+F2 kam kurz oben ein Feld eingeschoben, das dann aber nix weiter gemacht hatte (nach Texteingabe) und manuell über das Startmenü geht es wie mit den anderen Programmen beschrieben…

Jetzt ist guter Rat teuer, weil ich es ja nicht mal schaffe meine Daten auf einen USB-Stick zu ziehen…… (oder kann man das doch noch irgendwie hin bekommen?)

Gibt es so etwas wie bei OSX, das man die install DVD rein haut und eine Repair Funktion das System ohne Datenverlust wieder herstellt?

Dicken Dank im Voraus und viele Grüße

Andreas

P.S. ich bin was Terminal und Co angeht ein Noob und habe (warsch. weniger) nur rudimentär Ahnung was zu tun ist…… also weiß nicht mal wie man ein Programm via Terminal startet, daher bitte Step by Step für mich

Alt + F2 → dort “konsole” oder “terminal” eingeben & Enter → dann startet eine Konsole. Dort das von redkiwi vorgeschlagene Kommando reintippen und mit “Enter” ausführen, die dann hoffentlich erscheinende Ausgabe hierher kopieren, damit wir sie lesen können.

Die Konsole ist unter Linux kein Muss, aber auf lange Sicht ist es schon besser, wenn man sich mit ihr halbwegs souverän bewegen kann - und schwer ist es auch nicht. Hier mal ein schöner Einstieg in die Materie, kannst ja mal bei Gelegenheit reinschauen: http://www.bin-bash.de/

Hm, ja, nee… also wie gesagt erschien das kleine Textfeld (am oberen Bildschirmrand), konnte auch was eingeben, ist aber nichts passiert. Wenn ich jetzt Alt+F2 drücke, passiert einfach nichts mehr…… Sch…

Geht da noch was?

btw. danke für den Link

Hallo TriggerTrix

Zuerst einmal brauchst Du eine Konsole, sonst geht wirklich gar nichts mehr. Versuch bitte folgendes:

Drücke gleichzeitig: Ctrl+Alt+F1 (kann auch F2 oder F3 sein) und es sollte dann ein schwarzer Bildschirm erscheinen, wo Du Dich als Benutzer root einloggen kannst. Dann gibst Du ein:

df -h

Was kommt dabei raus? Ich möchte zuerst 100%ig sicher sein, dass nicht irgend ein Unglücksfall Deine Harddisk aufgefüllt hat. Dann läuft nämlich nichts mehr, wie von Dir beschrieben.

Man kann auch einfach mal im Programmenü stöbern, ob sich dort nicht zufälligerweise eine Konsolenanwendung befindet (mal im Ernst: ein klein wenig Eigeninitiative wäre schon nicht ganz übel).