Problems with Samba


I had Samba working under 13.2 and now with tumbleweed it has stopped. Windows 10 doesn’t even see the Linux machine. I have one computer with tumbleweed and another with Windows 10. Windows 10 does not see the Linux machine. The windows 10 machine is set for the workgroup: workgroup as well as the Linux machine. The two machines are on the same wired network.
I have done:
systemctl start nmb.service
systemctl start smb.service

The smb config file (/etc/samba/smb.conf) is: :

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
        workgroup = WORKGROUP
        passdb backend = tdbsam
        server string = Samba Server %v
        netbios name = tumbleweed
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        dns proxy = no
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = No
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        domain logons = No
        domain master = No
        security = user
        usershare max shares = 100
        wins support = No
        wins server =
        os level = 65
        preferred master = Yes
        name resolve order = bcast host lmhosts wins 
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = No
        read only = No
        inherit acls = Yes
        comment = Network Profiles Service
        path = %H
        read only = No
        store dos attributes = Yes
        create mask = 0600
        directory mask = 0700
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

        inherit acls = Yes
        path = /home/foster
        read only = No

## Share disabled by YaST
# [netlogon]

Did you make provision for passage through the firewall? Yast ==> Security & users ==> Firewall ==> Interfaces ==> set network Device to External. And Firewall ==> Allowed Services ==> set these allowed services: Netbios server, Samba client, Samba server.

Also, check the daemons are still working, perhaps this: Yast ==> System ==> Services ==> nmb (Samba NMB daemon) ==> set to “enabled” and “active”. And similarly for smb.

Ah swerdna,

I’ve read some of your tutorials on Samba in the past. For that I thank you as they were a big help!

Both the nmb and smb services are enabled and active. As for the firewall I have it stopped when trying to work with samba. (Didn’t need another issue getting in the way).

If you’re using share names instead of IP addresses, what happens if you test name resolution?

So, for example if your Win10 can’t “see” the Tumbleweed machine, from your Win10, ping your TW machine by IP address and then again by machine name. Maybe re-inspect hosts and lmhosts files on client machines and any DNS(looks like you have WINS disabled at least on your SAMBA server). I don’t know if your TW machine hostname is the same as the netbios name which is set to be “tumbleweed” (Your machine’s full NetBIOS machine name appears to be tumbleweed.WORKGROUP).

Especially if you recently replaced your 13.2 machine with your Tumbleweed, be aware that your network and possibly local hostname and netbios name resolution could have changed, so you may also need to purge various caches.


Your [global] stanza is quite full, confusing. Perhaps it should be tidied up. And under the [global] you have defined 7 shares, some doubling up on each other. Perhaps they should be rationalised. So is this what you want:

  • a network name (for win10 to see) named “tumbleweed”?
  • a standard old fashioned workgroup called “workgroup”?
  • and a share that allows access to the entire home directory of linux user foster (stanza [FA])?

If that’s the goal/s, would you like guest access to [FA] (i.e. no username/password) or secure access (i.e. access by username/password)?

I’ve seen upgrades turning firewalls on and off occasionally, it doesn’t hurt to make a quick check with these commands (as root I think):

systemctl status SuSEfirewall2
systemctl status SuSEfirewall2_init

Just to be thorough, I would simplify the smb.conf file to be like this:

workgroup = WORKGROUP
netbios name = tumbleweed
name resolve order = bcast host lmhosts wins
server string = ""
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
use client driver = yes
map to guest = Bad User
local master = yes
preferred master = yes
os level = 65
usershare allow guests = No
usershare max shares = 100
usershare owner only = False

path = /home/foster
read only = no
force user = foster
valid users = foster

This would require that you set or reset the credentials for user foster by running command:

sudo smbpasswd foster

After doing all of that you should run these four commands to (a) make the changes propagate and (b) check it’s working:

sudo systemctl restart smb; sudo systemctl status smb


sudo systemctl restart nmb; sudo systemctl status nmb

Then I would reboot windows and linux computers and then run the “smbtree” command to see if samba is communicating OK, you should get something like this:

frednurk@leap421:~> smbtree -N
                \\LINLEAP\IPC$                  IPC Service ("")
                \\TABASUS\IPC$                  Remote IPC
                \\TABASUS\C$                    Default share
                \\TABASUS\ADMIN$                Remote Admin

The simplified file smb.conf and these restarts and tests should work and should show what’s happening around the LAN. If it doesn’t work then you could dig deeper into the engineroom of samba with the knowledge that you had already configured samba correctly at the top level.

Regarding the post of tsu2, reminds me to say this:

I suppose to be even more thorough, this is worth a read, from 2004:

Whereby the suggestion is to change the file nsswitch.conf by adding wins to the hosts string like so:

hosts:  	files mdns_minimal [NOTFOUND=return] dns wins

I have found it important over the years but not sure if it’s still necessary [FWIW].

A <very> many networks were still being set up with NetBIOS name resolution in 2004.
Today, it’s probably fairly rarely done intentionally.

But, when NetBIOS name resolution is an option, a decision needs to be made whether to implement or not, because many systems still prioritize NetBIOS name resolution before Hostname resolution, so there really shouldn’t be any halfway decision to implement. IMO NetBIOS name resolution should either be fully implemented or not. No decision needs to be made about Hostname resolution because today it’s the method used by all modern networks including the Internet, Active Directory and I expect OpenLDAP. IMO the reason why SAMBA still often implements NetBIOS name resolution is because of how long SAMBA4 was delayed (about a decade in development), so NT4-style networking was the SAMBA standard until only a couple years ago when MS finally got involved to fix the remaining problems, excepting DC data replication(I don’t know if even that has been fixed after a couple years).


Wow. A lot to read and understand. I agree that simplification is best. I know what I am going to do tomorrow.

Thank you all for the information!

I reactivated the firewall making sure the services are opened. And it works.

The problem I found is we recently upgraded to AT&T U-Verse from DSL. AT&T’s tech had the Linux machine use the static IP address assigned to the computer instead of using the 192. type address. This in turned screwed up other machines trying to reach the Linux machine using samba. Of course I now have a problem getting to the web server now but that is another issue.

Since the router has a firewall and each machine has a firewall as well, should the Linux machine’s firewall (and it only has one NIC) to have an internal zone assigned?

Quite a tangle.

Since the router has a firewall and each machine has a firewall as well, should the Linux machine’s firewall (and it only has one NIC) to have an internal zone assigned?

In a workgroup, all members are prima-facie the same, so firewalls should all be the same. They each/all put up max protection (external zone setting), and then allow tunnels for Samba to travel through (aka ports). So keep them all at “external” setting.