Problems with Laptop openSUSE 11.0 64-bit

I am having a couple of problems with my Hp dv2000 opensuse 11.0 system:

> Wireless not working (Intel Wireless)

> Sound not working (Intel Sound Card)

Any ideas?


Run the following command in a console as su (root) and post the results here;


Also, can you describe your hardware in more detail than simply ‘Intel’?

I got the following

zaid@linux-rmkm:~> lspci
bash: lspci: command not found

sudo lspci

Then enter roots password.

Please try to work your way through the open suse audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

If that does not help you, then please post here the output URL(s) provided to you by running the two diagnostic scripts: Scripts_to_run_to_obtain_detailed_information

and please also provide the output of the following commands run in a terminal/xterm/konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

This is what I got from the output.

btw my Network Card is Intel Pro Wireless 3945BG
Sound Card 82801G (ICH7 Family) High Definition Audio Controller

zaid@linux-rmkm:~> rpm -qa | grep alsa
zaid@linux-rmkm:~> rpm -qa | grep pulse
zaid@linux-rmkm:~> rpm -q libasound2
zaid@linux-rmkm:~> uname -a
Linux linux-rmkm #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x86_64 x86_64 GNU/Linux
zaid@linux-rmkm:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
# u1Nb.uHk6lYgTyh8:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel

Thankyou for that. It appears you have installed way too many “pulse audio” applications. IMHO the pulse audio is still not completely mature in 11.0, and its far better to remove them all, than install them all.

Please, could you run the diagnostic scripts that I asked previous:

If you have a problem running those scripts, please advise. If the wget command does not work for you, then just right click and download the files to your hard drive. #and run with: bash
tsalsa: #and run (with root permissions): bash tsalsa

I need you to run those as they help me confirm you have the correct mixer settings, and they also provide me your audio codec. There is a possibilty the command
cat /proc/asound/cards
will provide your codec, but it is not always successful, hence I need you to run the scripts.

Thanks Sound Works, but it does not work with skype for some reason plus when multiple apps are open only one can use the sound.

i still have problems with wireless

Please Check

I have a similar puter running 10.3 and KDE 3.5.9 with skype working. 11.0 is probably similar to set up.

If you sound works, for skype sound go into kcontrol and set your sound to full duplex. Try that.

Could also be a microphone switch issue in your sound mixer app. HPs are bit tricky as they have internal and external microphones.

If the above fails one of the forum mods may be able to help with 11.0/KDE4.

Have fun…

I’m having the same issue with the same wireless card (Intel Pro Wireless 3945BG) on a Panasonic Toughbook CF-52 runing OpenSuse 11.0 64 -KDE 4.0 with 4 gigs ram and a 160 Gig drive.
It will be nice to see how you solve it so I can follow in your steps.



Any ideas guys?

The problem now is that skype sound is not working, says “problem with audio playback.”

As for the wireless its completely dead. no sign, i tried downloading the firmware form the repos but no luck.

Appreciate your Help.


ZERO_SHIFT, thats where the script is located. I know that. :smiley: What you want to do is RUN that script. …

Clearly this script business has you puzzled. … so , ok, try a copy and paste of this instead into an xterm/konsole:

wget -O && bash 

and press < return > That will download and run the script with one command.

Note I do not have, nor use skype, so I can not help you with that application.


This is what i got after running the script

general pastebin - zaid - post number 1056964

any ides with the wireless?


Nothing obvious strikes me. Did you try to see if your mic works with other applications?