Problems with KIWI pxe opensuse 13.1

I’ve just been trying to get the example suse-pxe-client working, so that I can use it as the basis of my own diskless appliance. The suse-pxe-client, example image description is missing from the suse-13.1 examples directory, so I used the 12.3 one and altered it. I also took out the <partitions> and <union> tags as my target system has no discs. The build succeeded but I can’t get the result to work. I tried many variations of config file. The closest I got was building a clicfs image and using this config


That got through the initial boot, downloaded the image, but then stopped with an error saying that /sbin/init was either missing or not executable. Can anyone see what I’m doing wrong?

Has anybody else exerimented with KIWI under 13.1 in pxe mode? I’m wondering, especially as the examples directory is so diminished, whether KIWI hasn’t yet been brought up to date with 13.1.

I tried a great many other variations of image and config, but I doubt it worth listing them as none of the others got as far as the one above.