Problems with hyperthreading Pentium 4 (640)


I have a problem with openSUSE 11.0 freezing. Everything locks: graphics, mouse, keyboard. The computer is completely unresponsive and requires a hard reset. It normally freezes within only a few minutes of booting. The problem occurs with both 32-bit and 64-bit versions (currently using 64-bit).


Processor: Intel Pentium 4 (640)
Intel® Pentium® 4 Processor Numbers

Motherboard: Intel Deskboard D101GGC
Intel® Desktop Board D101GGC Overview

Memory: Super Talent D32PB1G25 1GB DDR-400 PC3200 (X2 – total 2GB RAM)
Super Talent Technology - DDR, DDR2, DDR3 Value Memory and Upgrade Memory

Audio: High Definition Audio subsystem using the Realtek* ALC861 audio codec (integrated with motherboard - configured as “IXP SB4x0 High Definition Audio Controller” and with driver "

Video: NVidia GeForce 7300 GT (configured with NVidia driver NVidia YAST repository)

I have found that disabling hyperthreading in the BIOS prevents the freezing. I would prefer to leave it enabled if there is any possible way to be able to take advantage of it in openSUSE without the problems. Additionally, I also dual boot my computer with Windows, and would like to keep it enabled for the other operating system.

Alternatively, I have found that boot loader option acpi=off will prevent the computer from freezing. The problem with that is when I set that boot loader option, the sound from the sound card is a never ending loop whenever there is a sound event (the first second or so of the sound keeps playing over and over again until sound system is restarted). I tried disabling the onboard sound and using an Audigy 2 ZS. Unfortunately, the sound didn’t work, and my searches indicate that many people have reported problems with the card and no solution so far as I have been able to find. Oh well :stuck_out_tongue:

I have found a little here and there indicating that SMP needs to be compiled; however, recent kernel versions (as I understand from the reading) of openSUSE have it enabled without the need for a specific smp kernel (again, if I understand correctly).

Hyperthreading Enabled? - openSUSE Forums

I recall that I had a previous computer that also ran a Pentium 4 with HT. I had trouble with it freezing with 10.3, but it worked fine with 10.2. I hadn’t found anything on HT at that time, nor did I try to disable HT in my BIOS on that computer.

Has there been a fix for this (in case this is a fixed/fixable bug, and I just haven’t searched the right places).

Any help or suggestions would be greatly, greatly appreciated.

If disabling ACPI fixes some problems, go into BIOS and see if there is an option to disable the ACPI 2.0 tables or similarly named. You’ll still have ACPI, just an older standard. That fixed several odd problems I’ve had.

Hi folks,

Since my original post in this thread, I tried looking in my motherboard BIOS for ACPI settings; however, my BIOS doesn’t have those settings. Well, except that the motherboard “info” about hyperthreading enable/disable said that ACPI is auto when hyperthreading is enabled, and manual when disabled. But, there were no specific ACPI user selectable settings in BIOS (so, I’m guessing that auto or manual referred to the instaled OS – but don’t hold me to that).

One thing that I forgot to mention in my first post was that the clock date and time did not match the system date/time when hyperthreading was enabled, and it was fine when it was disabled. When hyperthreading was enabled, I could not change the date/time.

I tried recompiling the kernel changing processor type from generic x86_64 to P4. That didn’t work. I tried installing a new kernel from, and that didn’t work either. When I compiled a new kernel, I used make oldconfig, and again tried P4 instead of generic x86_64.

I compiled software both while hyperthreading was enabled as well as disabled. When hyperthreading was enabled, I noticed that I received a lot of warnings about time syncs while compiling. Anyway, I tried other distributions. I haven’t been able to make it through the installation without hard freezing, crashes, and so on. I tried Kubuntu 8.04.1. I have had good hardware compatibility in the past with Kubuntu; however, Kubuntu wasn’t compatible with my processor, either. During the crash of the installer, I did see a bunch of errors. I hate that I don’t have any sort of screenshot or camera shots to share, and I wish I would have thought to write some of them down. Some of the errors were I/O errors, buffer errors, errors relating to not being able to access RAM, and CPU frequency errors.

I might be inclined to suspect that perhaps that the processor itself may have been flawed or damaged if it weren’t for the fact that it worked perfectly well for the other installed OS (Windows XP).

I reinstalled my older Celeron D processor. There’s no HT, of course, but it at least supports 64-bit, so that’s a bonus. openSUSE 11.0 has been running just fine now without any freezes or problems.

For the time being considering that no Linux OS would install, I’m chalking it all up as an unsupported processor. Granted, even though I can recompile and install new kernels, I’m not highly experienced at tweaking the kernel especially in situations like this. If anyone has anything tips or ideas to share, please do. I’d be interested in knowing what I could have done to get the processor working with HT.