Problems with HPLIP

Hello! I recently installed LEAP 42.3 on a DELL Vostro 220 box (Celeron 450 CPU @2.20 GHz; 2 GiB RAM; 75 GiB WDC disk). I have an older (LaserJet M1522nf MFP) Hewlett Packard printer, which I have installed several times on other versions of openSUSE (starting about 9.0, as I recall). I have always used the “HPLIP” utility to manage this printer, usually with very few problems.

When I tried to install the printer in LEAP, bad things happened. The first thing I tried was to install HPLIP with YAST2, and to run it as a standalone app. That worked OK, up to a point. I could locate the printer on the local network, and I could download the drivers from HP. I even got HPLIP to ask for root privileges. But when it tried to install the drivers, it got stuck in an infinite loop. So I tried to fire it up from inside YAST2 (a button in the lower right of the “Add Printer” dialog, “Run HP-SETUP”) – that also got stuck in an infinite loop. I finally installed the printer using a generic PCL6 print driver for HP LaserJet printers, and that worked after a fashion. but I couldn’t actually print anything … the print queue in CUPS was there, but it was paused. And the only way I could get the print queue started was to uninstall HPLIP. Then I could print things. Oh yeah – the .rpm for HPLIP is version 3.16.11.

I wasn’t real happy with this, so I did a bit of digging around on the web and found this page (be careful – the download launches automatically). I downloaded the package, followed these instructions, and managed to compile and install version 3.17.11 of HPLIP, which now works like a champ. I was really impressed by the .run package from SourceForge. It verified that I was running LEAP 42.3, checked for missing libraries / option packages, downloaded the missing software and installed it, removed a few bits of HPLIP 3.16.11 that YAST2 had apparently left lying around somewhere, compiled the new program, and installed it. The new version runs the way it’s supposed to, although I can’t invoke it from the icon in the system tray. But it’s on my launcher menu, and I now have the correct printer drivers installed in the database where YAST2 can find them. It even updated /var/log/Zypp/history.txt so I’ve got a log of the actions it performed.

Has anyone else had problems with HPLIP? Is there some way to incorporate version 3.17.11 (or some other recent version, better than 3.16.11) in LEAP 42.3? Or is that part of what I gave up by abandoning Tumbleweed? Will we have to wait for 42.4 to get an improved HPLIP? I think I’ll be happier with a system that doesn’t update 400 or 500 software packages every single day … the base system (Tumbleweed) seemed OK, but the applications seemed pretty buggy – features would come and go, seemingly at random.

Any and all feedback is appreciated. Thanks!

I’ve not had problems with HPLIP but I use the most recent version by including the repository:

Thanks for the tip. I did that, and now I see that the .rpm for HPLIP in YAST2 is up to 3.17.9. I guess there’s a lot to keep up with around here. :slight_smile:

I find it annoying. I have a laserjet M201. I was able to get that working in 42.2 without needing HPLIP. But I could not get it to install in 42.3 until I installed HPLIP.

And, after that, there’s an HPLIP applet in the Plasma 5 tray. And that seems to block “gapcmon” from starting properly (that’s the monitor for an APC UPS). I eventually found out how to stop the HPLIP applet from starting, and now “gapcmon” is happy again.

Well, I’m sorry to hear about your problem, NRickert. I haven’t had a UPS in years. I put one on my very first PC back in 1995: I was mainly concerned about voltage surges harming my PC. By the time the battery needed replacement I had a new PC, and a lot more confidence in the electric company. Are you monitoring a whole network, or something? If you just have a few PCs at home, as I do, a real-time monitor sounds like overkill. If there’s a power failure, I know about it, monitor or no. <g>

The main reason I like HPLIP is it (usually) speeds installation of an HP printer. The distro has to contains drivers for a lot of different printer manufacturers, and a guy could grow a beard waiting for YAST2 to build the entire list of available print drivers. HPLIP finds the right driver in about two seconds. That, plus HPLIP gives you better control of unique printer features than you’re likely to get through a bare-bones CUPS setup. But every Linux user is unique: there are no Bosons in this bunch!

One of the issues I’ve met dozens of times when helping out people with HP printers:

  • the hpijs driverset is already installed by default. These drivers do not always work, or do not provide all the options the user expects. Crippled is the word that comes to mind. Besides that the list of drivers is far from complete.
  • So one installs the hplip packages and runs hp-setup as root. Printer gets discovered, ppd gets selected, but it’s the one from the hpijs packages, so …

To work around this, one can uninstall the hpijs packages, or make sure the hplip driver is selected ( IIRC ‘cups’ in the ppd name ). Never had to leave without a working printer though.

Yes, Knurpht – I learned that lesson long ago. I’ve been running some version of OpenSuse since 2002. Even on openSUSE 9.0 finding the right print driver was a chore. I don’t remember when I discovered HPLIP. Probably 10 or 12 years ago. It was so much better than relying only on YAST. This is the first time I couldn’t get by with the version of HPLIP that came with the distro: I’m not sure why it got hung in an infinite loop, but at least it works now. Oh – when I finally got HPLIP to work i had already installed the printer via YAST with a generic driver, so I had two printers installed in CUPS. I deleted the generic version , and now it all looks pretty clean.

I’m also pleased that scanner support for my multi-function printer has been incorporated into openSUSE. I found two separate programs (Xsane and Skanlite) that work OK – I still need to familiarize myself with the programs, but I’ve tried them both, and both of them work. Hurrah!

Simple Scan is worth a look IMHO. Although part of gnome, I think, I’ve been using it with KDE and found it easier than the other two. Site is Simple Scan in Launchpad but it’s in openSUSE repos IINM (I’m still running oS 13.2).

Simple scan is superb for scanning to PDF and also easy to change from portrait to landscape in the PDF output. Skanlite is much better when you want a particular image resolution. However, for real control of image scans, simply run xsane by calling it from the HP Device Manager.

…and multi-page scanning support. It’s my scanner front-end of choice too.

Using Leap 42.3, had problems with Duplexing on HP 4650.
Switched to hpcups 3.16.11 (from hpijs 3.16.11) and Duplexer Option showed in All Options for Current Driver. Set it to DuplexNoTumble, and now it works.