Problems updating Tumbleweed

I’m getting blocked updating Tumbleweed. I need advice on how to proceed.

–terminal output–
Problem: the to be installed libopenssl-devel-3.0.7-1.1.noarch requires ‘libopenssl-3-devel = 3.0.7’, but this requirement cannot be provided
not installable providers: libopenssl-3-devel-3.0.7-3.1.aarch64[]
Solution 1: Following actions will be done:
keep obsolete libopenssl-1_1-devel-1.1.1s-2.1.aarch64
keep obsolete libopenssl1_1-1.1.1s-2.1.aarch64
keep obsolete libopenssl-devel-1.1.1s-1.1.noarch
keep obsolete openssl-1.1.1s-1.1.noarch
keep obsolete openssl-1_1-1.1.1s-2.1.aarch64
Solution 2: deinstallation of libopenssl-1_1-devel-1.1.1s-2.1.aarch64
Solution 3: deinstallation of libopenssl-devel-1.1.1s-1.1.noarch
Solution 4: break libopenssl-devel-3.0.7-1.1.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/4/c/d/?] (c):
–end terminal output–

I did during the weekend into the same problem and did chose I think 3 or otherwise 2.

After that I did run into:

But if you do not have a VPN you will not run into that problem and also if you have a VPN with up-to-date certificates you will not run into the problem. I did contact my VPN provider and they could provide me with updated certificates which would not have triggered the problem.

That you need to ask the question suggests you are not a developer, and thus have no use for any -devel packages to remain installed. Choosing any solution that involves -devel package deinstallation should fix you up. :slight_smile:

Presumably you don’t need libopenssl-devel. When I was asked the above embarrassing question I removed libopenssl-devel and successfully reran zypper dup.

Thanks for the replies lads.