Problems on burning ISO to USB thumb drive for system installation

Hello everyone,

I still have some problems on burning the installation DVD ISO Image of openSUSE Tumbleweed to a USB stick for system installation. I have asked a similar question before: https://forums.opensuse.org/showthread.php/523743-Cannot-boot-from-usb-to-install-openSUSE-Tumbleweed-on-T470s/ But it only works partially, sort of.

I tried several times last week when I needed to reinstall the system to a new hard drive. Here is a summary first and then some logs. Please help me to find out why the dd command does not working for my situation.

1. The summary.

The installation uses EFI boot, testing with “secure boot” enabled and disabled.

Here, “works” means I can boot from the USB stick and enter the system installation screen; “failed” means the screen turns to black for 1 second or two then flashes back to EFI boot menu (all the tested failed situations are the same for me).

The computer is a new model of Lenovo ThinkPad T470s with USB 3.0 port. The computer has Windows 10 pre-installed and I was trying to install a dual boot openSUSE with it. “Fast boot” of the pre-installed Windows 10 has been disabled specifically. The USB drives I tried are 8GB, 16GB and 64GB Kingston DataTraveler G4. In some cases, the USB stick is re-formatted to narrow down the factors. The ISO image is openSUSE-Tumbleweed-DVD-x86_64-Snapshot20170429-Media.iso.

Burning methods I used include,

  • dd
# umount /dev/sdc
# dd if=openSUSE-Tumbleweed-DVD-x86_64-Snapshot20170429-Media.iso of=/dev/sdc bs=4M status=progress; sync
  • cp
# cp openSUSE-Tumbleweed-DVD-x86_64-Snapshot20170429-Media.iso /dev/sdc
  • SUSE ImageWriter (graphic)
  • ImageUSB (on Windows)
  • Rufus 2.14 (on Windows) (including 2 modes: ISO image and DD image)

For me, only Rufus 2.14 with ISO image mode works on all 3 USB sticks with and without “secure boot”. All other methods, including the Rufus with DD image mode, failed.

I think, all the methods using dd or dd like mechanism do not work for my situation. But I don’t understand the reason. Or,how could I make something like dd work for me? If I understand correctly, the dd command indicates a very fundamental operation which should work under most, if not all, situations.

I have even tried to dd an ISO image of the KDE Live CD on one of the USB sticks mention above. It doesn’t work either.

2. Some logs
2.1 fdisk of the 64GB drive after using cp

Disk /dev/sdc: 58.6 GiB, 62932647936 bytes, 122915328 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x50e24707

Device     Boot Start     End Sectors  Size Id Type
/dev/sdc1        3824   11635    7812  3.8M ef EFI (FAT-12/16/32)
/dev/sdc2  *    11636 8138751 8127116  3.9G 17 Hidden HPFS/NTFS

2.2 fdisk of the 8GB drive after using dd

Disk /dev/sdc: 7.2 GiB, 7736072192 bytes, 15109516 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x50e24707

Device     Boot Start     End Sectors  Size Id Type
/dev/sdc1        3824   11635    7812  3.8M ef EFI (FAT-12/16/32)
/dev/sdc2  *    11636 8138751 8127116  3.9G 17 Hidden HPFS/NTFS

2.3 fdisk of the 8GB drive after using ImageUSB on Windows

Disk /dev/sdc: 7.2 GiB, 7736072192 bytes, 15109516 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x50e24707

Device     Boot Start     End Sectors  Size Id Type
/dev/sdc1        3824   11635    7812  3.8M ef EFI (FAT-12/16/32)
/dev/sdc2  *    11636 8138751 8127116  3.9G 17 Hidden HPFS/NTFS

3. References I have read and followed

Best wishes,
CnZhx

Looking at your dd command there is no path to the iso that you are copying. I’m not sure where dvds’s mount but probably off /media or /run/media either maybe followed by a user name. You could use a file manager to browse and see where it is and make sure it’s named as you think it is.

This and some other methods are shown here
https://wiki.archlinux.org/index.php/USB_flash_installation_media

I had the same problem creating a bootable Knoppix usb stick :wink: and then noticed that the iso had a utility to create one.

John

Thank you, John, for your response on my post. I am sorry for that I have not used the original CLI commands here without proper explanation and this caused some misunderstanding.

I thought one does not need to mount the ISO file when using dd to burn it to a USB stick. Am I right on this? The command I showed above is just for the format. I have cd-ed to the right directory for locating the ISO file so there is no path in the command.

Thanks for this suggestion. I should’ve included this one as a reference above. This is a good one and I have a thorough reading on this.

As I stated at the beginning, I can use “Rufus with ISO image mode” to create a USB drive for system installation and have succeeded with “secure boot” of EFI enabled and disabled.

My problem is the dd made USB stick cannot boot into the installation screen.

Regards,
CnZhx

You do not require an absolute path, a relative one (to your working directory) is OK of course. This is one reason that we advise to copy/paste what you do complete: prompt, command, output, next prompt. In this case we e.g. could have seen your working directory from your prompt, possibly that would have avoided ajohnw’s confusion.

And of course you do not “burn” anything, you just copy a file.

Thanks Henk for your advice on providing a complete commandline output. I’ll try to do it better next time.

You’re absolutely correct on this.

I did not really be of any help to your problem. That is because I think the way you create the bootable install device (with e.g. the dd command you used) is correct. Thus it comes down to the details of booting it. EFI vs. non-EFI, Secure. vs. not Secure, etc. I am not that good a these boot details and hope that others will join here to try to analyze that.

The other problem I had with my Knoppix bootable stick was bios settings. It crops up way down the list as a blank space as I haven’t added a label to it. It took some bios setting changes to get it appear in the legacy section of the boot menu and then it did boot.

This link gives some detail about secure boot.

https://wiki.archlinux.org/index.php/Secure_Boot

I’m not sure if opensuse iso’s even use secure boot. I installed leap from a dvd but can’t remember which bios boot section it was booted from.

The only thing I can add to the other archwiki link is that lsblk will show which sdx the usb is located on and as they mention it must not be a partition. :wink: I dug the link out for next time I need to do one.

John

Secure boot should work ok once installed but on some machines you need it off during the install. Not all UEFI are made the same.

Your lines to do the copy look ok and so does your partitioning. So more info on exactly where in the install things fail. Any modification to the ISO to use syslinux or other boot helpers will not work. Only a plain binary copy to the device. I use the cp command all the time without problems.

Hi Henk, your comments are valuable not only on this topic but also on the long run although it’s not specific to my problem.

I will detail other things such as EFI vs. non-EFI, Secure. vs. not Secure later in this post.

Hi John, your comments remind that I should state that I don’t want Legacy boot but only EFI boot, with or without secure boot. I am not sure about the problem because I can boot and install the system with the USB stick made by using Rufus with ISO image mode but not others.

For what it worth, I have tried with secure boot both on and off, and both configuration work on this same USB stick I made. However, other USB sticks won’t work either with secure boot ON or with secure boot OFF.

So I guess openSUSE does support secure boot because I installed my current system with secure boot ON and it is still on at present.

Hi gogalthorp, you have helped on this topic on the other thread which I posted initially when I was trying to install this system. I will elaborate this topic a little more below.

========== Add some details on my problem. ==========
First, I think, after all the way down to this point, I do not have problem with the command line regarding to dd or cp to made a bootable USB stick with the installation DVD ISO image. As you can see, the fdisk -l outputs show that the USB stick “should” work.

Second, on secure boot ON vs OFF, and EFI vs Legacy boot. I need to clarify that I only want EFI boot, so Legacy mode is not an option here. Unless, the dd made bootable USB stick, or to say the installation DVD ISO image will not work for EFI mode. It does work for EFI mode, right?

Third, I have already tried the USB stick which was made using Rufus in ISO image mode. This USB stick can be used under EFI boot with secure boot ON and OFF. So, secure boot seems not a problem here. Unless, the dd made bootable USB stick, or to say the installation DVD ISO image will not work for EFI secure boot mode which I think is not true.

So, the problem seems to be related to the difference between the way Rufus making bootable USB stick using installation ISO image under ISO image mode, and the way dd binary copying the ISO image to a USB drive.

Thank you all for your discussion. I really appreciate them.

Regards,
CnZhx

I made no conscious decision to use secure boot on the machine that I was installing on but that is what the install did to the machine - caused it to use secure boot when leap is booted. I understand that if windows is to be dual booted the linux boot must be secure otherwise windows will be unavailable. It may be optional on some distro’s.

I use an HP workstation so things on that are likely to be different. There is more than one boot from usb for instance. From what I am reading here it sounds like some machines have the ability to turn the need for a secure boot on and off. Mine doesn’t work like that. What can be booted shows in a different section of the bios’s boot from table. I think the sections start secure, not secure and then legacy support. The Knoppix bootable usb stick I mentioned is also intended to run Knoppix rather than install it. I boot it from where the bios decides to put it. In this case the 2nd lower boot from usb option. I’d need to reboot to check but think that needed the other usb boot option to be disabled.

From an installation point of view I can’t see why what ever is used needs to use secure boot. It’s only going to be booted when it installs. Knoppix is a little different. It’s main purpose is to run live from either a dvd or a usb stick for maintenance and recovery work on another linux pc but I believe it can be used for the same on windows. It mounts all of the disks on a machine under /media. When it created the usb stick for me from the dvd I suspect it used dd. I’ve seen no signs of a separate utility in it. Actually it runs faster from the dvd so I have some usb3 sticks on order.

John

Secure boot is not the point here. I just mention it to make it clear that the problem is not caused by “secure boot” feature of EFI boot. Also,
“secure boot” seems not mandatory to the boot of Windows. At least in my case, I can disable secure boot and then boot the Windows 10 on that machine. And after that, I can enable “secure boot” again without problem.

I don’t get your point on mention Knoppix. My problem is about making a USB bootable installation media from the DVD ISO image of openSUSE Tumbleweed since I have no DVD drive in my machine. And I believe the ISO image of openSUSE Tumbleweed supports EFI boot. Additionally, it can be booted with secure boot ON or OFF.

By default refus modifies the iso image to use sysLinux as a boot loader this breaks a openSUSE installer but may be needed by some other distors. There is a pure binary copy dd mode apparently that does no mods to the iso and thus should work. Your claim that dd and cp as you wrote the commands does not work seems very strange in the experiences recorded in numerous threads here. Personally I have always used cp and it has worked every time. So I’m very confused.

Yes a DVD install will work in EFI mode if again you boot the DVD in EFI mode. For most hardware secure boot should not be a problem but in some cases it is so turn off if it is a problem but check the secure boot option in the installer and once installed you should be able to turn it back on if you really feel it is needed. The box must be checked if you plan to use secure boot but you can boot with the box checked and secure boot off.

So, the ISO image mode of Rufus makes a bootable USB drive. This USB drive uses sysLinux to load the content (or maybe it’s better to call it the installer) in the ISO to install the system. Am I right about this?

But the dd or cp or DD image mode of Rufus makes a binary copy of the ISO image to the USB drive. Then the USB drive works like a packaged USB DVD drive. Am I right about this?

So maybe the problem is, in my machine, the mainboard does not accept the emulation of a USB stick as a USB DVD drive. Is this right?

If the above understanding is not wrong, I think I need to find another computer to test my dd made USB stick to find out whether this is the restriction of the mainboard or the BIOS or not.

Thanks for the clarification. It’s agree with my observation.

Nope the openSUSE iso is boot ready on either DVD or USB. Does not need or want sysLinux added. Never even tried Rufus so have no idea of the options or how they are phrased. There is no real difference between what a system sees on a bootable USB and a DVD. The logical layout is the same and the hardware/firmware makes allowance between the different media type.

I had a thought though USB 3 ports sometimes cause problem with some devices and OS. Is the USB port you use USB2 or USB3???

As per the explanation from the developer [1], “DD (Image mode) is an exact clone of the image onto the USB”, while “ISO Image mode” is to “partition and format the USB in a way that Windows can always understand (and using the whole capacity of the drive), and then copy each individual file and directory from the ISO image onto the newly created file system”. I think the DD mode is the same as using dd command on Linux.

My machine has only USB 3 ports. But it’s a new type with Intel i7 7600U CPU. I thought it would have no support issue with USB 3.0 port despite that I’ve heard USB 3.0 port on less new machine had problem to boot with.

I guess I need to test the dd made USB stick on other machines to at least make sure my way of creating the USB stick is correct although I don’t think this could be a problem.

[1] https://github.com/pbatard/rufus/issues/843#issuecomment-255680876

THe image must be copied to a device not a partition on the device you need the embedded partition tables to copy to the device this does not happen if copied to a partition

This is what he posted in post #1 of this thread: dev/sdc.

Yes, I am sure this is not a problem here. I started to thinking that maybe this is restricted by the hardware or BIOS/EFI. I will try to borrow other machines to test the USB drive.

Hi Henk, you have a photographic memory :slight_smile:

Yes but then the last post confuses this and speaks of copying to a partition. The original post shows correct commands but then he says this does not work but rufus works but then says that rufus copies to a partition. Don’t use Rufus so have no idea how it works but do know that originally it modified the iso by adding sysLinux before doing what ever it does. I also understand that a dd mode ie straight binary copy has been added to it which should work. I also know that in the past some “Linux boot helpers” modified the iso itself before copy so maybe a test to the check sums should be done again to assure the iso image has not been changed.

If working from Windows use http://www.osforensics.com/tools/write-usb-images.html

If from any Linux use dd or cp to the unmounted device. This has worked for me since started using USB as install media

Correct, use dd (or cp). I have no idea while that whole Rufus discussion was started. He did dd correct and he can’t boot it. That is the kernel of the problem imho.