Problems connecting with OpenSUSE 11

I have been using Ubuntu for quite a while and decided to take a look at OpenSUSE 11. I’m very impressed and would like to switch to it full-time (KDE4 rocks). However, I’m having problems with network connections. I have an Intel 3945ABG wireless card and integrated Intel gigabit ethernet card. Output from lspci

00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

I can connect fine with Ubuntu 8.04. However, OpenSUSE won’t autoconnect to anything, wired or wireless. If I use ethernet, I run dhclient, which gives me a valid IP address, but I don’t have a connection (Firefox won’t connection, etc.). KNetworkManager also still shows that it is not connected. For wireless, the problem is worse. It won’t list any networks, even when I try to create a new connection. However,

iwlist scan

returns several entries, including the network to which I want to connect.
Could someone help me get connected? I would like to use Knetworkmanager, but the command line would be acceptable.

Thanks for all the help.

I’d bet the problem with your wired connection is the lack of a default gateway. If you type the following command:

/sbin/route -n

It will return some output. The last line of the output should look something like: UG 0 0 0 eth0

If you do not have an entry for in your routing table, you do not have a default gateway set and thus you cannot route.

I would suggest using YaST to do you network configurations. You can use command line tools such as dhclient, but issues like this arise. The easiest way to configure your network connections is to go under Network Devices -> Network Settings in YaST.

The wireless can be tricky. The fact that your wireless is seeing nodes using iwlist scan means that it is working with the OS. I use the little connection manager tool in the taskbar and it seems to work well for me. I’ve also been told that if you configure your wireless in YaST similar to your wired connection it works as well. Just be careful about your WEP key length. I’ve made the mistake of using the wrong key length (128bit instead of 64bit) and it caused me quite a headache.


thanks for the help. I’m thinking it’s a problem with knetworkmanager because once I rebooted everything works fine. Must be something with the Novell-Microsoft deal; random reboots fix Linux now? It’s very spotty though. I tried what you suggested but could really identify any settings. Besides DHCP, there aren’t any settings that I could tell that would do anything.

so u like insulting the linux distro u want to switch to? this coming from a person who uses ubuntu, a distro which has done almost no innovation in the linux world whatsoever. If u don’t believe me why not go check your self.

knetwork manager is a kde 3 app, I think u know that right? kde 3 apps and gnome apps r still having trouble with kde 4

I would check to ensure in the Network settings, under the Hostname/DNS tab that you have the option at the bottom “Update DNS data via DHCP” selected. Also, in the global options, ensure that the IPv6 is disabled unless you really need it.

just go to yast and network devices then network services and u can configure anything u want