Problems changing channels in kaffeine in 11.2


Changing TV channels in kaffeine worked fine in 11.1 with my dvb-t card Hauppauge HVR-4000

After loading 11.2 from scratch I cannot easily change TV channels.
After formatting and downloading 11.2, I followed the guide “Multi-media and Restricted Format Installation Guide” in the “new user howto”

kaffeine hangs - freezes when i try to change channel.
It hangs until i press a button, and then it comes with an error message:
“Cannot find demultiplexer plugin for the given media data”

Then if I try afgain - it works and the new channel comes up.

As a workaround, I can push the stop button in order to stop the current TV channel.
After this, I can change to a new TV channel without problem.

I noted that in 11.1 kaffeine briefly displays “pause” when changing TV channels.

It seems to me as a timing problem somewhere


jens Elmo

Installing ffmpeg seems to solve that matter.

I am using ffmpeg 0.520358 loaded from packmans repository for OpenSuse 11.2
I also tried downloading ffmpeg directly from
Still same problem

Same problem here with kaffeine4 on 11.1 kde 4.3.1 release 183. Kaffeine4 is still in beta, though.
Let’s hope it’s fixed soon.

Just loaded suse 11.2 with dvb option and avermedia a180 HD card. Kaffeine will not scan any channels. Strange because it worked very well in suse 11.0 :frowning:

Have you installed the dvb tools and ffmpeg? Can you scan from the
command line eg?

scan /usr/share/dvb/atsc/us-NTSC-center-frequencies-8VSB

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 17:22, 2 users, load average: 0.22, 0.21, 0.20
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

I have been trying to copy the channels.dvb file from my working 11.0 to 11.2 and Kaffeine 1. No can do.I have been reading the new improved Kaffeine bug reports . Well apparently. They have screwed things up with a new file structure. Just yesterday I was saying Kaffeine is the best dam software I have ever seen, it would play any file I threw at it. Today nada!!! too bad. I guess i will have to find something else that works.
FFMPG thanks. I will give it a try

You have the opportunity to install the KDE3 version of kaffeine alongside. It will pull in some libs but that won’t hurt.

When I do a manual scan in terminal it fails.The problem probably has nothing to do with Kaffeine !

mick@linux-t6vx:~> scan /usr/share/dvb/atsc/us-NTSC-center-frequencies-8VSB
scanning /usr/share/dvb/atsc/us-NTSC-center-frequencies-8VSB
using ‘/dev/dvb/adapter0/frontend0’ and ‘/dev/dvb/adapter0/demux0’
>>> tune to: 57000000:8VSB
WARNING: >>> tuning failed!!!

Like everthing works great in 11.0 . So if it ain’t broke don’t fix it.I will play with 11.2 on my laptop and the modem challenge !!!

The warning is normal, just keep an eye on it to see if it’s finding
active channels. If it didn’t start scanning then there would be an
issue with the hardware.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 12:14, 2 users, load average: 1.25, 0.57, 0.24
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Hi Malcolm.

Thanks for the help. This is some sort of kernel problem with the ntx200x front end. nxt200x: Timeout waiting for nxt2004 to init.

It’s common with the latest linux kernel and the Pro’s seem to be working on it. Something about buffer this and buffer that, the man said. Just have to be patient and wait for a patch.

I have the same problem. When I try to change channel not works. And the second time works correctly. :’(

Wait, wait, wait… for a new Kernel or patch kernel.

I have a avertv hd a180 card. I got it working in the latest Mandriva with help from This card needs the firmware file dvb-fe-nx2004.fw in the /lib/firmware in order to function. The new kaffeine also needs phonon-xine.
Bad news is. It is still not working in Suse 11.2.:’(
Kaffiene reports it cannot find the demultiplxer ?


The xine library provided by Suse has a lot of plugins missing because of software patents (for example, all mpeg related plugins). It’s recommended to install a “full” xine library that can be found at PackMan :: Startseite, too.

I have the exact same problem too. I’m using a Hauppauge PCI Nova card. Worked fine under 11.1 with the kde3 version of kaffeine. On the second attempt it works, but still a bit annoying.

Same problem and same card (Hauppauge 4000)… work in Opensuse 11.1 and don’t work in opensuse 11.2. Only fails in the firts time and before works. :’(

Any ideas?

That’s the one I still use. I tried Kaffeine 4 many times, even recently but it lacks a lot of features and is just not there - still has a long way to go.
The KDE 3 version of Kaffeine works fine. Pity that it doesn’t match the KDE 4 desktop.

Same problem in opensuse 11.3 so i think the problem isn’t kernel…