Problem with Yast

I have just installed SUSE 11.0. Everything installed without problem and seems to be working well except YAST.
When I open YAST I am asked for my Root password. After typing it in the cursor bounces several times, stops, and nothing opens. No error messages, no YAST page, nothing except the desktop.
Can anyone help me get to YAST?


Run the command ‘yast2’ (no quotes) from a console as su (root). Any error messages?

I ran yast2 from a terminal and the message that returned was “Command not found”

Are you sure you became root first with su command? What do get when you do rpm -qa |grep yast2 ?

To clarify this a bit, open a terminal console and type:

**su - **
(enter the root password)
yast2 &

If this works it could be a problem with the sudo (/etc/sudoers) setup.

> SU -
> (enter the root password)
> YAST2 &

yep, there is a difference between ‘su’ and ‘su -’

but, there is also a difference between ‘su -’ and ‘SU -’

so, i wonder why you tell him to use capital letters??

DenverD (Linux Counter 282315)
A Texan in Denmark

Ehm, well, because I’m not?!

The letters are bold, not capital!

I’m seeing 'su - ’ and ‘yast2 &’ here… ? … a small NNTP glitch maybe? :wink:


> I’m seeing 'su - ’ and ‘yast2 &’ here… ? … a small NNTP glitch
> maybe? :wink:

ah, yes…in fact i ran into that before but forgot about it…as i
recall i ran into it before i realized that the ‘new forum’ was more
than yet another newsgroup…

hmmm…perhaps there should be a “stickie” somewhere telling folks
giving command line directions to not use bold, but something else…i
don’t know what, but i do see (in nntp) something that looks like:


su -


is that more difficult to do on the web side than bold??

i ask, because anyone coming along via nntp are not gonna be helped by SU -

know what i mean, Gene?

DenverD (Linux Counter 282315)
A Texan in Denmark

Opening the terminal and typing “su” and “yast2&” results in the following message:
“Qt GUI wanted but not found, falling back to ncurses.”

Typing “su” followed by “yast2” (leaving off the “&”) results in a command line version of Yast.

Thanks to everyone who responded to my plea for help.


Hi Paul,

Probably easily resolved by installing the yast2-qt package.

In this case do it from the console with these commands:

su -
zypper install yast2-qt

Accept you want to install and after it has installed retry running YaST from the console.

Which DE are you using btw? (KDE, GNOME?)

It is strange that YaST doesn’t install all the items it needs… was it a fresh install or upgrade?

ps. is that better DenverD? :slight_smile:

> ps. is that better DenverD? :slight_smile:

yes…even the poor folks with slow connections in India (no broadband
to whisk down those beautiful web pages) can read the code

DenverD (Linux Counter 282315)
A Texan in Denmark

I must admit I hadn’t realised how the bold formatting would fail with nntp. Now I will avoid it. Makes me wonder what other web based formatting features get lost in translation. :slight_smile:

give the old fashioned way a try, and see…you might even like how much
faster it is…

DenverD (Linux Counter 282315)
A Texan in Denmark