Problem with volume control

I’ve lost control of my volume this morning. Sliding the bar left might might increase it, it might get muted, it seems arbitrary. I use GNOME Classic 3.20, but I’ve also tested it in KDE with the same problem. YaST lists 3 sound cards, and I’ve deleted and reset them there. I’ve logged off and rebooted, too. The volume control in YaST is also acting strange. Has anyone heard of this happening before? This is a serious problem for me, the music is very therapeutic,

You could try installing pavucontrol.

I could try that, but there’s a problem with the system. YaST, KDE and GNOME all have the same behavior.

I guess there’s a long delay, about 20 seconds. Anybody know what would be behind this?

Yea, that works. Thanks. I’d still like to get the system control working in the panel.

If you have something that works - then thats good news.

wrt the problem, I’ve read of different things that could be a cause, and honestly I do not know if any are applicable to you. Possibilities

  • enable-deferred-volume - with a Ubuntu thread (where in /etc/pulse/daemon.conf the entry “enable-deferred-volume = yes” had the " ; " in front removed the value changed from “yes” to “no” (followed by a restart of pulse)). However changing default settings can cause problems so this could cause other hiccups, or do nothing, or make it worse.
  • power management delaying start - again a ubuntu thread

As noted - I don’t know if those applicable to you. Further I have no experience with any, they are just articles I noted on the web.

I suspect there may also be other causes.

Thanks, oldcpu. Whatever was going on, it’s fixed today. I shut down the computer overnight, and I guess a cold boot did the trick. I’d be curious as to what was causing this, but I’m just glad it’s working now.